summaryrefslogtreecommitdiffstats
path: root/conf/layer.conf
diff options
context:
space:
mode:
Diffstat (limited to 'conf/layer.conf')
-rw-r--r--conf/layer.conf23
1 files changed, 15 insertions, 8 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
index 7a7283ca..97dfb897 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -10,15 +10,16 @@ BBFILE_PATTERN_intel := "^${LAYERDIR}/"
10BBFILE_PRIORITY_intel = "5" 10BBFILE_PRIORITY_intel = "5"
11 11
12# Additional license directories. 12# Additional license directories.
13LICENSE_PATH += "${LAYERDIR}/custom-licenses" 13CUSTOM_LICENSES_PATH = "${LAYERDIR}/custom-licenses"
14LICENSE_PATH += "${CUSTOM_LICENSES_PATH}"
14 15
15LAYERDEPENDS_intel = "core" 16LAYERDEPENDS_intel = "core"
16LAYERRECOMMENDS_intel = "dpdk intel-qat" 17LAYERRECOMMENDS_intel = "dpdk"
17 18
18# This should only be incremented on significant changes that will 19# This should only be incremented on significant changes that will
19# cause compatibility issues with other layers 20# cause compatibility issues with other layers
20LAYERVERSION_intel = "5" 21LAYERVERSION_intel = "5"
21LAYERSERIES_COMPAT_intel = "dunfell" 22LAYERSERIES_COMPAT_intel = "kirkstone scarthgap"
22 23
23BBFILES_DYNAMIC += " \ 24BBFILES_DYNAMIC += " \
24 clang-layer:${LAYERDIR}/dynamic-layers/clang-layer/*/*/*.bb \ 25 clang-layer:${LAYERDIR}/dynamic-layers/clang-layer/*/*/*.bb \
@@ -27,12 +28,18 @@ BBFILES_DYNAMIC += " \
27 openembedded-layer:${LAYERDIR}/dynamic-layers/openembedded-layer/*/*/*.bbappend \ 28 openembedded-layer:${LAYERDIR}/dynamic-layers/openembedded-layer/*/*/*.bbappend \
28 meta-python:${LAYERDIR}/dynamic-layers/meta-python/*/*/*.bb \ 29 meta-python:${LAYERDIR}/dynamic-layers/meta-python/*/*/*.bb \
29 meta-python:${LAYERDIR}/dynamic-layers/meta-python/*/*/*.bbappend \ 30 meta-python:${LAYERDIR}/dynamic-layers/meta-python/*/*/*.bbappend \
30 virtualization-layer:${LAYERDIR}/dynamic-layers/virtualization-layer/*/*/*.bb \
31 virtualization-layer:${LAYERDIR}/dynamic-layers/virtualization-layer/*/*/*.bbappend \
32" 31"
33 32
34require ${LAYERDIR}/conf/include/maintainers.inc 33require ${LAYERDIR}/conf/include/maintainers.inc
35 34
36PREFERRED_PROVIDER_zlib ?= "zlib" 35# Use the libva from OE-Core when layer is included but no MACHINE
37PREFERRED_PROVIDER_zlib-native ?= "zlib-native" 36# from meta-intel is being used.
38PREFERRED_PROVIDER_nativesdk-zlib ?= "nativesdk-zlib" 37PREFERRED_PROVIDER_libva ?= "libva"
38PREFERRED_PROVIDER_libva-native ?= "libva-native"
39PREFERRED_PROVIDER_nativesdk-libva ?= "nativesdk-libva"
40
41PREFERRED_PROVIDER_libva-utils ?= "libva-utils"
42PREFERRED_PROVIDER_libva-utils-native ?= "libva-utils-native"
43PREFERRED_PROVIDER_nativesdk-libva-utils ?= "nativesdk-libva-utils"
44
45# addpylib ${LAYERDIR}/lib oeqa