summaryrefslogtreecommitdiffstats
path: root/common/recipes-core/microcode/iucode-tool_2.1.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'common/recipes-core/microcode/iucode-tool_2.1.1.bb')
-rw-r--r--common/recipes-core/microcode/iucode-tool_2.1.1.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/common/recipes-core/microcode/iucode-tool_2.1.1.bb b/common/recipes-core/microcode/iucode-tool_2.1.1.bb
new file mode 100644
index 00000000..e98bca60
--- /dev/null
+++ b/common/recipes-core/microcode/iucode-tool_2.1.1.bb
@@ -0,0 +1,27 @@
1SUMMARY = "Update Intel CPU microcode"
2
3DESCRIPTION = "iucode_tool is a program to manipulate Intel i686 and X86-64\
4 processor microcode update collections, and to use the kernel facilities to\
5 update the microcode on Intel system processors. It can load microcode data\
6 files in text and binary format, sort, list and filter the microcode updates\
7 contained in these files, write selected microcode updates to a new file in\
8 binary format, or upload them to the kernel. \
9 It operates on microcode data downloaded directly from Intel:\
10 http://feeds.downloadcenter.intel.com/rss/?p=2371\
11"
12HOMEPAGE = "https://gitlab.com/iucode-tool/"
13BUGTRACKER = "https://bugs.debian.org/cgi-bin/pkgreport.cgi?ordering=normal;archive=0;src=iucode-tool;repeatmerged=0"
14
15LICENSE = "GPLv2+"
16LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
17 file://iucode_tool.c;beginline=1;endline=15;md5=5d8e3639c3b6a80e7d5e0e073933da16"
18
19SRC_URI = "https://gitlab.com/iucode-tool/releases/raw/master/iucode-tool_${PV}.tar.xz"
20SRC_URI[md5sum] = "306d20b43da847812af4bf973f46045d"
21SRC_URI[sha256sum] = "8f94ec73f5d4d1a6801aaa894fa1c6544d9b27aec16e1a00e18e8241c7e0f6ba"
22
23inherit autotools
24
25BBCLASSEXTEND = "native"
26
27COMPATIBLE_HOST = "(i.86|x86_64).*-linux"