summaryrefslogtreecommitdiffstats
path: root/common/recipes-bsp/thermald/thermald_1.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'common/recipes-bsp/thermald/thermald_1.6.bb')
-rw-r--r--common/recipes-bsp/thermald/thermald_1.6.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/common/recipes-bsp/thermald/thermald_1.6.bb b/common/recipes-bsp/thermald/thermald_1.6.bb
new file mode 100644
index 00000000..fe6d109c
--- /dev/null
+++ b/common/recipes-bsp/thermald/thermald_1.6.bb
@@ -0,0 +1,35 @@
1SUMMARY = "Linux thermal daemon"
2
3DESCRIPTION = "Thermal Daemon is a Linux daemon used to prevent the \
4overheating of platforms. This daemon monitors temperature and applies \
5compensation using available cooling methods."
6
7HOMEPAGE = "https://github.com/01org/thermal_daemon"
8
9DEPENDS = "dbus dbus-glib dbus-glib-native libxml2 glib-2.0 glib-2.0-native"
10DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES','systemd','systemd','',d)}"
11DEPENDS_append_libc-musl = " argp-standalone"
12
13LICENSE = "GPL-2.0"
14LIC_FILES_CHKSUM = "file://COPYING;md5=ea8831610e926e2e469075b52bf08848"
15
16SRC_URI = "https://github.com/01org/thermal_daemon/archive/v${PV}.tar.gz"
17SRC_URI[md5sum] = "d0cdba81b75d8dd304c10bf4663fb201"
18SRC_URI[sha256sum] = "c63ae1b031f2b4ce037441e7e9910d05405b540fe6668e156d32c56d5dfa7492"
19
20S = "${WORKDIR}/thermal_daemon-${PV}"
21
22inherit pkgconfig autotools systemd
23
24FILES_${PN} += "${datadir}/dbus-1/system-services/*.service"
25
26SYSTEMD_SERVICE_${PN} = "thermald.service"
27
28COMPATIBLE_HOST = '(i.86|x86_64).*-linux'
29
30CONFFILES_${PN} = " \
31 ${sysconfdir}/thermald/thermal-conf.xml \
32 ${sysconfdir}/thermald/thermal-cpu-cdev-order.xml \
33 "
34
35UPSTREAM_CHECK_URI = "https://github.com/01org/thermal_daemon/releases"