summaryrefslogtreecommitdiffstats
path: root/common/recipes-bsp/rmc/rmc.bb
diff options
context:
space:
mode:
Diffstat (limited to 'common/recipes-bsp/rmc/rmc.bb')
-rw-r--r--common/recipes-bsp/rmc/rmc.bb20
1 files changed, 5 insertions, 15 deletions
diff --git a/common/recipes-bsp/rmc/rmc.bb b/common/recipes-bsp/rmc/rmc.bb
index f69b41a0..8c89a99c 100644
--- a/common/recipes-bsp/rmc/rmc.bb
+++ b/common/recipes-bsp/rmc/rmc.bb
@@ -14,33 +14,23 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=838c366f69b72c5df05c96dff79b35f2"
14 14
15SRC_URI = "git://git.yoctoproject.org/rmc" 15SRC_URI = "git://git.yoctoproject.org/rmc"
16 16
17SRCREV = "2e38d056f86c0457f3a5ca7ef848545bbb190e47" 17SRCREV = "4799cb89b543712390d863a6fc50a58881590fa2"
18 18
19S = "${WORKDIR}/git" 19S = "${WORKDIR}/git"
20 20
21DEPENDS_class-target = "gnu-efi"
22
23COMPATIBLE_HOST = "(x86_64.*|i.86.*)-linux*" 21COMPATIBLE_HOST = "(x86_64.*|i.86.*)-linux*"
24 22
25EXTRA_OEMAKE='RMC_CFLAGS="-Wl,--hash-style=both"' 23TARGET_CFLAGS +="-Wl,--hash-style=both"
26
27# from gnu-efi, we should align arch-mapping with it.
28def rmc_efi_arch(d):
29 import re
30 arch = d.getVar("TARGET_ARCH", True)
31 if re.match("i[3456789]86", arch):
32 return "ia32"
33 return arch
34 24
35SECURITY_CFLAGS_remove_class-target = "-fstack-protector-strong" 25SECURITY_CFLAGS_remove_class-target = "-fstack-protector-strong"
36do_compile_class-target() { 26do_compile_class-target() {
37 oe_runmake 27 oe_runmake
38 oe_runmake RMC_EFI_HEADER_PREFIX=${STAGING_INCDIR}/efi RMC_EFI_ARCH="${@rmc_efi_arch(d)}" -f Makefile.efi 28 oe_runmake -f Makefile.efi
39} 29}
40 30
41do_install() { 31do_install() {
42 oe_runmake RMC_EFI_ARCH="${@rmc_efi_arch(d)}" RMC_INSTALL_PREFIX=${D}/usr install 32 oe_runmake RMC_INSTALL_PREFIX=${D}/usr install
43 oe_runmake RMC_EFI_ARCH="${@rmc_efi_arch(d)}" RMC_INSTALL_PREFIX=${D}/usr -f Makefile.efi install 33 oe_runmake RMC_INSTALL_PREFIX=${D}/usr -f Makefile.efi install
44} 34}
45 35
46do_install_class-native() { 36do_install_class-native() {