summaryrefslogtreecommitdiffstats
path: root/common/recipes-bsp/gnu-efi/gnu-efi_3.0m.bb
diff options
context:
space:
mode:
Diffstat (limited to 'common/recipes-bsp/gnu-efi/gnu-efi_3.0m.bb')
-rw-r--r--common/recipes-bsp/gnu-efi/gnu-efi_3.0m.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/common/recipes-bsp/gnu-efi/gnu-efi_3.0m.bb b/common/recipes-bsp/gnu-efi/gnu-efi_3.0m.bb
new file mode 100644
index 00000000..252d49a1
--- /dev/null
+++ b/common/recipes-bsp/gnu-efi/gnu-efi_3.0m.bb
@@ -0,0 +1,34 @@
1SUMMARY = "Libraries for producing EFI binaries"
2HOMEPAGE = "http://sourceforge.net/projects/gnu-efi/"
3SECTION = "devel"
4LICENSE = "GPLv2+"
5LIC_FILES_CHKSUM = "file://debian/copyright;md5=5fb358a180f484b285b0d99acdc29666"
6
7PR = "r2"
8
9SRCREV = "74"
10
11SRC_URI = "http://downloads.sourceforge.net/gnu-efi/gnu-efi_3.0m.orig.tar.gz \
12 file://cross-compile-support.patch \
13 file://parallel-make.patch \
14 "
15SRC_URI[md5sum] = "d0a21125aee56c0c7291ad260e916cb3"
16
17S = "${WORKDIR}/gnu-efi-3.0"
18
19def gnu_efi_arch(d):
20 import re
21 tarch = d.getVar("TARGET_ARCH", True)
22 if re.match("i[3456789]86", tarch):
23 return "ia32"
24 return tarch
25
26EXTRA_OEMAKE = "'ARCH=${@gnu_efi_arch(d)}' 'CC=${CC}' 'AS=${AS}' 'LD=${LD}' 'AR=${AR}' \
27 'RANLIB=${RANLIB}' 'OBJCOPY=${OBJCOPY}' \
28 "
29
30do_install() {
31 oe_runmake install INSTALLROOT="${D}${prefix}"
32}
33
34FILES_${PN} += "${libdir}/*.lds"