summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-bsp/thermald/thermald/0001-Use-correct-format-specifier-for-size_t.patch52
-rw-r--r--recipes-bsp/thermald/thermald_1.9.bb (renamed from recipes-bsp/thermald/thermald_1.8.bb)2
2 files changed, 31 insertions, 23 deletions
diff --git a/recipes-bsp/thermald/thermald/0001-Use-correct-format-specifier-for-size_t.patch b/recipes-bsp/thermald/thermald/0001-Use-correct-format-specifier-for-size_t.patch
index 6897ffc1..eaa0da61 100644
--- a/recipes-bsp/thermald/thermald/0001-Use-correct-format-specifier-for-size_t.patch
+++ b/recipes-bsp/thermald/thermald/0001-Use-correct-format-specifier-for-size_t.patch
@@ -1,37 +1,45 @@
1From bb7631163c8f3f44d0dc83690765cdb799664fd5 Mon Sep 17 00:00:00 2001 1From dcdaf523393a6e7c07b5a510c573223722b0289b Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com> 2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Wed, 26 Sep 2018 10:34:15 +0800 3Date: Thu, 1 Aug 2019 08:15:52 +0800
4Subject: [PATCH] Use correct format specifier for size_t 4Subject: [PATCH] Use correct format specifier for size_t
5 5
6%zu instead of %lu, otherwise on 32 bit: 6%zu instead of %lu, otherwise on 32 bit:
7 7
8| ../git/src/thd_zone.cpp: In member function 'void cthd_zone::sort_and_update_poll_trip()': 8| In file included from ../git/src/thd_common.h:27,
9| ../git/src/thd_zone.cpp:106:16: error: format '%lu' expects argument of type 'long unsigned int', but argument 4 has type 'std::vector<cthd_trip_point>::size_type' {aka 'unsigned int'} [-Werror=format=] 9| from ../git/src/thd_zone.h:30,
10| thd_log_debug("sort_and_update_poll_trip: trip_points_size =%lu\n", 10| from ../git/src/thd_zone.cpp:34:
11| ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ 11| ../git/src/thd_zone.cpp: In member function 'void cthd_zone::update_highest_trip_temp(cthd_trip_point&)':
12| trip_points.size()); 12| ../git/src/thd_zone.cpp:322:16: error: format '%lu' expects argument of type 'long unsigned int', but argument 4 has type 'std::vector<cthd_trip_point>::size_type' {aka 'unsigned int'} [-Werror=format=]
13 13| 322 | thd_log_info("trip_points.size():%lu\n", trip_points.size());
14Upstream-Status: Submitted 14| | ^~~~~~~~~~~~~~~~~~~~~~~~~~ ~~~~~~~~~~~~~~~~~~
15[https://github.com/intel/thermal_daemon/pull/165] 15| | |
16| | std::vector<cthd_trip_point>::size_type {aka unsigned int}
17| ../git/src/thermald.h:82:57: note: in definition of macro 'thd_log_info'
18| 82 | #define thd_log_info(...) g_log(NULL, G_LOG_LEVEL_INFO, __VA_ARGS__)
19| | ^~~~~~~~~~~
20| ../git/src/thd_zone.cpp:322:38: note: format string is defined here
21| 322 | thd_log_info("trip_points.size():%lu\n", trip_points.size());
22| | ~~^
23| | |
24| | long unsigned int
25| | %u
16 26
27Upstream-Status: Submitted [https://github.com/intel/thermal_daemon/pull/198]
17Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> 28Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
18--- 29---
19 src/thd_zone.cpp | 2 +- 30 src/thd_zone.cpp | 2 +-
20 1 file changed, 1 insertion(+), 1 deletion(-) 31 1 file changed, 1 insertion(+), 1 deletion(-)
21 32
22diff --git a/src/thd_zone.cpp b/src/thd_zone.cpp 33diff --git a/src/thd_zone.cpp b/src/thd_zone.cpp
23index b7edf9e..cb7b8e8 100644 34index dd485d9..eb81d61 100644
24--- a/src/thd_zone.cpp 35--- a/src/thd_zone.cpp
25+++ b/src/thd_zone.cpp 36+++ b/src/thd_zone.cpp
26@@ -103,7 +103,7 @@ int cthd_zone::read_user_set_psv_temp() { 37@@ -319,7 +319,7 @@ void cthd_zone::add_trip(cthd_trip_point &trip) {
27 } 38 void cthd_zone::update_highest_trip_temp(cthd_trip_point &trip)
28 39 {
29 void cthd_zone::sort_and_update_poll_trip() {
30- thd_log_debug("sort_and_update_poll_trip: trip_points_size =%lu\n",
31+ thd_log_debug("sort_and_update_poll_trip: trip_points_size =%zu\n",
32 trip_points.size());
33 if (trip_points.size()) { 40 if (trip_points.size()) {
34 unsigned int polling_trip = 0; 41- thd_log_info("trip_points.size():%lu\n", trip_points.size());
35-- 42+ thd_log_info("trip_points.size():%zu\n", trip_points.size());
362.17.1 43 for (unsigned int j = trip_points.size() - 1;; --j) {
37 44 if (trip_points[j].get_trip_type() == trip.get_trip_type()) {
45 thd_log_info("updating existing trip temp \n");
diff --git a/recipes-bsp/thermald/thermald_1.8.bb b/recipes-bsp/thermald/thermald_1.9.bb
index f7725f31..4f3650fa 100644
--- a/recipes-bsp/thermald/thermald_1.8.bb
+++ b/recipes-bsp/thermald/thermald_1.9.bb
@@ -16,7 +16,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=ea8831610e926e2e469075b52bf08848"
16SRC_URI = "git://github.com/intel/thermal_daemon/ \ 16SRC_URI = "git://github.com/intel/thermal_daemon/ \
17 file://0001-Use-correct-format-specifier-for-size_t.patch \ 17 file://0001-Use-correct-format-specifier-for-size_t.patch \
18 " 18 "
19SRCREV = "517c0e5f92d49aeeef3a22b04caf40d588216827" 19SRCREV = "7f573b681a25b5ffbe81103ba9fdcf7fec0f2884"
20S = "${WORKDIR}/git" 20S = "${WORKDIR}/git"
21 21
22inherit pkgconfig autotools systemd 22inherit pkgconfig autotools systemd