summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-emenlow/README49
-rw-r--r--meta-emenlow/conf/machine/emenlow.conf32
-rw-r--r--meta-emenlow/recipes-bsp/formfactor/formfactor/emenlow/machconfig3
-rw-r--r--meta-emenlow/recipes-graphics/xorg-xserver/xserver-xf86-config/emenlow/xorg.conf43
-rw-r--r--meta-emenlow/recipes-kernel/linux/linux-yocto_3.10.bbappend13
5 files changed, 6 insertions, 134 deletions
diff --git a/meta-emenlow/README b/meta-emenlow/README
index 05a04837..0bf0cbcb 100644
--- a/meta-emenlow/README
+++ b/meta-emenlow/README
@@ -82,35 +82,13 @@ common metadata shared between BSPs) e.g.:
82 yocto/meta-intel \ 82 yocto/meta-intel \
83 yocto/meta-intel/meta-emenlow \ 83 yocto/meta-intel/meta-emenlow \
84 84
85The meta-emenlow layer contains support for two different machine 85The meta-emenlow layer contains support for emenlow-noemgd machine
86configurations. These configurations are identical except for the fact 86configuration. The previously supported emenlow machine with the
87that the one prefixed with 'emenlow' makes use of the 87proprietary EMGD graphics driver has been retired. The 'emenlow-noemgd'
88Intel-proprietary EMGD 1.18 graphics driver, while the one prefixed 88machine configuration uses the open source 'gma500' kernel DRM driver
89with 'emenlow-noemgd' does not. The 'emenlow-noemgd' machine
90configuration instead uses the open source 'gma500' kernel DRM driver
91along with the 'modesetting' X driver. 89along with the 'modesetting' X driver.
92 90
93If you want to enable the layer that supports EMGD graphics add the 91To enable the layer add the following to the local.conf file:
94following to the local.conf file:
95
96 MACHINE ?= "emenlow"
97
98The 'emenlow' machine includes the emgd-driver-bin package, which has
99a proprietary license that must be whitelisted by adding the string
100"license_emgd-driver-bin_1.18" to the LICENSE_FLAGS_WHITELIST variable
101in your local.conf. For example:
102
103 LICENSE_FLAGS_WHITELIST = "license_emgd-driver-bin"
104
105The emgd recipe depends on Xorg's dri and glx modules, which are built
106only when 'opengl' is listed in DISTRO_FEATURES. So if the distro
107doesn't list 'opengl' in the DISTRO_FEATURES you would need this
108additional line to your local.conf:
109
110 DISTRO_FEATURES_append = " opengl"
111
112If you want to enable the layer that does not support EMGD graphics
113add the following to the local.conf file:
114 92
115 MACHINE ?= "emenlow-noemgd" 93 MACHINE ?= "emenlow-noemgd"
116 94
@@ -123,21 +101,6 @@ At the end of a successful build, you should have a live image that
123you can boot from a USB flash drive (see instructions on how to do 101you can boot from a USB flash drive (see instructions on how to do
124that below, in the section 'Booting the images from /binary'). 102that below, in the section 'Booting the images from /binary').
125 103
126NOTE: The 'emenlow' machine will include support for hardware video
127acceleration via gstreamer if and only if the "commercial" string is
128added to the the LICENSE_FLAGS_WHITELIST variable in your local.conf.
129
130For example:
131
132 LICENSE_FLAGS_WHITELIST = "license_emgd-driver-bin commercial"
133
134The reason this is needed is to prevent the image from including
135anything that might violate the license terms of the packages used to
136implement the the video acceleration feature, such as gst-ffmpeg and
137ffmpeg. As always, please consult the licenses included in the
138specific packages for details if you use packages that require
139particular LICENSE_FLAGS.
140
141As an alternative to downloading the BSP tarball, you can also work 104As an alternative to downloading the BSP tarball, you can also work
142directly from the meta-intel git repository. For each BSP in the 105directly from the meta-intel git repository. For each BSP in the
143'meta-intel' repository, there are multiple branches, one 106'meta-intel' repository, there are multiple branches, one
@@ -159,7 +122,7 @@ Under Linux, insert a USB flash drive. Assuming the USB flash drive
159takes device /dev/sdf, use dd to copy the live image to it. For 122takes device /dev/sdf, use dd to copy the live image to it. For
160example: 123example:
161 124
162# dd if=core-image-sato-emenlow.hddimg of=/dev/sdf 125# dd if=core-image-sato-emenlow-noemgd.hddimg of=/dev/sdf
163# sync 126# sync
164# eject /dev/sdf 127# eject /dev/sdf
165 128
diff --git a/meta-emenlow/conf/machine/emenlow.conf b/meta-emenlow/conf/machine/emenlow.conf
deleted file mode 100644
index 502d196a..00000000
--- a/meta-emenlow/conf/machine/emenlow.conf
+++ /dev/null
@@ -1,32 +0,0 @@
1#@TYPE: Machine
2#@NAME: emenlow
3
4#@WEBTITLE: Intel Atom Z5xx Processor With Intel US15W Controller Hub (eMenlow)
5
6#@DESCRIPTION: Machine configuration for eMenlow based systems, like the
7# Webs-2120 box.
8
9PREFERRED_VERSION_linux-yocto ?= "3.10%"
10
11require conf/machine/include/intel-core2-32-common.inc
12require conf/machine/include/meta-intel.inc
13require conf/machine/include/meta-intel-emgd.inc
14
15MACHINE_FEATURES += "va-impl-mixvideo"
16
17MACHINE_HWCODECS ?= "va-intel"
18XSERVERCODECS ?= "emgd-driver-video emgd-gst-plugins-va \
19 emgd-gst-plugins-mixvideo gst-va-intel"
20
21XSERVER ?= "${XSERVER_X86_BASE} \
22 ${XSERVER_X86_EXT} \
23 ${XSERVER_X86_EMGD} \
24 "
25
26PREFERRED_VERSION_xserver-xorg ?= "1.9.3"
27PREFERRED_VERSION_xf86-input-synaptics ?= "1.6.3"
28PREFERRED_VERSION_xf86-input-evdev ?= "2.6.0"
29PREFERRED_VERSION_emgd-driver-bin ?= "1.18"
30PREFERRED_VERSION_libva ?= "1.0.16"
31
32APPEND += "video=vesafb vga=0x318 vmalloc=256MB reboot=pci"
diff --git a/meta-emenlow/recipes-bsp/formfactor/formfactor/emenlow/machconfig b/meta-emenlow/recipes-bsp/formfactor/formfactor/emenlow/machconfig
deleted file mode 100644
index ffce0122..00000000
--- a/meta-emenlow/recipes-bsp/formfactor/formfactor/emenlow/machconfig
+++ /dev/null
@@ -1,3 +0,0 @@
1# Assume a USB mouse and keyboard are connected
2HAVE_TOUCHSCREEN=0
3HAVE_KEYBOARD=1
diff --git a/meta-emenlow/recipes-graphics/xorg-xserver/xserver-xf86-config/emenlow/xorg.conf b/meta-emenlow/recipes-graphics/xorg-xserver/xserver-xf86-config/emenlow/xorg.conf
deleted file mode 100644
index 52179631..00000000
--- a/meta-emenlow/recipes-graphics/xorg-xserver/xserver-xf86-config/emenlow/xorg.conf
+++ /dev/null
@@ -1,43 +0,0 @@
1##
2## X Config options generated from CED
3## x11 conf skeleton
4## DriverVer=
5##
6
7Section "Screen"
8 Identifier "Screen0"
9 Device "IntelEMGD-0"
10 Monitor "Monitor0"
11 SubSection "Display"
12 EndSubSection
13EndSection
14
15# Primary (First/only) display
16Section "Device"
17 Identifier "IntelEMGD-0"
18 Driver "emgd"
19 VendorName "Intel(R) DEG"
20 BoardName "Embedded Graphics"
21 BusID "0:2:0"
22 Screen 0
23 Option "PcfVersion" "1792"
24 Option "ConfigId" "1"
25 Option "ALL/1/name" "e6xx"
26 Option "ALL/1/General/PortOrder" "24000"
27 Option "ALL/1/General/DisplayConfig" "1"
28 Option "ALL/1/General/DisplayDetect" "1"
29 Option "ALL/1/General/TuningWA" "1"
30 Option "ALL/1/Port/4/General/name" "lvds"
31 Option "ALL/1/Port/4/General/EdidAvail" "3"
32 Option "ALL/1/Port/4/General/EdidNotAvail" "1"
33 Option "ALL/1/Port/4/General/Rotation" "0"
34 Option "ALL/1/Port/4/General/Edid" "0"
35EndSection
36
37Section "ServerLayout"
38 Identifier "Default Layout"
39 Screen 0 "Screen0" 0 0
40 # InputDevice "Mouse0" "CorePointer"
41 # InputDevice "Keyboard0" "CoreKeyboard"
42 # InputDevice "DevInputMice" "SendCoreEvents"
43EndSection
diff --git a/meta-emenlow/recipes-kernel/linux/linux-yocto_3.10.bbappend b/meta-emenlow/recipes-kernel/linux/linux-yocto_3.10.bbappend
index bf3df764..b5ed2146 100644
--- a/meta-emenlow/recipes-kernel/linux/linux-yocto_3.10.bbappend
+++ b/meta-emenlow/recipes-kernel/linux/linux-yocto_3.10.bbappend
@@ -1,23 +1,10 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3
4COMPATIBLE_MACHINE_emenlow = "emenlow"
5KMACHINE_emenlow = "emenlow"
6KBRANCH_emenlow = "standard/emenlow"
7KERNEL_FEATURES_append_emenlow = " features/drm-emgd/drm-emgd-1.18 cfg/vesafb"
8
9COMPATIBLE_MACHINE_emenlow-noemgd = "emenlow-noemgd" 3COMPATIBLE_MACHINE_emenlow-noemgd = "emenlow-noemgd"
10KMACHINE_emenlow-noemgd = "emenlow" 4KMACHINE_emenlow-noemgd = "emenlow"
11KBRANCH_emenlow-noemgd = "standard/emenlow" 5KBRANCH_emenlow-noemgd = "standard/emenlow"
12KERNEL_FEATURES_append_emenlow-noemgd = " features/drm-gma500/drm-gma500" 6KERNEL_FEATURES_append_emenlow-noemgd = " features/drm-gma500/drm-gma500"
13 7
14LINUX_VERSION_emenlow = "3.10.38"
15SRCREV_meta_emenlow = "e1f26aeccfd43bc3d7e95873ceda469b631b8473"
16SRCREV_machine_emenlow = "02f7e63e56c061617957388c23bd5cf9b05c5388"
17SRCREV_emgd_emenlow = "42d5e4548e8e79e094fa8697949eed4cf6af00a3"
18
19LINUX_VERSION_emenlow-noemgd = "3.10.38" 8LINUX_VERSION_emenlow-noemgd = "3.10.38"
20SRCREV_meta_emenlow-noemgd = "e1f26aeccfd43bc3d7e95873ceda469b631b8473" 9SRCREV_meta_emenlow-noemgd = "e1f26aeccfd43bc3d7e95873ceda469b631b8473"
21SRCREV_machine_emenlow-noemgd = "02f7e63e56c061617957388c23bd5cf9b05c5388" 10SRCREV_machine_emenlow-noemgd = "02f7e63e56c061617957388c23bd5cf9b05c5388"
22
23SRC_URI_emenlow = "git://git.yoctoproject.org/linux-yocto-3.10.git;protocol=git;nocheckout=1;branch=${KBRANCH},${KMETA},emgd-1.18;name=machine,meta,emgd"