summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-support/libipt/libipt_2.0.1.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/recipes-support/libipt/libipt_2.0.1.bb b/recipes-support/libipt/libipt_2.0.1.bb
index 1b3e1e64..68f6d5c5 100644
--- a/recipes-support/libipt/libipt_2.0.1.bb
+++ b/recipes-support/libipt/libipt_2.0.1.bb
@@ -14,3 +14,19 @@ S = "${WORKDIR}/git"
14SRC_URI = "git://github.com/intel/libipt.git;protocol=https;branch=stable/v2.0" 14SRC_URI = "git://github.com/intel/libipt.git;protocol=https;branch=stable/v2.0"
15 15
16SRCREV = "916d777123bf60d323890557347570e5e19dfa12" 16SRCREV = "916d777123bf60d323890557347570e5e19dfa12"
17
18EXTRA_OECMAKE += " \
19 -DPTDUMP=ON \
20 -DPTTC=ON \
21 "
22
23do_install_append() {
24 install -d ${D}${bindir}/libipt
25 install -d ${D}${bindir}/libipt/tests
26
27 cp -r ${B}/bin/* ${D}${bindir}/libipt/
28 cp -r ${WORKDIR}/git/test/src/* ${D}${bindir}/libipt/tests
29}
30
31FILES_${PN}-test = "${bindir}"
32PACKAGES =+ "${PN}-test"