summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--dynamic-layers/openembedded-layer/recipes-bsp/amt/lms/fix-gcc13.patch46
-rw-r--r--dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2245.0.0.0.bb1
2 files changed, 47 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-bsp/amt/lms/fix-gcc13.patch b/dynamic-layers/openembedded-layer/recipes-bsp/amt/lms/fix-gcc13.patch
new file mode 100644
index 00000000..7e5e3bee
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-bsp/amt/lms/fix-gcc13.patch
@@ -0,0 +1,46 @@
1Upstream-Status: Pending
2Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
3
4diff --git a/MEIClient/AMTHIClient/Include/AmtAnsiString.h b/MEIClient/AMTHIClient/Include/AmtAnsiString.h
5index 23114c9..deef61b 100644
6--- a/MEIClient/AMTHIClient/Include/AmtAnsiString.h
7+++ b/MEIClient/AMTHIClient/Include/AmtAnsiString.h
8@@ -12,6 +12,7 @@
9
10 #include <string>
11 #include <vector>
12+#include <cstdint>
13
14 namespace Intel
15 {
16diff --git a/MEIClient/Include/MEIparser.h b/MEIClient/Include/MEIparser.h
17index 0d47bb9..d4ffcd8 100644
18--- a/MEIClient/Include/MEIparser.h
19+++ b/MEIClient/Include/MEIparser.h
20@@ -8,6 +8,7 @@
21 #include "MEIClientException.h"
22 #include <cstring>
23 #include <vector>
24+#include <cstdint>
25
26 namespace Intel
27 {
28diff --git a/UNS/GMS_COMMON/FuncEntryExit.h b/UNS/GMS_COMMON/FuncEntryExit.h
29index 21862ab..7165906 100644
30--- a/UNS/GMS_COMMON/FuncEntryExit.h
31+++ b/UNS/GMS_COMMON/FuncEntryExit.h
32@@ -5,6 +5,7 @@
33 #ifndef FUNCENTRYEXIT_H
34 #define FUNCENTRYEXIT_H
35 #include "GMSCommonDllExport.h"
36+#include <cstdint>
37
38 GMS_COMMON_EXPORT void FlowLog(const wchar_t *name, const wchar_t *pref, const wchar_t *func);
39 GMS_COMMON_EXPORT void FuncEntry(const wchar_t *name, const wchar_t *func);
40@@ -48,4 +49,4 @@ private:
41 const wchar_t * name_;
42 const wchar_t * func_;
43 };
44-#endif // FUNCENTRYEXIT_H
45\ No newline at end of file
46+#endif // FUNCENTRYEXIT_H
diff --git a/dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2245.0.0.0.bb b/dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2245.0.0.0.bb
index 36e45dd5..7f339c8f 100644
--- a/dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2245.0.0.0.bb
+++ b/dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2245.0.0.0.bb
@@ -30,6 +30,7 @@ S = "${WORKDIR}/git"
30SYSTEMD_SERVICE:${PN} = "lms.service" 30SYSTEMD_SERVICE:${PN} = "lms.service"
31 31
32SRC_URI = "git://github.com/intel/lms.git;branch=master;protocol=https \ 32SRC_URI = "git://github.com/intel/lms.git;branch=master;protocol=https \
33 file://fix-gcc13.patch \
33 " 34 "
34SRCREV = "4db4ceb3f70cd1b907747646dda6785db7b247d7" 35SRCREV = "4db4ceb3f70cd1b907747646dda6785db7b247d7"
35 36