summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/vc-intrinsics/vc-intrinsics_1.0.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/vc-intrinsics/vc-intrinsics_1.0.bb b/dynamic-layers/clang-layer/recipes-opencl/vc-intrinsics/vc-intrinsics_1.0.bb
new file mode 100644
index 00000000..a51b980c
--- /dev/null
+++ b/dynamic-layers/clang-layer/recipes-opencl/vc-intrinsics/vc-intrinsics_1.0.bb
@@ -0,0 +1,25 @@
1SUMMARY = "VC Intrinsics"
2DESCRIPTION = "VC Intrinsics project contains a set of new intrinsics on \
3top of core LLVM IR instructions that represent SIMD semantics of a program \
4targeting GPU"
5
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://License.md;md5=c18ea6bb4786a26bf4eee88a7424a408"
8
9SRC_URI = "git://github.com/intel/vc-intrinsics.git;protocol=https; \
10 "
11
12SRCREV = "f39ff1e6589f8bda1bcd81a9260f8143996b8a19"
13
14S = "${WORKDIR}/git"
15
16inherit cmake
17
18COMPATIBLE_HOST = '(x86_64).*-linux'
19COMPATIBLE_HOST_libc-musl = "null"
20
21DEPENDS += " clang"
22
23EXTRA_OECMAKE = "-DLLVM_DIR=${STAGING_LIBDIR}"
24
25BBCLASSEXTEND = "native nativesdk"