summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/layer.conf3
-rw-r--r--recipes-core/packagegroups/packagegroup-core-standalone-sdk-target.bbappend2
2 files changed, 4 insertions, 1 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
index 77baa827..a226ddcf 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -41,3 +41,6 @@ PREFERRED_PROVIDER_nativesdk-libva ?= "nativesdk-libva"
41PREFERRED_PROVIDER_libva-utils ?= "libva-utils" 41PREFERRED_PROVIDER_libva-utils ?= "libva-utils"
42PREFERRED_PROVIDER_libva-utils-native ?= "libva-utils-native" 42PREFERRED_PROVIDER_libva-utils-native ?= "libva-utils-native"
43PREFERRED_PROVIDER_nativesdk-libva-utils ?= "nativesdk-libva-utils" 43PREFERRED_PROVIDER_nativesdk-libva-utils ?= "nativesdk-libva-utils"
44
45# Do not include icc in SDK unless user wants to.
46ICCSDK ??= "0"
diff --git a/recipes-core/packagegroups/packagegroup-core-standalone-sdk-target.bbappend b/recipes-core/packagegroups/packagegroup-core-standalone-sdk-target.bbappend
index b2dd25b7..329a9244 100644
--- a/recipes-core/packagegroups/packagegroup-core-standalone-sdk-target.bbappend
+++ b/recipes-core/packagegroups/packagegroup-core-standalone-sdk-target.bbappend
@@ -1,2 +1,2 @@
1INTEL_COMPILER_COMMON_PKGS = "intel-oneapi-runtime-compilers intel-oneapi-runtime-compilers-staticdev intel-oneapi-runtime-compilers-dev" 1INTEL_COMPILER_COMMON_PKGS = "intel-oneapi-runtime-compilers intel-oneapi-runtime-compilers-staticdev intel-oneapi-runtime-compilers-dev"
2RRECOMMENDS:${PN} += "${@bb.utils.contains('ICCSDK', '1', ' ${INTEL_COMPILER_COMMON_PKGS} intel-oneapi-compiler-classic ', '', d)}" 2RRECOMMENDS:${PN}:append:intel-x86-common = "${@bb.utils.contains('ICCSDK', '1', ' ${INTEL_COMPILER_COMMON_PKGS} intel-oneapi-compiler-classic', '', d)}"