summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-sugarbay/COPYING.MIT17
-rw-r--r--meta-sugarbay/README84
-rw-r--r--meta-sugarbay/binary/.gitignore0
-rw-r--r--meta-sugarbay/conf/layer.conf12
-rw-r--r--meta-sugarbay/conf/machine/sugarbay.conf57
-rw-r--r--meta-sugarbay/recipes-bsp/formfactor/formfactor/sugarbay/machconfig3
-rw-r--r--meta-sugarbay/recipes-bsp/formfactor/formfactor_0.0.bbappend3
-rw-r--r--meta-sugarbay/recipes-graphics/xorg-xserver/xserver-xf86-config/sugarbay/xorg.conf26
-rw-r--r--meta-sugarbay/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend3
-rw-r--r--meta-sugarbay/recipes-graphics/xorg-xserver/xserver-xf86-dri-lite_1.9.3.bbappend1
-rw-r--r--meta-sugarbay/recipes-kernel/linux/linux-yocto_git.bbappend5
11 files changed, 211 insertions, 0 deletions
diff --git a/meta-sugarbay/COPYING.MIT b/meta-sugarbay/COPYING.MIT
new file mode 100644
index 00000000..fb950dc6
--- /dev/null
+++ b/meta-sugarbay/COPYING.MIT
@@ -0,0 +1,17 @@
1Permission is hereby granted, free of charge, to any person obtaining a copy
2of this software and associated documentation files (the "Software"), to deal
3in the Software without restriction, including without limitation the rights
4to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
5copies of the Software, and to permit persons to whom the Software is
6furnished to do so, subject to the following conditions:
7
8The above copyright notice and this permission notice shall be included in
9all copies or substantial portions of the Software.
10
11THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
12IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
13FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
14AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
15LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
16OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
17THE SOFTWARE.
diff --git a/meta-sugarbay/README b/meta-sugarbay/README
new file mode 100644
index 00000000..bcc46c23
--- /dev/null
+++ b/meta-sugarbay/README
@@ -0,0 +1,84 @@
1This README file contains information on building the meta-sugarbay
2BSP layer, and booting the images contained in the /binary directory.
3Please see the corresponding sections below for details.
4
5The 'Sugar Bay' platform consists of the Intel Sandy Bridge processor,
6plus the Cougar Point PCH (Q67 Express or B65 Express chipsets). This
7BSP assumes that the Sandy Bridge integrated graphics are being used.
8
9Table of Contents
10=================
11
12 I. Building the meta-sugarbay BSP layer
13 II. Special notes for building the meta-sugarbay BSP layer
14III. Booting the images in /binary
15
16
17I. Building the meta-sugarbay BSP layer
18=======================================
19
20For each BSP in the 'meta-intel' repository, there are multiple
21branches, one corresponding to each major release starting with
22'laverne' (0.90), in addition to the latest code which tracks the
23current master.
24
25In order to build an image with BSP support for a given release, you
26need to check out the 'meta-intel' branch corresponding to the release
27you're building against e.g. to build for laverne (0.90), check out
28the 'laverne' branch of both poky and 'meta-intel'.
29
30Having done that, and assuming you cloned the 'meta-intel' repository
31at the top-level of your yocto build tree, you can build a sugarbay
32image by adding the location of the meta-sugarbay layer to
33bblayers.conf e.g.:
34
35 yocto/meta-intel/meta-sugarbay \
36
37To enable the sugarbay layer, add the sugarbay MACHINE to local.conf:
38
39 MACHINE ?= "sugarbay"
40
41You should then be able to build a sugarbay image as such:
42
43 $ source poky-init-build-env
44 $ bitbake poky-image-sato-live
45
46At the end of a successful build, you should have a live image that
47you can boot from a USB flash drive (see instructions on how to do
48that below, in the section 'Booting the images from /binary').
49
50
51II. Booting the images in /binary
52=================================
53
54This BSP contains bootable live images, which can be used to directly
55boot Yocto off of a USB flash drive.
56
57Under Linux, insert a USB flash drive. Assuming the USB flash drive
58takes device /dev/sdf, use dd to copy the live image to it. For
59example:
60
61# dd if=poky-image-sato-live-sugarbay-20101207053738.hddimg of=/dev/sdf
62# sync
63# eject /dev/sdf
64
65This should give you a bootable USB flash device. Insert the device
66into a bootable USB socket on the target, and power on. This should
67result in a system booted to the Sato graphical desktop.
68
69If you want a terminal, use the arrows at the top of the UI to move to
70different pages of available applications, one of which is named
71'Terminal'. Clicking that should give you a root terminal.
72
73If you want to ssh into the system, you can use the root terminal to
74ifconfig the IP address and use that to ssh in. The root password is
75empty, so to log in type 'root' for the user name and hit 'Enter' at
76the Password prompt: and you should be in.
77
78----
79
80If you find you're getting corrupt images on the USB (it doesn't show
81the syslinux boot: prompt, or the boot: prompt contains strange
82characters), try doing this first:
83
84# dd if=/dev/zero of=/dev/sdf bs=1M count=512
diff --git a/meta-sugarbay/binary/.gitignore b/meta-sugarbay/binary/.gitignore
new file mode 100644
index 00000000..e69de29b
--- /dev/null
+++ b/meta-sugarbay/binary/.gitignore
diff --git a/meta-sugarbay/conf/layer.conf b/meta-sugarbay/conf/layer.conf
new file mode 100644
index 00000000..e23d1233
--- /dev/null
+++ b/meta-sugarbay/conf/layer.conf
@@ -0,0 +1,12 @@
1# We have a conf and classes directory, add to BBPATH
2BBPATH := "${BBPATH}:${LAYERDIR}"
3
4# We have a recipes directory, add to BBFILES
5BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb \
6 ${LAYERDIR}/recipes-*/*/*.bbappend \
7 ${LAYERDIR}/../common/recipes-*/*/*.bb \
8 ${LAYERDIR}/../common/recipes-*/*/*.bbappend"
9
10BBFILE_COLLECTIONS_sugarbay += "sugarbay"
11BBFILE_PATTERN_sugarbay := "^${LAYERDIR}/"
12BBFILE_PRIORITY_sugarbay = "6"
diff --git a/meta-sugarbay/conf/machine/sugarbay.conf b/meta-sugarbay/conf/machine/sugarbay.conf
new file mode 100644
index 00000000..4d58d050
--- /dev/null
+++ b/meta-sugarbay/conf/machine/sugarbay.conf
@@ -0,0 +1,57 @@
1#@TYPE: Machine
2#@NAME: sugarbay
3
4#@DESCRIPTION: Machine configuration for Sugar Bay systems
5# i.e. Sandy Bridge + Cougar Point
6
7TARGET_ARCH = "x86_64"
8PACKAGE_EXTRA_ARCHS = "x86 snb"
9
10BASE_PACKAGE_ARCH="snb"
11
12MACHINE_FEATURES = "kernel26 screen keyboard pci usbhost ext2 ext3 x86 \
13 acpi serial usbgadget"
14
15KERNEL_IMAGETYPE = "bzImage"
16
17PREFERRED_PROVIDER_virtual/kernel = "linux-yocto"
18PREFERRED_PROVIDER_linux-libc-headers ?= "linux-libc-headers-yocto"
19
20PREFERRED_PROVIDER_virtual/libx11 ?= "libx11-trim"
21PREFERRED_PROVIDER_virtual/libgl ?= "mesa-dri"
22PREFERRED_PROVIDER_virtual/xserver ?= "xserver-xf86-dri-lite"
23PREFERRED_PROVIDER_virtual/xserver-xf86 ?= "xserver-xf86-dri-lite"
24XSERVER ?= "xserver-xf86-dri-lite \
25 xf86-input-mouse \
26 xf86-input-keyboard \
27 xf86-input-evdev \
28 xf86-input-synaptics \
29 xf86-video-intel"
30
31SERIAL_CONSOLE = "115200 ttyS0"
32
33MACHINE_EXTRA_RRECOMMENDS = "kernel-modules eee-acpi-scripts"
34
35GUI_MACHINE_CLASS = "bigscreen"
36
37IMAGE_ROOTFS_SIZE_ext3 = "2000000"
38
39IMAGE_FSTYPES ?= "ext3 cpio.gz"
40
41GLIBC_ADDONS = "nptl"
42GLIBC_EXTRA_OECONF = "--with-tls"
43
44MACHINE_ESSENTIAL_EXTRA_RDEPENDS = "grub"
45
46TARGET_CC_ARCH = "-m64"
47
48PREFERRED_VERSION_xf86-video-intel ?= "2.14.0"
49PREFERRED_VERSION_mesa-dri ?= "7.10"
50PREFERRED_VERSION_libdrm ?= "2.4.23"
51PREFERRED_VERSION_cairo ?= "1.10.2"
52PREFERRED_VERSION_xserver-xf86-dri-lite ?= "1.9.3"
53
54PREFERRED_VERSION_grub ?= "1.98"
55
56#SRCREV_machine_pn-linux-yocto_sugarbay ?= "0431115c9d720fee5bb105f6a7411efb4f851d26"
57#SRCREV_meta_pn-linux-yocto_sugarbay ?= "39b796c508a80dcab6b4511b46183d4dfee6284d"
diff --git a/meta-sugarbay/recipes-bsp/formfactor/formfactor/sugarbay/machconfig b/meta-sugarbay/recipes-bsp/formfactor/formfactor/sugarbay/machconfig
new file mode 100644
index 00000000..ffce0122
--- /dev/null
+++ b/meta-sugarbay/recipes-bsp/formfactor/formfactor/sugarbay/machconfig
@@ -0,0 +1,3 @@
1# Assume a USB mouse and keyboard are connected
2HAVE_TOUCHSCREEN=0
3HAVE_KEYBOARD=1
diff --git a/meta-sugarbay/recipes-bsp/formfactor/formfactor_0.0.bbappend b/meta-sugarbay/recipes-bsp/formfactor/formfactor_0.0.bbappend
new file mode 100644
index 00000000..4a41d487
--- /dev/null
+++ b/meta-sugarbay/recipes-bsp/formfactor/formfactor_0.0.bbappend
@@ -0,0 +1,3 @@
1FILESEXTRAPATHS := "${THISDIR}/${PN}"
2
3PRINC = "1"
diff --git a/meta-sugarbay/recipes-graphics/xorg-xserver/xserver-xf86-config/sugarbay/xorg.conf b/meta-sugarbay/recipes-graphics/xorg-xserver/xserver-xf86-config/sugarbay/xorg.conf
new file mode 100644
index 00000000..96b94b46
--- /dev/null
+++ b/meta-sugarbay/recipes-graphics/xorg-xserver/xserver-xf86-config/sugarbay/xorg.conf
@@ -0,0 +1,26 @@
1Section "Device"
2 Identifier "Intel Graphics Driver"
3 Driver "intel"
4EndSection
5
6Section "Monitor"
7 Identifier "Generic Monitor"
8 Option "DPMS"
9EndSection
10
11Section "Screen"
12 Identifier "Default Screen"
13 Device "Intel Graphics Driver"
14 Monitor "Generic Monitor"
15 DefaultDepth 24
16EndSection
17
18Section "ServerLayout"
19 Identifier "Default Layout"
20 Screen "Default Screen"
21EndSection
22
23Section "ServerFlags"
24 Option "DontZap" "0"
25 Option "AutoAddDevices" "False"
26EndSection
diff --git a/meta-sugarbay/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend b/meta-sugarbay/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend
new file mode 100644
index 00000000..4b8d0e65
--- /dev/null
+++ b/meta-sugarbay/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend
@@ -0,0 +1,3 @@
1THISDIR := "${@os.path.dirname(bb.data.getVar('FILE', d, True))}"
2FILESPATH =. "${@base_set_filespath(["${THISDIR}/${PN}"], d)}:"
3
diff --git a/meta-sugarbay/recipes-graphics/xorg-xserver/xserver-xf86-dri-lite_1.9.3.bbappend b/meta-sugarbay/recipes-graphics/xorg-xserver/xserver-xf86-dri-lite_1.9.3.bbappend
new file mode 100644
index 00000000..b2808ef2
--- /dev/null
+++ b/meta-sugarbay/recipes-graphics/xorg-xserver/xserver-xf86-dri-lite_1.9.3.bbappend
@@ -0,0 +1 @@
EXTRA_OECONF += "--enable-dga"
diff --git a/meta-sugarbay/recipes-kernel/linux/linux-yocto_git.bbappend b/meta-sugarbay/recipes-kernel/linux/linux-yocto_git.bbappend
new file mode 100644
index 00000000..07fd27b7
--- /dev/null
+++ b/meta-sugarbay/recipes-kernel/linux/linux-yocto_git.bbappend
@@ -0,0 +1,5 @@
1FILESEXTRAPATHS := "${THISDIR}/${PN}"
2
3COMPATIBLE_MACHINE_sugarbay = "sugarbay"
4KMACHINE_sugarbay = "yocto/standard/sugarbay"
5