summaryrefslogtreecommitdiffstats
path: root/recipes-support/sbsigntool/sbsigntool-native_git.bb
diff options
context:
space:
mode:
authorAndrei Gherzan <andrei.gherzan@huawei.com>2021-12-09 15:14:39 +0100
committerAnuj Mittal <anuj.mittal@intel.com>2021-12-10 16:41:29 +0800
commitaa8482af7b286f8fe8f7aae648938d4ebf0283c5 (patch)
tree362becac7d01366a7b9ab1eff7c3524f30053f0f /recipes-support/sbsigntool/sbsigntool-native_git.bb
parent48440091d4cba2712ea2c23a779c044b07f5bb4d (diff)
downloadmeta-intel-aa8482af7b286f8fe8f7aae648938d4ebf0283c5.tar.gz
sbsigntool: Fix build with Openssl 3.0
The patch fixes the build when OpenSSL 3.0 is used. We also disable errors on deprecations as the code uses a good amount of them that look to be harmless. Signed-off-by: Andrei Gherzan <andrei.gherzan@huawei.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'recipes-support/sbsigntool/sbsigntool-native_git.bb')
-rw-r--r--recipes-support/sbsigntool/sbsigntool-native_git.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/recipes-support/sbsigntool/sbsigntool-native_git.bb b/recipes-support/sbsigntool/sbsigntool-native_git.bb
index a584f106..58af6349 100644
--- a/recipes-support/sbsigntool/sbsigntool-native_git.bb
+++ b/recipes-support/sbsigntool/sbsigntool-native_git.bb
@@ -22,6 +22,7 @@ LIC_FILES_CHKSUM = "file://LICENSE.GPLv3;md5=9eef91148a9b14ec7f9df333daebc746 \
22SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/jejb/sbsigntools.git;protocol=https;name=sbsigntools;branch=master \ 22SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/jejb/sbsigntools.git;protocol=https;name=sbsigntools;branch=master \
23 git://github.com/rustyrussell/ccan.git;protocol=https;destsuffix=git/lib/ccan.git;name=ccan;branch=master \ 23 git://github.com/rustyrussell/ccan.git;protocol=https;destsuffix=git/lib/ccan.git;name=ccan;branch=master \
24 file://0001-configure-Fixup-build-dependencies-for-cross-compili.patch \ 24 file://0001-configure-Fixup-build-dependencies-for-cross-compili.patch \
25 file://0002-fix-openssl-3-0.patch \
25 " 26 "
26 27
27SRCREV_sbsigntools ?= "f12484869c9590682ac3253d583bf59b890bb826" 28SRCREV_sbsigntools ?= "f12484869c9590682ac3253d583bf59b890bb826"
@@ -79,3 +80,5 @@ EXTRA_OEMAKE = "\
79 -I${STAGING_INCDIR_NATIVE} \ 80 -I${STAGING_INCDIR_NATIVE} \
80 -I${STAGING_INCDIR_NATIVE}/efi/${@efi_arch(d)}' \ 81 -I${STAGING_INCDIR_NATIVE}/efi/${@efi_arch(d)}' \
81 " 82 "
83
84CFLAGS:append = " -Wno-error"