summaryrefslogtreecommitdiffstats
path: root/recipes-oneapi
diff options
context:
space:
mode:
authorVtiurina, Mariia <mariia.vtiurina@intel.com>2021-11-02 20:11:27 +0300
committerAnuj Mittal <anuj.mittal@intel.com>2021-11-24 22:35:46 +0800
commitb56b3e485805b5daeb8dcf0d15779380e2ed26fd (patch)
treee55effdb7b8818c8b192b1de7d40f75b6785c6a8 /recipes-oneapi
parent922d3cb1747ea657bb5668e24d6df5a606d9c5dd (diff)
downloadmeta-intel-b56b3e485805b5daeb8dcf0d15779380e2ed26fd.tar.gz
intel-crypto-mb: add recipe for ipp crypto library
Intel® Integrated Performance Primitives (Intel® IPP) Cryptography is a secure, fast and lightweight library of building blocks for cryptography, highly-optimized for various Intel® CPUs. Signed-off by: Andrey Latyshev <andrey.latyshev@intel.com> Signed-off-by: Mariia Vtiurina <mariia.vtiurina@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'recipes-oneapi')
-rw-r--r--recipes-oneapi/crypto/intel-crypto-mb/0001-GNU.cmake-allow-to-pass-compiler-and-linker-flags.patch29
-rw-r--r--recipes-oneapi/crypto/intel-crypto-mb/0003-CMakeLists.txt-exclude-host-system-headers.patch24
-rw-r--r--recipes-oneapi/crypto/intel-crypto-mb_2021.3.bb29
3 files changed, 82 insertions, 0 deletions
diff --git a/recipes-oneapi/crypto/intel-crypto-mb/0001-GNU.cmake-allow-to-pass-compiler-and-linker-flags.patch b/recipes-oneapi/crypto/intel-crypto-mb/0001-GNU.cmake-allow-to-pass-compiler-and-linker-flags.patch
new file mode 100644
index 00000000..49adf8f1
--- /dev/null
+++ b/recipes-oneapi/crypto/intel-crypto-mb/0001-GNU.cmake-allow-to-pass-compiler-and-linker-flags.patch
@@ -0,0 +1,29 @@
1From c440800cae91f857949255cc63993426bdaefb26 Mon Sep 17 00:00:00 2001
2From: Naveen Saini <naveen.kumar.saini@intel.com>
3Date: Wed, 16 Jun 2021 20:54:33 +0800
4Subject: [PATCH 1/4] GNU.cmake: allow to pass compiler and linker flags
5
6Upstream-Status: Inappropriate
7
8Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
9---
10 sources/ippcp/crypto_mb/src/cmake/linux/GNU.cmake | 3 ++-
11 1 file changed, 2 insertions(+), 1 deletion(-)
12
13diff --git a/sources/ippcp/crypto_mb/src/cmake/linux/GNU.cmake b/sources/ippcp/crypto_mb/src/cmake/linux/GNU.cmake
14index 5d148a1..4cb2289 100644
15--- a/sources/ippcp/crypto_mb/src/cmake/linux/GNU.cmake
16+++ b/sources/ippcp/crypto_mb/src/cmake/linux/GNU.cmake
17@@ -56,7 +56,8 @@ set(LINK_FLAGS_DYNAMIC "${LINK_FLAGS_DYNAMIC} ${CRYPTO_MB_SOURCES_DIR}/cmake/dll
18 # Compiler flags
19
20 # Tells the compiler to align functions and loops
21-set(CMAKE_C_FLAGS " -falign-functions=32 -falign-loops=32")
22+set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -falign-functions=32 -falign-loops=32")
23+
24 # Ensures that compilation takes place in a freestanding environment
25 set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -ffreestanding")
26
27--
282.17.1
29
diff --git a/recipes-oneapi/crypto/intel-crypto-mb/0003-CMakeLists.txt-exclude-host-system-headers.patch b/recipes-oneapi/crypto/intel-crypto-mb/0003-CMakeLists.txt-exclude-host-system-headers.patch
new file mode 100644
index 00000000..f9c4a923
--- /dev/null
+++ b/recipes-oneapi/crypto/intel-crypto-mb/0003-CMakeLists.txt-exclude-host-system-headers.patch
@@ -0,0 +1,24 @@
1From 7b575fc23d246373425c3682e83634203aadc4a6 Mon Sep 17 00:00:00 2001
2From: Naveen Saini <naveen.kumar.saini@intel.com>
3Date: Thu, 17 Jun 2021 12:35:36 +0800
4Subject: [PATCH 3/4] CMakeLists.txt: exclude host system headers
5
6Upstream-Status: Inappropriate
7
8Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
9---
10diff --git a/sources/ippcp/crypto_mb/CMakeLists.txt b/sources/ippcp/crypto_mb/CMakeLists.txt
11index d1f3994..db9635b 100644
12--- a/sources/ippcp/crypto_mb/CMakeLists.txt
13+++ b/sources/ippcp/crypto_mb/CMakeLists.txt
14@@ -75,7 +75,6 @@ endif()
15 include_directories(
16 ${MB_INCLUDE_DIRS}
17 $<$<C_COMPILER_ID:Intel>:$ENV{ROOT}/compiler/include $ENV{ROOT}/compiler/include/icc>
18- $<$<NOT:$<C_COMPILER_ID:Intel>>:${CMAKE_SYSTEM_INCLUDE_PATH}>
19 $<$<OR:$<C_COMPILER_ID:Intel>,$<BOOL:${MSVC_IDE}>>:$ENV{INCLUDE}>
20 )
21
22--
232.17.1
24
diff --git a/recipes-oneapi/crypto/intel-crypto-mb_2021.3.bb b/recipes-oneapi/crypto/intel-crypto-mb_2021.3.bb
new file mode 100644
index 00000000..68010a4a
--- /dev/null
+++ b/recipes-oneapi/crypto/intel-crypto-mb_2021.3.bb
@@ -0,0 +1,29 @@
1SUMMARY = "Crypto Multi-buffer Library"
2DESCRIPTION = "Intel® Integrated Performance Primitives (Intel® IPP) Cryptography \
3is a secure, fast and lightweight library of building blocks for cryptography, \
4highly-optimized for various Intel® CPUs."
5HOMEPAGE = "https://github.com/intel/ipp-crypto"
6
7LICENSE = "Apache-2.0"
8
9LIC_FILES_CHKSUM = "file://../../../LICENSE;md5=e787af283468feca985d6b865d27d95b"
10
11SRC_URI = " \
12 git://github.com/intel/ipp-crypto;protocol=https;branch=ipp-crypto_2021_3 \
13 file://0001-GNU.cmake-allow-to-pass-compiler-and-linker-flags.patch;striplevel=4 \
14 file://0003-CMakeLists.txt-exclude-host-system-headers.patch;striplevel=4 \
15 "
16
17SRCREV = "d9d13aaaf8889753fb58a13c2652c39b67c2076b"
18
19S = "${WORKDIR}/git/sources/ippcp/crypto_mb"
20
21DEPENDS = "openssl"
22
23inherit cmake pkgconfig
24COMPATIBLE_HOST = '(x86_64).*-linux'
25
26# error: 'SHA512_Init' is deprecated: Since OpenSSL 3.0 [-Werror=deprecated-declarations]
27CFLAGS:append = " -Wno-error=deprecated-declarations"
28
29EXTRA_OECMAKE += " -DARCH=intel64"