summaryrefslogtreecommitdiffstats
path: root/recipes-oneapi
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2023-06-14 13:20:54 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2023-06-14 14:53:00 +0800
commit9fa42594c4a2624693309bd293ad3555badb9b0a (patch)
tree8e649bebc256caaec8743aee17e6e653b4b7389e /recipes-oneapi
parenta4991839919b924b861aec02575b769c40336c4e (diff)
downloadmeta-intel-9fa42594c4a2624693309bd293ad3555badb9b0a.tar.gz
intel-crypto-mb: fix multilib build
Make sure libraries are installed correctly even when libdir is not /usr/lib. Fixes: | ERROR: intel-crypto-mb-2021.6-r0 do_package: QA Issue: intel-crypto-mb: Files/directories were installed but not shipped in any package: | /usr/lib/libcrypto_mb.so.11.4 | /usr/lib/libcrypto_mb.so.11 | /usr/lib/libcrypto_mb.so | /usr/lib/libcrypto_mb.a Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'recipes-oneapi')
-rw-r--r--recipes-oneapi/crypto/intel-crypto-mb/0001-crypto-mb-Make-sure-libs-are-installed-correctly.patch42
-rw-r--r--recipes-oneapi/crypto/intel-crypto-mb_2021.7.1.bb1
2 files changed, 43 insertions, 0 deletions
diff --git a/recipes-oneapi/crypto/intel-crypto-mb/0001-crypto-mb-Make-sure-libs-are-installed-correctly.patch b/recipes-oneapi/crypto/intel-crypto-mb/0001-crypto-mb-Make-sure-libs-are-installed-correctly.patch
new file mode 100644
index 00000000..c47c8de5
--- /dev/null
+++ b/recipes-oneapi/crypto/intel-crypto-mb/0001-crypto-mb-Make-sure-libs-are-installed-correctly.patch
@@ -0,0 +1,42 @@
1From 3b7b4eca54aa8d851e37f60c74e4a027fa7b21f2 Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Wed, 14 Jun 2023 13:18:45 +0800
4Subject: [PATCH] crypto-mb: Make sure libs are installed correctly
5
6Dont assume that "lib" is always the correct destination. This fixes
7multilib builds when libdir != /usr/lib.
8
9Upstream-Status: Pending
10
11Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
12---
13 sources/ippcp/crypto_mb/src/CMakeLists.txt | 6 +++---
14 1 file changed, 3 insertions(+), 3 deletions(-)
15
16diff --git a/sources/ippcp/crypto_mb/src/CMakeLists.txt b/sources/ippcp/crypto_mb/src/CMakeLists.txt
17index c9cad06..31f52bd 100644
18--- a/sources/ippcp/crypto_mb/src/CMakeLists.txt
19+++ b/sources/ippcp/crypto_mb/src/CMakeLists.txt
20@@ -123,8 +123,8 @@ endif(DYNAMIC_LIB OR MB_STANDALONE)
21 # Installation of the shared library
22 if (MB_STANDALONE) # standalone crypto_mb's cmake run
23 install(TARGETS ${MB_DYN_LIB_TARGET}
24- LIBRARY DESTINATION "lib"
25- RUNTIME DESTINATION "lib"
26+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
27+ RUNTIME DESTINATION ${CMAKE_INSTALL_LIBDIR}
28 PUBLIC_HEADER DESTINATION "include/crypto_mb")
29 elseif (DYNAMIC_LIB) # build from ippcp's cmake
30 install(TARGETS ${MB_DYN_LIB_TARGET}
31@@ -154,7 +154,7 @@ endif()
32 # Static lib installation
33 if(MB_STANDALONE)
34 install(TARGETS ${MB_STATIC_LIB_TARGET}
35- ARCHIVE DESTINATION "lib"
36+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
37 PUBLIC_HEADER DESTINATION "include/crypto_mb")
38 else()
39 install(TARGETS ${MB_STATIC_LIB_TARGET}
40--
412.37.3
42
diff --git a/recipes-oneapi/crypto/intel-crypto-mb_2021.7.1.bb b/recipes-oneapi/crypto/intel-crypto-mb_2021.7.1.bb
index a11ed04b..36cae430 100644
--- a/recipes-oneapi/crypto/intel-crypto-mb_2021.7.1.bb
+++ b/recipes-oneapi/crypto/intel-crypto-mb_2021.7.1.bb
@@ -12,6 +12,7 @@ SRC_URI = " \
12 git://github.com/intel/ipp-crypto;protocol=https;branch=ipp-crypto_2021_7_1 \ 12 git://github.com/intel/ipp-crypto;protocol=https;branch=ipp-crypto_2021_7_1 \
13 file://0001-CMakeLists.txt-exclude-host-system-headers.patch;striplevel=4 \ 13 file://0001-CMakeLists.txt-exclude-host-system-headers.patch;striplevel=4 \
14 file://0002-cmake-exclude-Yocto-build-flags.patch;striplevel=4 \ 14 file://0002-cmake-exclude-Yocto-build-flags.patch;striplevel=4 \
15 file://0001-crypto-mb-Make-sure-libs-are-installed-correctly.patch;striplevel=4 \
15 " 16 "
16SRCREV = "8e1f90d507bc4d73b3860745d491837c6c57a804" 17SRCREV = "8e1f90d507bc4d73b3860745d491837c6c57a804"
17 18