summaryrefslogtreecommitdiffstats
path: root/recipes-oneapi/onedpl/onedpl_2021.6.1.bb
diff options
context:
space:
mode:
authorezhilarasan s <ezhilarasanx.s@intel.com>2022-02-11 20:06:57 +0530
committerAnuj Mittal <anuj.mittal@intel.com>2022-02-12 00:37:48 +0800
commit623a96b34ea725c667e91a4b1070681e8c221445 (patch)
tree30505b67bdfdf013b76d2622d871001f9e8510d1 /recipes-oneapi/onedpl/onedpl_2021.6.1.bb
parentf847dd524c5596213370a04a02ced978041dd1fb (diff)
downloadmeta-intel-623a96b34ea725c667e91a4b1070681e8c221445.tar.gz
onedpl: upgrade 2021.5.0 -> 2021.6.1
*Fixed compilation errors with C++20. *Fixed CL_OUT_OF_RESOURCES issue for Radix sort algorithm executed on CPU devices. *Fixed crashes in exclusive_scan_by_segment, inclusive_scan_by_segment, reduce_by_segment algorithms applied to device-allocated USM. Signed-off-by: ezhilarasan s <ezhilarasax.s@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'recipes-oneapi/onedpl/onedpl_2021.6.1.bb')
-rw-r--r--recipes-oneapi/onedpl/onedpl_2021.6.1.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes-oneapi/onedpl/onedpl_2021.6.1.bb b/recipes-oneapi/onedpl/onedpl_2021.6.1.bb
new file mode 100644
index 00000000..eb8fccc8
--- /dev/null
+++ b/recipes-oneapi/onedpl/onedpl_2021.6.1.bb
@@ -0,0 +1,26 @@
1SUMMARY = "oneAPI DPC++ Library (oneDPL)"
2DESCRIPTION = "The oneAPI DPC++ Library (oneDPL) aims to work with the \
3oneAPI DPC++ Compiler to provide high-productivity APIs to developers, \
4which can minimize DPC++ programming efforts across devices for high \
5performance parallel applications."
6HOMEPAGE = "https://github.com/oneapi-src/oneDPL"
7
8LICENSE = "Apache-2.0-with-LLVM-exception"
9LIC_FILES_CHKSUM = "file://licensing/LICENSE.txt;md5=2e982d844baa4df1c80de75470e0c5cb \
10 file://licensing/third-party-programs.txt;md5=74cbe473c3521af32a92f662c44aa6bd"
11
12S = "${WORKDIR}/git"
13
14SRC_URI = "git://github.com/oneapi-src/oneDPL.git;protocol=https;branch=release/2021.6 \
15 "
16SRCREV = "bfa2cd2fc07ea105a07d4772276e8c15f7530cd4"
17
18do_compile[noexec] = "1"
19do_configure[noexec] = "1"
20
21do_install() {
22 install -d -m 755 ${D}${includedir}/onedpl
23 cp -r ${S}/include/* ${D}${includedir}/onedpl
24}
25
26UPSTREAM_CHECK_GITTAGREGEX = "^oneDPL-(?P<pver>(\d+(\.\d+)+))-release$"