summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia
diff options
context:
space:
mode:
authorLim Siew Hoon <siew.hoon.lim@intel.com>2023-11-24 09:23:03 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2023-11-24 11:59:50 +0800
commit52ce86a7f5f1ed751d80bc5e1d6b76db1c5b84c8 (patch)
treed88c74003c778e4b17b8643661947c5776616686 /recipes-multimedia
parent989d35a4999a5bed56042d357d57e26232f385dc (diff)
downloadmeta-intel-52ce86a7f5f1ed751d80bc5e1d6b76db1c5b84c8.tar.gz
onevpl-intel-gpu: upgrade 23.2.4 -> 23.3.4
Backport two code fixed: - 0001-Encode-Bugfix-for-HEVC-VDENC-422-RPL-caps-issue.-588.patch - 0001-RT-Common-Fix-MediaAdapterType-issue-5898.patch Release notes: https://github.com/oneapi-src/oneVPL-intel-gpu/releases/tag/intel-onevpl-23.3.4 Signed-off-by: Lim Siew Hoon <siew.hoon.lim@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'recipes-multimedia')
-rw-r--r--recipes-multimedia/onevpl/files/0001-Encode-Bugfix-for-HEVC-VDENC-422-RPL-caps-issue.-588.patch70
-rw-r--r--recipes-multimedia/onevpl/files/0001-RT-Common-Fix-MediaAdapterType-issue-5898.patch36
-rw-r--r--recipes-multimedia/onevpl/onevpl-intel-gpu_23.3.4.bb (renamed from recipes-multimedia/onevpl/onevpl-intel-gpu_23.2.4.bb)4
3 files changed, 109 insertions, 1 deletions
diff --git a/recipes-multimedia/onevpl/files/0001-Encode-Bugfix-for-HEVC-VDENC-422-RPL-caps-issue.-588.patch b/recipes-multimedia/onevpl/files/0001-Encode-Bugfix-for-HEVC-VDENC-422-RPL-caps-issue.-588.patch
new file mode 100644
index 00000000..6209f960
--- /dev/null
+++ b/recipes-multimedia/onevpl/files/0001-Encode-Bugfix-for-HEVC-VDENC-422-RPL-caps-issue.-588.patch
@@ -0,0 +1,70 @@
1From 3830e393b6e2807f842d3cacda575fa715827e62 Mon Sep 17 00:00:00 2001
2From: gfxVPLsdm <gfxvplsdm@intel.com>
3Date: Thu, 19 Oct 2023 13:03:53 +0800
4Subject: [PATCH] [Encode] Bugfix for HEVC VDENC 422 RPL caps issue. (#5886)
5
6Fixed HEVC VDENC 422 RPL caps issue.
7
8Co-authored-by: Wenjuan Zhang <wenjuan.zhang@intel.com>
9
10Upstream-Status: Backport [https://github.com/oneapi-src/oneVPL-intel-gpu/commit/3830e393b6e2807f842d3cacda575fa715827e62]
11Signed-off-by: Lim Siew Hoon <siew.hoon.lim@intel.com>
12---
13 .../hevc/agnostic/base/hevcehw_base_recon422.h | 4 +++-
14 .../hevc/agnostic/base/hevcehw_base_recon422_ext.h | 11 +++++++++++
15 .../hevc/linux/base/hevcehw_base_va_packer_lin.cpp | 2 +-
16 3 files changed, 15 insertions(+), 2 deletions(-)
17
18diff --git a/_studio/mfx_lib/encode_hw/hevc/agnostic/base/hevcehw_base_recon422.h b/_studio/mfx_lib/encode_hw/hevc/agnostic/base/hevcehw_base_recon422.h
19index 24bf5cf2..d150ca1c 100644
20--- a/_studio/mfx_lib/encode_hw/hevc/agnostic/base/hevcehw_base_recon422.h
21+++ b/_studio/mfx_lib/encode_hw/hevc/agnostic/base/hevcehw_base_recon422.h
22@@ -36,7 +36,9 @@ class Recon422
23 public:
24 #define DECL_BLOCK_LIST\
25 DECL_BLOCK(SetCallChain)\
26- DECL_BLOCK(SetRecon422Caps)
27+ DECL_BLOCK(SetRecon422Caps)\
28+ DECL_BLOCK(HardcodeCaps)\
29+ DECL_BLOCK(HardcodeCapsExt)
30 #define DECL_FEATURE_NAME "Base_RECON422"
31 #include "hevcehw_decl_blocks.h"
32
33diff --git a/_studio/mfx_lib/encode_hw/hevc/agnostic/base/hevcehw_base_recon422_ext.h b/_studio/mfx_lib/encode_hw/hevc/agnostic/base/hevcehw_base_recon422_ext.h
34index 165c96b1..63b3c301 100644
35--- a/_studio/mfx_lib/encode_hw/hevc/agnostic/base/hevcehw_base_recon422_ext.h
36+++ b/_studio/mfx_lib/encode_hw/hevc/agnostic/base/hevcehw_base_recon422_ext.h
37@@ -40,6 +40,17 @@ public:
38 {}
39
40 protected:
41+ virtual void Query1WithCaps(const FeatureBlocks& /*blocks*/, TPushQ1 Push) override
42+ {
43+ Push(BLK_HardcodeCaps
44+ , [this](const mfxVideoParam&, mfxVideoParam&, StorageRW& strg) -> mfxStatus
45+ {
46+ auto& caps = HEVCEHW::Base::Glob::EncodeCaps::Get(strg);
47+ caps.YUV422ReconSupport = !caps.Color420Only;
48+ return MFX_ERR_NONE;
49+ });
50+ }
51+
52 virtual void Query1NoCaps(const FeatureBlocks& blocks, TPushQ1 Push) override
53 {
54 using Base::Glob;
55diff --git a/_studio/mfx_lib/encode_hw/hevc/linux/base/hevcehw_base_va_packer_lin.cpp b/_studio/mfx_lib/encode_hw/hevc/linux/base/hevcehw_base_va_packer_lin.cpp
56index 1ffc9388..46a1f69c 100644
57--- a/_studio/mfx_lib/encode_hw/hevc/linux/base/hevcehw_base_va_packer_lin.cpp
58+++ b/_studio/mfx_lib/encode_hw/hevc/linux/base/hevcehw_base_va_packer_lin.cpp
59@@ -60,7 +60,7 @@ void VAPacker::Query1WithCaps(const FeatureBlocks& /*blocks*/, TPushQ1 Push)
60
61 caps.MaxEncodedBitDepth |= (!caps.BitDepth8Only);
62 caps.YUV444ReconSupport |= (!caps.Color420Only && IsOn(par.mfx.LowPower));
63- caps.YUV422ReconSupport &= (!caps.Color420Only);
64+ caps.YUV422ReconSupport &= (!caps.Color420Only && !IsOn(par.mfx.LowPower));
65
66 return MFX_ERR_NONE;
67 });
68--
692.40.1
70
diff --git a/recipes-multimedia/onevpl/files/0001-RT-Common-Fix-MediaAdapterType-issue-5898.patch b/recipes-multimedia/onevpl/files/0001-RT-Common-Fix-MediaAdapterType-issue-5898.patch
new file mode 100644
index 00000000..597cc14d
--- /dev/null
+++ b/recipes-multimedia/onevpl/files/0001-RT-Common-Fix-MediaAdapterType-issue-5898.patch
@@ -0,0 +1,36 @@
1From a694f724e9969575a9c993ff1769850de5673fee Mon Sep 17 00:00:00 2001
2From: gfxVPLsdm <gfxvplsdm@intel.com>
3Date: Mon, 23 Oct 2023 16:57:50 +0800
4Subject: [PATCH] [RT Common] Fix MediaAdapterType issue (#5898)
5
6Co-authored-by: Liu, Rachel <rachel.liu@intel.com>
7
8Upstream-Status: Backport [https://github.com/oneapi-src/oneVPL-intel-gpu/commit/a694f724e9969575a9c993ff1769850de5673fee]
9Signed-off-by: Lim Siew Hoon <siew.hoon.lim@intel.com>
10---
11 _studio/mfx_lib/shared/src/libmfxsw.cpp | 9 +++++++++
12 1 file changed, 9 insertions(+)
13
14diff --git a/_studio/mfx_lib/shared/src/libmfxsw.cpp b/_studio/mfx_lib/shared/src/libmfxsw.cpp
15index 94982359..f85f2d75 100644
16--- a/_studio/mfx_lib/shared/src/libmfxsw.cpp
17+++ b/_studio/mfx_lib/shared/src/libmfxsw.cpp
18@@ -831,6 +831,15 @@ mfxHDL* MFX_CDECL MFXQueryImplsDescription(mfxImplCapsDeliveryFormat format, mfx
19 ah.PushBack(impl.PoolPolicies.Policy) = MFX_ALLOCATION_UNLIMITED;
20 ah.PushBack(impl.PoolPolicies.Policy) = MFX_ALLOCATION_LIMITED;
21
22+ impl.Dev.Version.Version = MFX_STRUCT_VERSION(1, 1);
23+ impl.Dev.MediaAdapterType = MFX_MEDIA_UNKNOWN;
24+
25+ if (auto pCore1_19 = QueryCoreInterface<IVideoCore_API_1_19>(&core, MFXICORE_API_1_19_GUID))
26+ {
27+ mfxPlatform platform = {};
28+ if (MFX_ERR_NONE == pCore1_19->QueryPlatform(&platform))
29+ impl.Dev.MediaAdapterType = platform.MediaAdapterType;
30+ }
31
32 snprintf(impl.Dev.DeviceID, sizeof(impl.Dev.DeviceID), "%x/%d", deviceId, adapterNum);
33 snprintf(impl.ImplName, sizeof(impl.ImplName), "mfx-gen");
34--
352.40.1
36
diff --git a/recipes-multimedia/onevpl/onevpl-intel-gpu_23.2.4.bb b/recipes-multimedia/onevpl/onevpl-intel-gpu_23.3.4.bb
index 2a2233e1..5ba4ff58 100644
--- a/recipes-multimedia/onevpl/onevpl-intel-gpu_23.2.4.bb
+++ b/recipes-multimedia/onevpl/onevpl-intel-gpu_23.3.4.bb
@@ -18,9 +18,11 @@ DEPENDS += "libdrm libva intel-media-driver onevpl pkgconfig-native"
18RDEPENDS:${PN} += "intel-media-driver" 18RDEPENDS:${PN} += "intel-media-driver"
19 19
20SRC_URI = "git://github.com/oneapi-src/oneVPL-intel-gpu.git;protocol=https;nobranch=1;lfs=0 \ 20SRC_URI = "git://github.com/oneapi-src/oneVPL-intel-gpu.git;protocol=https;nobranch=1;lfs=0 \
21 file://0001-Encode-Bugfix-for-HEVC-VDENC-422-RPL-caps-issue.-588.patch \
22 file://0001-RT-Common-Fix-MediaAdapterType-issue-5898.patch \
21 " 23 "
22 24
23SRCREV = "b2af8d128452c4b4c94399f051c3214f11c1dfa9" 25SRCREV = "30963ed30d428ccaf3c80360c8657d9c831cb38c"
24S = "${WORKDIR}/git" 26S = "${WORKDIR}/git"
25 27
26FILES:${PN} += " \ 28FILES:${PN} += " \