summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/onevpl/onevpl_2022.0.3.bb
diff options
context:
space:
mode:
authorYew, Chang Ching <chang.ching.yew@intel.com>2022-02-11 10:24:42 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2022-02-11 12:50:06 +0800
commit840a4824e7f85a7f9fab1bc1fa8814aa6da2bf13 (patch)
tree7e9d86c096bec4a78c59b3f02558c30c7a1ae6ce /recipes-multimedia/onevpl/onevpl_2022.0.3.bb
parentc5ee8853cc2b40e081153271f6b866d4dbdfeac0 (diff)
downloadmeta-intel-840a4824e7f85a7f9fab1bc1fa8814aa6da2bf13.tar.gz
onevpl: upgrade 2021.6.0 -> 2022.0.3
New in This Release =================== * Updated mfxvideo++.h to remove deprecation warnings * Sample* tools select oneVPL 2.x APIs by default * Sample* tool update to support new GPU features * Updates to C++ & Python previews: * AV1 extension buffer support * new property interface * Targets Python 3.7 * Updated documentation and build for OpenVINO interop sample * The libmfx.dll and libmfx.so.2021.1.11 libraries, that had been renamed to libvpl.* have been removed Release notes: https://github.com/oneapi-src/oneVPL/releases/tag/v2022.0.0 Signed-off-by: Yew, Chang Ching <chang.ching.yew@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'recipes-multimedia/onevpl/onevpl_2022.0.3.bb')
-rw-r--r--recipes-multimedia/onevpl/onevpl_2022.0.3.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/recipes-multimedia/onevpl/onevpl_2022.0.3.bb b/recipes-multimedia/onevpl/onevpl_2022.0.3.bb
new file mode 100644
index 00000000..1de48ee6
--- /dev/null
+++ b/recipes-multimedia/onevpl/onevpl_2022.0.3.bb
@@ -0,0 +1,43 @@
1SUMMARY = "oneAPI Video Processing Library"
2DESCRIPTION = "The oneAPI Video Processing Library (oneVPL) provides \
3a single video processing API for encode, decode, and video processing \
4that works across a wide range of accelerators."
5
6HOMEPAGE = "https://github.com/oneapi-src/oneVPL"
7LICENSE = "MIT"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=c18ea6bb4786a26bf4eee88a7424a408 \
9 file://third-party-programs.txt;md5=43ed11c52f754dafaa62e2cfdd2bac13"
10
11SRC_URI = "git://github.com/oneapi-src/oneVPL.git;protocol=https;branch=master \
12 file://0001-Fix-basename-build-issue-with-musl_libc.patch \
13 file://0001-samples-Addin-wayland-scanner-auto-generate-on-cmake.patch \
14 file://0002-sample_misc-Addin-basic-wayland-dmabuf-support.patch \
15 file://0003-sample_misc-use-wayland-dmabuf-to-render-nv12.patch \
16 "
17SRCREV = "efc259f8b7ee5c334bca1a904a503186038bbbdd"
18S = "${WORKDIR}/git"
19
20inherit cmake
21DEPENDS += "libva pkgconfig-native"
22
23PACKAGECONFIG ??= "tools"
24PACKAGECONFIG[tools] = "-DBUILD_TOOLS=ON, -DBUILD_TOOLS=OFF, wayland wayland-native wayland-protocols"
25
26do_install:append() {
27 mkdir -p ${D}${datadir}/oneVPL/samples
28 mv ${D}${bindir}/sample_* ${D}${datadir}/oneVPL/samples
29}
30
31COMPATIBLE_HOST = '(x86_64).*-linux'
32
33PACKAGES += "${PN}-examples"
34
35FILES:${PN}-examples = "${datadir}/oneVPL/examples \
36 "
37
38FILES_SOLIBSDEV = ""
39FILES:${PN}-dev += "${libdir}/libvpl.so"
40
41FILES:${PN} += "${datadir} \
42 ${libdir}/oneVPL/libvpl_wayland.so \
43 "