summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/libva/va-intel.bb
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2018-02-06 16:38:19 +0800
committerCalifornia Sullivan <california.l.sullivan@intel.com>2018-02-16 15:38:35 -0800
commit433e4f31e92e228d2df21646d838a261077a3041 (patch)
tree0225109b8fa7355b4e133800d336d00c5042304f /recipes-multimedia/libva/va-intel.bb
parenta6a0dbc65eb418082b858e259253ee56be9503cf (diff)
downloadmeta-intel-433e4f31e92e228d2df21646d838a261077a3041.tar.gz
intel-vaapi-driver: upgrade to 2.0.0
Major changes: * Bump version to 2.0.0 * Add support for Coffee Lake (aka. CFL) - Decoding: H.264/MPEG-2/VC-1/JPEG/VP8/HEVC/HEVC 10-bit/VP9/VP9 10-bit - Encoding: H.264/MPEG-2/JPEG/VP8/VP9/HEVC/HEVC 10-bit/AVC low power CQP/CBR/VBR mode - VPP: CSC/scaling/NoiseReduction/Deinterlacing{Bob, MotionAdaptive, MotionCompensated}/ColorBalance/STD * Add support for H264 FEI * Add support for HEVC ROI encoding * Add support for intensity compensation for VC-1 decoding * Improve the quality of the H264 encoder on BDW/BSW * Improve the CSC performance between I420/NV12/P010/YUY2/VYUY format * Improve the performace of va{Get, Put}Image for I420/NV12/P010/YUY2/VYUY format * Fix image corruption for VP9 decoding * Fix race condition in wayland support * Fix ROI support in VDEnc support * Fix corrupted stream when using VDEnc CBR/VBR * Fix GCC 7.1.1 warnings/errors * Update the shader for HEVC encoding The upstream package name now is intel-vaapi-driver instead of libva-intel-driver. Updated to point to release tarball instead of git. Also, changed the URLs to point to new project page. Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> Signed-off-by: California Sullivan <california.l.sullivan@intel.com>
Diffstat (limited to 'recipes-multimedia/libva/va-intel.bb')
-rw-r--r--recipes-multimedia/libva/va-intel.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-multimedia/libva/va-intel.bb b/recipes-multimedia/libva/va-intel.bb
index 88539e25..33b81a30 100644
--- a/recipes-multimedia/libva/va-intel.bb
+++ b/recipes-multimedia/libva/va-intel.bb
@@ -7,9 +7,9 @@ S = "${WORKDIR}"
7PR = "r1" 7PR = "r1"
8 8
9def map_valibs(d): 9def map_valibs(d):
10 # The intel implementation requires the libva-intel-driver package 10 # The intel implementation requires the intel-vaapi-driver package
11 if bb.utils.contains('MACHINE_FEATURES', 'va-impl-intel', "1", "0", d) == "1": 11 if bb.utils.contains('MACHINE_FEATURES', 'va-impl-intel', "1", "0", d) == "1":
12 return "libva libva-intel-driver" 12 return "libva intel-vaapi-driver"
13 # All meta-intel video acceleration requires libva 13 # All meta-intel video acceleration requires libva
14 return "libva" 14 return "libva"
15 15