summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/libva/intel-vaapi-driver_2.1.0.bb
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2018-02-21 12:35:15 +0800
committerCalifornia Sullivan <california.l.sullivan@intel.com>2018-02-26 16:55:07 -0800
commit9a4d583c7de4634a22104ca4c88ddf0d560494b6 (patch)
treec20ed9f2a6b65f91509b8bcc1ce6b8aa5e86d32c /recipes-multimedia/libva/intel-vaapi-driver_2.1.0.bb
parente5e3fe42c5a0ebd6d21e1a7acb2725afd8d7693c (diff)
downloadmeta-intel-9a4d583c7de4634a22104ca4c88ddf0d560494b6.tar.gz
intel-vaapi-driver: upgrade to 2.1.0
* Add support for CannonLake (aka. CNL) - Decoding: H.264/MPEG-2/VC-1/JPEG/VP8/HEVC/HEVC 10-bit/VP9/VP9 10-bit - Encoding: H.264/MPEG-2/JPEG/VP8/VP9 - VPP: CSC/scaling/NoiseReduction/Deinterlacing{Bob, MotionAdaptive, MotionCompensated}/ColorBalance/STD * Add support for VC1 interlaced video decoding * Add support for Stats/PreEnc on GEN9 * Add support for vaExportSurfaceHandle() * Add new PCI IDs for CFL * Add minimum resolution query for encoder * Enhance the logging to provide informational messages * Fix VP9 brc issue on KBL Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> Signed-off-by: California Sullivan <california.l.sullivan@intel.com>
Diffstat (limited to 'recipes-multimedia/libva/intel-vaapi-driver_2.1.0.bb')
-rw-r--r--recipes-multimedia/libva/intel-vaapi-driver_2.1.0.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes-multimedia/libva/intel-vaapi-driver_2.1.0.bb b/recipes-multimedia/libva/intel-vaapi-driver_2.1.0.bb
new file mode 100644
index 00000000..d0fbf2da
--- /dev/null
+++ b/recipes-multimedia/libva/intel-vaapi-driver_2.1.0.bb
@@ -0,0 +1,33 @@
1SUMMARY = "VA driver for Intel G45 & HD Graphics family"
2DESCRIPTION = "intel-vaapi-driver is the VA-API implementation \
3for Intel G45 chipsets and Intel HD Graphics for Intel Core \
4processor family."
5
6HOMEPAGE = "https://github.com/intel/intel-vaapi-driver"
7BUGTRACKER = "https://github.com/intel/intel-vaapi-driver/issues"
8
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://COPYING;md5=2e48940f94acb0af582e5ef03537800f"
11
12COMPATIBLE_HOST = '(i.86|x86_64).*-linux'
13
14DEPENDS = "libva libdrm"
15
16SRC_URI = "https://github.com/intel/${BPN}/releases/download/${PV}/${BPN}-${PV}.tar.bz2"
17SRC_URI[md5sum] = "ab4c33ab31183787dece9b99a86f7b8c"
18SRC_URI[sha256sum] = "ecfaf2ccc4b9af7340e002d2ef807d1e33051d4992f1983f5f4d60e516f86bdf"
19
20UPSTREAM_CHECK_URI = "https://github.com/intel/intel-vaapi-driver/releases"
21
22inherit autotools pkgconfig distro_features_check
23
24REQUIRED_DISTRO_FEATURES = "opengl"
25
26PACKAGECONFIG ??= "${@bb.utils.contains("DISTRO_FEATURES", "x11", "x11", "", d)} \
27 ${@bb.utils.contains("DISTRO_FEATURES", "opengl wayland", "wayland", "", d)}"
28PACKAGECONFIG[x11] = "--enable-x11,--disable-x11"
29PACKAGECONFIG[wayland] = "--enable-wayland,--disable-wayland,wayland wayland-native virtual/egl"
30
31FILES_${PN} += "${libdir}/dri/*.so"
32FILES_${PN}-dev += "${libdir}/dri/*.la"
33FILES_${PN}-dbg += "${libdir}/dri/.debug"