summaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
authorCalifornia Sullivan <california.l.sullivan@intel.com>2018-04-06 11:32:15 -0700
committerCalifornia Sullivan <california.l.sullivan@intel.com>2018-04-09 13:35:12 -0700
commit5130b9006301694cd60f95bff46b17d0555deff8 (patch)
treebfec86dcb38b53e0ab78962c19e0c0ca79c132b2 /recipes-kernel
parent723c7b8624d6e37a1e2da50eccd75159476c9414 (diff)
downloadmeta-intel-5130b9006301694cd60f95bff46b17d0555deff8.tar.gz
ixgbevf: update to v4.3.4
Also remove the python snippet limiting it to pre-4.14 kernels, as the new version is compatible. Signed-off-by: California Sullivan <california.l.sullivan@intel.com>
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/intel-ethernet/ixgbevf.bb15
1 files changed, 3 insertions, 12 deletions
diff --git a/recipes-kernel/intel-ethernet/ixgbevf.bb b/recipes-kernel/intel-ethernet/ixgbevf.bb
index 025ee081..bb00e354 100644
--- a/recipes-kernel/intel-ethernet/ixgbevf.bb
+++ b/recipes-kernel/intel-ethernet/ixgbevf.bb
@@ -6,7 +6,7 @@ SECTION = "kernel/network"
6LICENSE = "GPLv2" 6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://${WORKDIR}/${PN}-${PV}/COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" 7LIC_FILES_CHKSUM = "file://${WORKDIR}/${PN}-${PV}/COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
8 8
9PV = "4.1.2" 9PV = "4.3.4"
10PR = "r0" 10PR = "r0"
11 11
12SRC_URI = "https://sourceforge.net/projects/e1000/files/ixgbevf%20stable/${PV}/ixgbevf-${PV}.tar.gz \ 12SRC_URI = "https://sourceforge.net/projects/e1000/files/ixgbevf%20stable/${PV}/ixgbevf-${PV}.tar.gz \
@@ -15,8 +15,8 @@ SRC_URI = "https://sourceforge.net/projects/e1000/files/ixgbevf%20stable/${PV}/i
15 file://0001-ixgbevf-skip-host-depmod.patch \ 15 file://0001-ixgbevf-skip-host-depmod.patch \
16 " 16 "
17 17
18SRC_URI[md5sum] = "f02ec46369d1ca949a1e9d2e0eb74d5f" 18SRC_URI[md5sum] = "9459bf9ac4b2b827bee2ff147d192622"
19SRC_URI[sha256sum] = "ab2824541f8a2d8f7b7d26ccbb46359ef551c5d4625fb333014e2b8023ac3ab6" 19SRC_URI[sha256sum] = "63a6568be16347e19bae74238d739cd7ffa83a6236c6d8e25d2539d46cb25f88"
20 20
21S = "${WORKDIR}/${PN}-${PV}/src" 21S = "${WORKDIR}/${PN}-${PV}/src"
22SCRIPT_DIR = "${WORKDIR}/${PN}-${PV}/scripts" 22SCRIPT_DIR = "${WORKDIR}/${PN}-${PV}/scripts"
@@ -44,12 +44,3 @@ FILES_${PN}-script += "/etc/network/set_irq_affinity"
44 44
45#Ignore "ERROR: QA Issue: ixgbe: Files/directories were installed but not shipped" 45#Ignore "ERROR: QA Issue: ixgbe: Files/directories were installed but not shipped"
46INSANE_SKIP_${PN} = "installed-vs-shipped" 46INSANE_SKIP_${PN} = "installed-vs-shipped"
47
48# Support for 4.14 not yet available
49python () {
50 if d.getVar("PREFERRED_PROVIDER_virtual/kernel") == "linux-intel" and \
51 d.getVar("PREFERRED_VERSION_linux-intel") == "4.14%" or \
52 d.getVar("PREFERRED_PROVIDER_virtual/kernel") == "linux-intel-rt" and \
53 d.getVar("PREFERRED_VERSION_linux-intel-rt") == "4.14%":
54 raise bb.parse.SkipPackage("Out of tree ixgbevf not yet available for Linux Kernel 4.14 or newer")
55}