summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux
diff options
context:
space:
mode:
authorTeoh Suh Haw <suh.haw.teoh@intel.com>2023-05-26 11:19:53 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2023-05-30 09:55:36 +0800
commite7ef28957a910a723d337a365ab51c93052aee35 (patch)
tree4fa506d6d28020b5e01872925050603e488183e5 /recipes-kernel/linux
parent92ed65a34f79ada1306f5d23ab7271fd41c819bc (diff)
downloadmeta-intel-e7ef28957a910a723d337a365ab51c93052aee35.tar.gz
linux-intel-rt/6.1: add recipe
*Replace v5.19 with linux-intel-lts v6.1.26-rt8 kernel. *Make linux-intel-lts v6.1.26 the default RT kernel for poky and poky-altcfg. Signed-off-by: Teoh Suh Haw <suh.haw.teoh@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'recipes-kernel/linux')
-rw-r--r--recipes-kernel/linux/linux-intel-rt_6.1.bb (renamed from recipes-kernel/linux/linux-intel-rt_5.19.bb)22
1 files changed, 14 insertions, 8 deletions
diff --git a/recipes-kernel/linux/linux-intel-rt_5.19.bb b/recipes-kernel/linux/linux-intel-rt_6.1.bb
index 4ff9e0fe..2a93062d 100644
--- a/recipes-kernel/linux/linux-intel-rt_5.19.bb
+++ b/recipes-kernel/linux/linux-intel-rt_6.1.bb
@@ -1,7 +1,8 @@
1require linux-intel.inc 1require linux-intel.inc
2 2
3SRC_URI:prepend = "git://github.com/intel/mainline-tracking.git;protocol=https;name=machine;nobranch=1; \ 3SRC_URI:prepend = "git://github.com/intel/linux-intel-lts.git;protocol=https;name=machine;branch=${KBRANCH}; \
4 " 4 "
5
5# Skip processing of this recipe if it is not explicitly specified as the 6# Skip processing of this recipe if it is not explicitly specified as the
6# PREFERRED_PROVIDER for virtual/kernel. This avoids errors when trying 7# PREFERRED_PROVIDER for virtual/kernel. This avoids errors when trying
7# to build multiple virtual/kernel providers, e.g. as dependency of 8# to build multiple virtual/kernel providers, e.g. as dependency of
@@ -11,17 +12,22 @@ python () {
11 raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-intel-rt to enable it") 12 raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-intel-rt to enable it")
12} 13}
13 14
14LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46" 15KBRANCH = "6.1/preempt-rt"
16KMETA_BRANCH = "yocto-6.1"
15 17
16KMETA_BRANCH = "yocto-5.19" 18LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
17 19
18DEPENDS += "elfutils-native openssl-native util-linux-native" 20DEPENDS += "elfutils-native openssl-native util-linux-native"
19 21
20LINUX_VERSION_EXTENSION ??= "-mainline-tracking-${LINUX_KERNEL_TYPE}" 22LINUX_VERSION_EXTENSION ??= "-intel-pk-${LINUX_KERNEL_TYPE}"
21 23
22LINUX_VERSION ?= "5.19.0" 24LINUX_VERSION ?= "6.1.26"
23SRCREV_machine ?= "3abe09b48ca3c13b50c78d3b7b0d7ce668211a70" 25SRCREV_machine ?= "de05aba07179c0782af8abfbc8abd05bd3f00735"
24SRCREV_meta ?= "f5d4c109d6de04005def04c3a06f053ae0c397ad" 26SRCREV_meta ?= "6c9bc579ad765338fad63685f7d4dd5773fa2416"
25 27
26LINUX_KERNEL_TYPE = "preempt-rt" 28LINUX_KERNEL_TYPE = "preempt-rt"
27UPSTREAM_CHECK_GITTAGREGEX = "^mainline-tracking-v5.19-(?P<pver>rt(\d+)-preempt-rt-(\d+)T(\d+)Z)$" 29
30# Functionality flags
31KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc features/security/security.scc"
32
33UPSTREAM_CHECK_GITTAGREGEX = "^lts-(?P<pver>v6.1.(\d+)-rt(\d)-preempt-rt-(\d+)T(\d+)Z)$"