summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux
diff options
context:
space:
mode:
authorNaveen Saini <naveen.kumar.saini@intel.com>2022-11-18 12:09:12 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2022-11-18 11:55:06 +0800
commit2ce9b55f99a30e810aed196888c0858f4996e26e (patch)
tree88de09e2d21504098b8ee6911f38b6928d6810ea /recipes-kernel/linux
parent585655e5be85330fdbf105eb7e0370ba9af99f81 (diff)
downloadmeta-intel-2ce9b55f99a30e810aed196888c0858f4996e26e.tar.gz
linux-intel/5.19: add recipe
Build 5.19 kernel version from mainline-tracking tree at: https://github.com/intel/mainline-tracking This will track the mainline kernel and will be used to enable support for newer platforms. Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'recipes-kernel/linux')
-rw-r--r--recipes-kernel/linux/linux-intel-rt_5.15.bb6
-rw-r--r--recipes-kernel/linux/linux-intel.inc4
-rw-r--r--recipes-kernel/linux/linux-intel_5.15.bb6
-rw-r--r--recipes-kernel/linux/linux-intel_5.19.bb20
4 files changed, 32 insertions, 4 deletions
diff --git a/recipes-kernel/linux/linux-intel-rt_5.15.bb b/recipes-kernel/linux/linux-intel-rt_5.15.bb
index d05214bc..b6e0e3e4 100644
--- a/recipes-kernel/linux/linux-intel-rt_5.15.bb
+++ b/recipes-kernel/linux/linux-intel-rt_5.15.bb
@@ -1,5 +1,9 @@
1require linux-intel.inc 1require linux-intel.inc
2 2
3SRC_URI:prepend = "git://github.com/intel/linux-intel-lts.git;protocol=https;name=machine;branch=${KBRANCH}; \
4 "
5SRC_URI:append = " file://0001-menuconfig-mconf-cfg-Allow-specification-of-ncurses-.patch"
6
3# Skip processing of this recipe if it is not explicitly specified as the 7# Skip processing of this recipe if it is not explicitly specified as the
4# PREFERRED_PROVIDER for virtual/kernel. This avoids errors when trying 8# PREFERRED_PROVIDER for virtual/kernel. This avoids errors when trying
5# to build multiple virtual/kernel providers, e.g. as dependency of 9# to build multiple virtual/kernel providers, e.g. as dependency of
@@ -16,6 +20,8 @@ KMETA_BRANCH = "yocto-5.15"
16 20
17DEPENDS += "elfutils-native openssl-native util-linux-native" 21DEPENDS += "elfutils-native openssl-native util-linux-native"
18 22
23LINUX_VERSION_EXTENSION ??= "-intel-pk-${LINUX_KERNEL_TYPE}"
24
19LINUX_VERSION ?= "5.15.71" 25LINUX_VERSION ?= "5.15.71"
20SRCREV_machine ?= "e29405e36bfbda7ace776548de802b76f61b80d9" 26SRCREV_machine ?= "e29405e36bfbda7ace776548de802b76f61b80d9"
21SRCREV_meta ?= "50e12441b95837206d02d3ecfd17b1c562759d76" 27SRCREV_meta ?= "50e12441b95837206d02d3ecfd17b1c562759d76"
diff --git a/recipes-kernel/linux/linux-intel.inc b/recipes-kernel/linux/linux-intel.inc
index 7e2823f0..b54d634b 100644
--- a/recipes-kernel/linux/linux-intel.inc
+++ b/recipes-kernel/linux/linux-intel.inc
@@ -6,16 +6,12 @@ FILESEXTRAPATHS:prepend := "${THISDIR}/linux-intel:"
6KERNEL_CONFIG_URI ?= "git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=${KMETA_BRANCH};destsuffix=${KMETA}" 6KERNEL_CONFIG_URI ?= "git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=${KMETA_BRANCH};destsuffix=${KMETA}"
7 7
8SRC_URI = " \ 8SRC_URI = " \
9 git://github.com/intel/linux-intel-lts.git;protocol=https;name=machine;branch=${KBRANCH}; \
10 ${KERNEL_CONFIG_URI} \ 9 ${KERNEL_CONFIG_URI} \
11 file://0001-menuconfig-mconf-cfg-Allow-specification-of-ncurses-.patch \
12 file://0001-vt-conmakehash-improve-reproducibility.patch \ 10 file://0001-vt-conmakehash-improve-reproducibility.patch \
13 file://0001-lib-build_OID_registry-fix-reproducibility-issues.patch \ 11 file://0001-lib-build_OID_registry-fix-reproducibility-issues.patch \
14 file://fix-perf-reproducibility.patch \ 12 file://fix-perf-reproducibility.patch \
15 " 13 "
16 14
17LINUX_VERSION_EXTENSION ??= "-intel-pk-${LINUX_KERNEL_TYPE}"
18
19PV = "${LINUX_VERSION}+git${SRCPV}" 15PV = "${LINUX_VERSION}+git${SRCPV}"
20 16
21KMETA = "kernel-meta" 17KMETA = "kernel-meta"
diff --git a/recipes-kernel/linux/linux-intel_5.15.bb b/recipes-kernel/linux/linux-intel_5.15.bb
index 17fed99e..644ae0d1 100644
--- a/recipes-kernel/linux/linux-intel_5.15.bb
+++ b/recipes-kernel/linux/linux-intel_5.15.bb
@@ -1,5 +1,9 @@
1require linux-intel.inc 1require linux-intel.inc
2 2
3SRC_URI:prepend = "git://github.com/intel/linux-intel-lts.git;protocol=https;name=machine;branch=${KBRANCH}; \
4 "
5SRC_URI:append = " file://0001-menuconfig-mconf-cfg-Allow-specification-of-ncurses-.patch"
6
3KBRANCH = "5.15/linux" 7KBRANCH = "5.15/linux"
4KMETA_BRANCH = "yocto-5.15" 8KMETA_BRANCH = "yocto-5.15"
5 9
@@ -7,6 +11,8 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
7 11
8DEPENDS += "elfutils-native openssl-native util-linux-native" 12DEPENDS += "elfutils-native openssl-native util-linux-native"
9 13
14LINUX_VERSION_EXTENSION ??= "-intel-pk-${LINUX_KERNEL_TYPE}"
15
10LINUX_VERSION ?= "5.15.71" 16LINUX_VERSION ?= "5.15.71"
11SRCREV_machine ?= "7f0de68338ad7f625a7137278bf1d0a5edcbab45" 17SRCREV_machine ?= "7f0de68338ad7f625a7137278bf1d0a5edcbab45"
12SRCREV_meta ?= "50e12441b95837206d02d3ecfd17b1c562759d76" 18SRCREV_meta ?= "50e12441b95837206d02d3ecfd17b1c562759d76"
diff --git a/recipes-kernel/linux/linux-intel_5.19.bb b/recipes-kernel/linux/linux-intel_5.19.bb
new file mode 100644
index 00000000..82d02fcd
--- /dev/null
+++ b/recipes-kernel/linux/linux-intel_5.19.bb
@@ -0,0 +1,20 @@
1require linux-intel.inc
2
3SRC_URI:prepend = "git://github.com/intel/mainline-tracking.git;protocol=https;name=machine;nobranch=1; \
4 "
5SRC_URI:append = " file://0001-v5.19-menuconfig-mconf-cfg-Allow-specification-of-ncurses-.patch"
6
7KMETA_BRANCH = "yocto-5.19"
8
9LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
10
11DEPENDS += "elfutils-native openssl-native util-linux-native"
12
13LINUX_VERSION_EXTENSION ??= "-mainline-tracking-${LINUX_KERNEL_TYPE}"
14
15LINUX_VERSION ?= "5.19.0"
16SRCREV_machine ?= "20024f44f7ef62c5c4bd030a858e6b44ea2541ec"
17SRCREV_meta ?= "0cba9aa40445bf59bfa651e1bd43a31c2ca7d524"
18
19# Functionality flags
20KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc features/security/security.scc"