summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-yocto-tiny_4.9.bbappend
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2017-11-07 10:32:26 -0800
committerSaul Wold <sgw@linux.intel.com>2017-11-20 15:33:02 -0800
commitd53dbb38c43da3fd04fed9a55e7b3b9e2c512b9a (patch)
treefbe372dba00d45bbf9fbfbb3726708dc2590daeb /recipes-kernel/linux/linux-yocto-tiny_4.9.bbappend
parent5adbf6df4fd89e7531ccccfb9cec7a5314d635f0 (diff)
downloadmeta-intel-d53dbb38c43da3fd04fed9a55e7b3b9e2c512b9a.tar.gz
meta-intel: Reorganize the layout to remove common
Remove the concept of the common directory and move all the recipes-* dirs to the top level as a normal layer would be. layer.conf is updated appropriately Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'recipes-kernel/linux/linux-yocto-tiny_4.9.bbappend')
-rw-r--r--recipes-kernel/linux/linux-yocto-tiny_4.9.bbappend31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-yocto-tiny_4.9.bbappend b/recipes-kernel/linux/linux-yocto-tiny_4.9.bbappend
new file mode 100644
index 00000000..9ecdb95a
--- /dev/null
+++ b/recipes-kernel/linux/linux-yocto-tiny_4.9.bbappend
@@ -0,0 +1,31 @@
1FILESEXTRAPATHS_prepend_intel-x86-common := "${THISDIR}/${PN}:"
2
3EXTRA_OEMAKE = "LD=${STAGING_BINDIR_NATIVE}/${HOST_SYS}/${TARGET_PREFIX}ld AR=${STAGING_BINDIR_NATIVE}/${HOST_SYS}/${TARGET_PREFIX}gcc-ar"
4
5LINUX_VERSION_i586-nlp-32-intel-common = "4.9.13"
6LINUX_VERSION_core2-32-intel-common = "4.9.13"
7LINUX_VERSION_corei7-64-intel-common = "4.9.13"
8
9SRCREV_meta_i586-nlp-32-intel-common = "8f3bc608ae61c5333043167fa31bac33be93c3de"
10SRCREV_meta_core2-32-intel-common = "8f3bc608ae61c5333043167fa31bac33be93c3de"
11SRCREV_meta_corei7-64-intel-common = "8f3bc608ae61c5333043167fa31bac33be93c3de"
12
13SRCREV_machine_i586-nlp-32-intel-common = "95c0a80ee83f1cf8e59d733f36e8a9dfd50a0098"
14SRCREV_machine_core2-32-intel-common = "95c0a80ee83f1cf8e59d733f36e8a9dfd50a0098"
15SRCREV_machine_corei7-64-intel-common = "95c0a80ee83f1cf8e59d733f36e8a9dfd50a0098"
16
17COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}"
18COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
19COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
20
21KBRANCH_i586-nlp-32-intel-common = "standard/tiny/base"
22KBRANCH_core2-32-intel-common = "standard/tiny/base"
23KBRANCH_corei7-64-intel-common = "standard/tiny/base"
24
25KMACHINE_i586-nlp-32-intel-common = "intel-quark"
26KMACHINE_core2-32-intel-common = "intel-core2-32"
27KMACHINE_corei7-64-intel-common = "intel-corei7-64"
28
29KERNEL_FEATURES_append_i586-nlp-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} cfg/fs/ext4.scc"
30KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} cfg/fs/ext4.scc"
31KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} cfg/fs/ext4.scc"