summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-yocto-tiny_4.10.bbappend
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2017-11-07 10:32:26 -0800
committerSaul Wold <sgw@linux.intel.com>2017-11-20 15:33:02 -0800
commitd53dbb38c43da3fd04fed9a55e7b3b9e2c512b9a (patch)
treefbe372dba00d45bbf9fbfbb3726708dc2590daeb /recipes-kernel/linux/linux-yocto-tiny_4.10.bbappend
parent5adbf6df4fd89e7531ccccfb9cec7a5314d635f0 (diff)
downloadmeta-intel-d53dbb38c43da3fd04fed9a55e7b3b9e2c512b9a.tar.gz
meta-intel: Reorganize the layout to remove common
Remove the concept of the common directory and move all the recipes-* dirs to the top level as a normal layer would be. layer.conf is updated appropriately Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'recipes-kernel/linux/linux-yocto-tiny_4.10.bbappend')
-rw-r--r--recipes-kernel/linux/linux-yocto-tiny_4.10.bbappend19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-yocto-tiny_4.10.bbappend b/recipes-kernel/linux/linux-yocto-tiny_4.10.bbappend
new file mode 100644
index 00000000..b8d3d81c
--- /dev/null
+++ b/recipes-kernel/linux/linux-yocto-tiny_4.10.bbappend
@@ -0,0 +1,19 @@
1FILESEXTRAPATHS_prepend_intel-x86-common := "${THISDIR}/${PN}:"
2
3KERNEL_FEATURES_INTEL_COMMON ?= ""
4
5COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}"
6COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
7COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
8
9KBRANCH_i586-nlp-32-intel-common = "standard/tiny/base"
10KBRANCH_core2-32-intel-common = "standard/tiny/base"
11KBRANCH_corei7-64-intel-common = "standard/tiny/base"
12
13KMACHINE_i586-nlp-32-intel-common = "intel-quark"
14KMACHINE_core2-32-intel-common = "intel-core2-32"
15KMACHINE_corei7-64-intel-common = "intel-corei7-64"
16
17KERNEL_FEATURES_append_i586-nlp-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} cfg/fs/ext4.scc"
18KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} cfg/fs/ext4.scc"
19KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} cfg/fs/ext4.scc"