summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-yocto-dev.bbappend
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2017-11-07 10:32:26 -0800
committerSaul Wold <sgw@linux.intel.com>2017-11-20 15:33:02 -0800
commitd53dbb38c43da3fd04fed9a55e7b3b9e2c512b9a (patch)
treefbe372dba00d45bbf9fbfbb3726708dc2590daeb /recipes-kernel/linux/linux-yocto-dev.bbappend
parent5adbf6df4fd89e7531ccccfb9cec7a5314d635f0 (diff)
downloadmeta-intel-d53dbb38c43da3fd04fed9a55e7b3b9e2c512b9a.tar.gz
meta-intel: Reorganize the layout to remove common
Remove the concept of the common directory and move all the recipes-* dirs to the top level as a normal layer would be. layer.conf is updated appropriately Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'recipes-kernel/linux/linux-yocto-dev.bbappend')
-rw-r--r--recipes-kernel/linux/linux-yocto-dev.bbappend26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-yocto-dev.bbappend b/recipes-kernel/linux/linux-yocto-dev.bbappend
new file mode 100644
index 00000000..ee33ecc3
--- /dev/null
+++ b/recipes-kernel/linux/linux-yocto-dev.bbappend
@@ -0,0 +1,26 @@
1FILESEXTRAPATHS_prepend_intel-x86-common := "${THISDIR}/${PN}:"
2
3COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
4KMACHINE_core2-32-intel-common = "intel-core2-32"
5KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
6
7COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
8KMACHINE_corei7-64-intel-common = "intel-corei7-64"
9KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
10
11# Quark / X1000 BSP Info
12COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}"
13KMACHINE_i586-nlp-32-intel-common = "intel-quark"
14KERNEL_FEATURES_append_i586-nlp-32-intel-common = ""
15
16# NOTE: We do not set SRCREVs here as -dev is intended to be built with AUTOREV
17# and setting them here breaks the default mechanism to use AUTOREV if the
18# default SRCREV is set and linux-yocto-dev is the preferred provider.
19
20# For Crystalforest and Romley
21KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio"
22KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " uio"
23
24# For FRI2, NUC
25KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " iwlwifi"
26KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " iwlwifi"