summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-intel_4.19.bb
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2018-11-24 11:30:46 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2018-12-05 14:42:27 +0800
commit13ae1339c24a5d431274bdd324048f1043045ae5 (patch)
tree6141b8f56c85dae757c370e5811930e0635714cc /recipes-kernel/linux/linux-intel_4.19.bb
parentf7a9272983abac3a5269286f8d214765f49af656 (diff)
downloadmeta-intel-13ae1339c24a5d431274bdd324048f1043045ae5.tar.gz
linux-intel/4.19: add recipe
Builds 4.19/base from linux-intel-lts. Include a patch from linux-yocto 4.18 to detect ncurses correctly when cross-compiling and move the older patch to version specific recipes from inc. In addition to intel-common kernel configs from yocto-kernel-cache, this also includes security.scc feature which enables a set of configs with the aim of reducing the kernel attack surface and/or of performing additional checks and validation of commonly used structures in kernel. Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'recipes-kernel/linux/linux-intel_4.19.bb')
-rw-r--r--recipes-kernel/linux/linux-intel_4.19.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-intel_4.19.bb b/recipes-kernel/linux/linux-intel_4.19.bb
new file mode 100644
index 00000000..02353d26
--- /dev/null
+++ b/recipes-kernel/linux/linux-intel_4.19.bb
@@ -0,0 +1,21 @@
1require linux-intel.inc
2
3KBRANCH = "4.19/base"
4KMETA_BRANCH = "yocto-4.19"
5
6LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
7
8SRC_URI_append = " file://0001-menuconfig-mconf-cfg-Allow-specification-of-ncurses-.patch"
9
10DEPENDS += "elfutils-native openssl-native util-linux-native"
11
12LINUX_VERSION ?= "4.19.0"
13SRCREV_machine ?= "a13be70e5ba050d848fc4005add46ca89bb8e6e6"
14SRCREV_meta ?= "26bfb042ebb6e4816c5a8ce85d97a55e763430c7"
15
16# For Crystalforest and Romley
17KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio"
18KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " uio"
19
20# Functionality flags
21KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc features/security/security.scc"