summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/libva
diff options
context:
space:
mode:
authorLim Siew Hoon <siew.hoon.lim@intel.com>2023-02-08 10:40:18 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2023-02-08 15:54:42 +0800
commit535790ae427b18feac95c2a865946e6fd2ca9890 (patch)
treea99626bcd7ea8bc4e4b80475db066cae5caf15b8 /recipes-graphics/libva
parentfe0c4e64a058c2a73377457d968c835c72c7552e (diff)
downloadmeta-intel-535790ae427b18feac95c2a865946e6fd2ca9890.tar.gz
libva-intel: upgrade 2.16.0 -> 2.17.0
Signed-off-by: Lim Siew Hoon <siew.hoon.lim@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'recipes-graphics/libva')
-rw-r--r--recipes-graphics/libva/files/0001-Add-missing-libva.def.patch115
-rw-r--r--recipes-graphics/libva/libva-intel_2.17.0.bb (renamed from recipes-graphics/libva/libva-intel_2.16.0.bb)6
2 files changed, 119 insertions, 2 deletions
diff --git a/recipes-graphics/libva/files/0001-Add-missing-libva.def.patch b/recipes-graphics/libva/files/0001-Add-missing-libva.def.patch
new file mode 100644
index 00000000..a6dafd61
--- /dev/null
+++ b/recipes-graphics/libva/files/0001-Add-missing-libva.def.patch
@@ -0,0 +1,115 @@
1From 124cea5f0ecb94320502d9f1923df53df61fa9f1 Mon Sep 17 00:00:00 2001
2From: Lim Siew Hoon <siew.hoon.lim@intel.com>
3Date: Tue, 7 Feb 2023 10:33:49 +0800
4Subject: [PATCH] Add missing libva.def
5
6The libva.def is missing from tarball, but from github
7it did contains libva.def. Without this libva.def it will
8be fail in meson configure the source code, it complain missing
9va/libva.def.
10
11This file is importing from:
12https://github.com/intel/libva/blob/2.17.0/va/libva.def
13
14upstream-status: merged.
15
16Signed-off-by: Lim Siew Hoon <siew.hoon.lim@intel.com>
17---
18 va/libva.def | 85 ++++++++++++++++++++++++++++++++++++++++++++++++++++
19 1 file changed, 85 insertions(+)
20 create mode 100644 va/libva.def
21
22diff --git a/va/libva.def b/va/libva.def
23new file mode 100644
24index 0000000..f57896e
25--- /dev/null
26+++ b/va/libva.def
27@@ -0,0 +1,85 @@
28+LIBRARY va
29+EXPORTS
30+ vaInitialize
31+ vaErrorStr
32+ vaTerminate
33+ vaQueryVendorString
34+ vaMaxNumProfiles
35+ vaMaxNumEntrypoints
36+ vaQueryConfigProfiles
37+ vaQueryConfigEntrypoints
38+ vaGetConfigAttributes
39+ vaProfileStr
40+ vaEntrypointStr
41+ vaConfigAttribTypeStr
42+ vaAcquireBufferHandle
43+ vaAssociateSubpicture
44+ vaBeginPicture
45+ vaCreateBuffer
46+ vaCreateConfig
47+ vaCreateContext
48+ vaCreateImage
49+ vaCreateSubpicture
50+ vaCreateSurfaces
51+ vaDeassociateSubpicture
52+ vaDeriveImage
53+ vaDestroyBuffer
54+ vaDestroyConfig
55+ vaDestroyContext
56+ vaDestroyImage
57+ vaDestroySubpicture
58+ vaDestroySurfaces
59+ vaEndPicture
60+ vaGetDisplayAttributes
61+ vaGetImage
62+ vaMapBuffer
63+ vaMaxNumDisplayAttributes
64+ vaMaxNumImageFormats
65+ vaMaxNumSubpictureFormats
66+ vaPutImage
67+ vaQueryDisplayAttributes
68+ vaQueryImageFormats
69+ vaQuerySubpictureFormats
70+ vaQuerySurfaceAttributes
71+ vaQuerySurfaceStatus
72+ vaQueryVideoProcFilterCaps
73+ vaQueryVideoProcFilters
74+ vaQueryVideoProcPipelineCaps
75+ vaReleaseBufferHandle
76+ vaRenderPicture
77+ vaSetDisplayAttributes
78+ vaSetErrorCallback
79+ vaSetInfoCallback
80+ vaSetSubpictureGlobalAlpha
81+ vaSyncSurface
82+ vaUnmapBuffer
83+ vaSetDriverName
84+ vaSyncBuffer
85+ vaQueryConfigAttributes
86+ vaBufferSetNumElements
87+ vaQuerySurfaceError
88+ vaSetImagePalette
89+ vaSetSubpictureChromakey
90+ vaBufferInfo
91+ vaLockSurface
92+ vaUnlockSurface
93+ vaCreateMFContext
94+ vaMFAddContext
95+ vaMFReleaseContext
96+ vaMFSubmit
97+ vaCreateBuffer2
98+ vaQueryProcessingRate
99+ vaExportSurfaceHandle
100+ va_newDisplayContext
101+ va_newDriverContext
102+ vaMaxNumConfigAttributes
103+ vaBufferTypeStr
104+ vaAttachProtectedSession
105+ vaCopy
106+ vaCreateProtectedSession
107+ vaDestroyProtectedSession
108+ vaDetachProtectedSession
109+ vaProtectedSessionExecute
110+ vaSetSubpictureImage
111+ vaStatusStr
112+ vaSyncSurface2
113--
1142.39.0
115
diff --git a/recipes-graphics/libva/libva-intel_2.16.0.bb b/recipes-graphics/libva/libva-intel_2.17.0.bb
index 3077a7e8..4225b09f 100644
--- a/recipes-graphics/libva/libva-intel_2.16.0.bb
+++ b/recipes-graphics/libva/libva-intel_2.17.0.bb
@@ -17,8 +17,10 @@ SECTION = "x11"
17LICENSE = "MIT" 17LICENSE = "MIT"
18LIC_FILES_CHKSUM = "file://COPYING;md5=2e48940f94acb0af582e5ef03537800f" 18LIC_FILES_CHKSUM = "file://COPYING;md5=2e48940f94acb0af582e5ef03537800f"
19 19
20SRC_URI = "https://github.com/intel/libva/releases/download/${PV}/libva-${PV}.tar.bz2" 20SRC_URI = "https://github.com/intel/libva/releases/download/${PV}/libva-${PV}.tar.bz2 \
21SRC_URI[sha256sum] = "115faca0db2c417a37da49830870e260450fa13066f5e24e252a20c36d920a1c" 21 file://0001-Add-missing-libva.def.patch \
22 "
23SRC_URI[sha256sum] = "f3e5eb27c305e05a9bb62703d1915a127301cc0c4f9f209025767432230c4eac"
22 24
23S = "${WORKDIR}/libva-${PV}" 25S = "${WORKDIR}/libva-${PV}"
24 26