summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/gmmlib
diff options
context:
space:
mode:
authorLim Siew Hoon <siew.hoon.lim@intel.com>2024-02-26 10:27:30 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2024-02-26 14:15:35 +0800
commita74c65c74955326c6399ab3d8176729509ea4b88 (patch)
tree44190780735e0d2bc509228363688c7c50564627 /recipes-graphics/gmmlib
parentef763abc2c02a1a3ec0f1280d742421c43606fcc (diff)
downloadmeta-intel-a74c65c74955326c6399ab3d8176729509ea4b88.tar.gz
gmmlib: upgrade 22.3.12 -> 22.3.15
Added a patches for new ARL-H device id support: - 0001-Introduce-ARL-H-support-172.patch Remove a patches already merged: - 0001-Add-more-DG2-Device-IDs.patch Signed-off-by: Lim Siew Hoon <siew.hoon.lim@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'recipes-graphics/gmmlib')
-rw-r--r--recipes-graphics/gmmlib/files/0001-Add-more-DG2-Device-IDs.patch30
-rw-r--r--recipes-graphics/gmmlib/files/0001-Introduce-ARL-H-support-172.patch42
-rw-r--r--recipes-graphics/gmmlib/gmmlib_22.3.15.bb (renamed from recipes-graphics/gmmlib/gmmlib_22.3.12.bb)4
3 files changed, 44 insertions, 32 deletions
diff --git a/recipes-graphics/gmmlib/files/0001-Add-more-DG2-Device-IDs.patch b/recipes-graphics/gmmlib/files/0001-Add-more-DG2-Device-IDs.patch
deleted file mode 100644
index d1e93114..00000000
--- a/recipes-graphics/gmmlib/files/0001-Add-more-DG2-Device-IDs.patch
+++ /dev/null
@@ -1,30 +0,0 @@
1From 92d702f885ae7bbfcd5b480c262db805ccc580bf Mon Sep 17 00:00:00 2001
2From: John Machado <john.machado@intel.com>
3Date: Thu, 16 Nov 2023 12:25:16 +0530
4Subject: [PATCH] Add more DG2 Device IDs
5
6Upstream-Status: Backport [https://github.com/intel/gmmlib/commit/92d702f885ae7bbfcd5b480c262db805ccc580bf]
7
8Signed-off-by: Signed-off-by: Lim Siew Hoon <siew.hoon.lim@intel.com>
9---
10 Source/inc/common/igfxfmid.h | 4 ++++
11 1 file changed, 4 insertions(+)
12
13diff --git a/Source/inc/common/igfxfmid.h b/Source/inc/common/igfxfmid.h
14index 2b50de2..5ef90f5 100644
15--- a/Source/inc/common/igfxfmid.h
16+++ b/Source/inc/common/igfxfmid.h
17@@ -1928,6 +1928,10 @@ typedef enum __NATIVEGTTYPE
18 #define DEV_ID_56B1 0x56B1
19 #define DEV_ID_56B2 0x56B2
20 #define DEV_ID_56B3 0x56B3
21+#define DEV_ID_56BA 0x56BA
22+#define DEV_ID_56BB 0x56BB
23+#define DEV_ID_56BC 0x56BC
24+#define DEV_ID_56BD 0x56BD
25 #define DEV_ID_56C0 0x56C0
26 #define DEV_ID_56C1 0x56C1
27
28--
292.40.1
30
diff --git a/recipes-graphics/gmmlib/files/0001-Introduce-ARL-H-support-172.patch b/recipes-graphics/gmmlib/files/0001-Introduce-ARL-H-support-172.patch
new file mode 100644
index 00000000..ab4cb178
--- /dev/null
+++ b/recipes-graphics/gmmlib/files/0001-Introduce-ARL-H-support-172.patch
@@ -0,0 +1,42 @@
1From 2b267b72d6aaa922861b120da9c1543161797046 Mon Sep 17 00:00:00 2001
2From: John Machado <john.machado@intel.com>
3Date: Fri, 9 Feb 2024 13:10:18 +0530
4Subject: [PATCH] Introduce ARL-H support (#172)
5
6Upstream-Status: Backport [https://github.com/intel/gmmlib/commit/544a8be6f66631e085c86c453aafd78b0e7f5179]
7Signed-off-by: Lim Siew Hoon <siew.hoon.lim@intel.com>
8---
9 Source/inc/common/igfxfmid.h | 10 ++++++++++
10 1 file changed, 10 insertions(+)
11
12diff --git a/Source/inc/common/igfxfmid.h b/Source/inc/common/igfxfmid.h
13index 99fc624..19aa505 100644
14--- a/Source/inc/common/igfxfmid.h
15+++ b/Source/inc/common/igfxfmid.h
16@@ -1966,6 +1966,11 @@ typedef enum __NATIVEGTTYPE
17 // ARL-S
18 #define DEV_ID_7D67 0x7D67
19
20+// ARL-H
21+#define DEV_ID_7D41 0x7D41
22+#define DEV_ID_7D51 0x7D51
23+#define DEV_ID_7DD1 0x7DD1
24+
25 #define MGM_HAS 0
26
27 //#define SDG_HAS 1 //Reserve place for Springdale-G HAS
28@@ -2012,6 +2017,11 @@ typedef enum __NATIVEGTTYPE
29 // Macro to identify ARL-S Device ID
30 #define GFX_IS_ARL_S(d) ( ( d == DEV_ID_7D67 ) )
31
32+// Macro to identify ARL-H Device ID
33+#define GFX_IS_ARL_H(d) ( ( d == DEV_ID_7D41 ) || \
34+ ( d == DEV_ID_7D51 ) || \
35+ ( d == DEV_ID_7DD1 ))
36+
37 //we define the highest cap and lower cap of stepping IDs
38 #define SI_REV_ID(lo,hi) (lo | hi<<16)
39
40--
412.40.1
42
diff --git a/recipes-graphics/gmmlib/gmmlib_22.3.12.bb b/recipes-graphics/gmmlib/gmmlib_22.3.15.bb
index 33ada350..5928fb86 100644
--- a/recipes-graphics/gmmlib/gmmlib_22.3.12.bb
+++ b/recipes-graphics/gmmlib/gmmlib_22.3.15.bb
@@ -8,10 +8,10 @@ LIC_FILES_CHKSUM = "file://LICENSE.md;md5=465fe90caea3edd6a2cecb3f0c28a654"
8 8
9SRC_URI = " \ 9SRC_URI = " \
10 git://github.com/intel/gmmlib.git;protocol=https;branch=master \ 10 git://github.com/intel/gmmlib.git;protocol=https;branch=master \
11 file://0001-Add-more-DG2-Device-IDs.patch \ 11 file://0001-Introduce-ARL-H-support-172.patch \
12 " 12 "
13 13
14SRCREV = "fa8ac6d3859ea78b721ce08afa6cd50591ad4d68" 14SRCREV = "5fb4180e22695ad4e3c155cf680119913c9f44bc"
15 15
16S = "${WORKDIR}/git" 16S = "${WORKDIR}/git"
17 17