summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2022-01-28 10:35:57 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2022-01-28 12:05:50 +0800
commit76cc0cce2c8cbe547009573901a1d7247e43fc97 (patch)
tree34979edf3eee0c0bb38048c4bd98e4c50f99d138 /recipes-devtools
parentf52d804c3093b3f6e5ec0e0251ed9731c8fb6237 (diff)
downloadmeta-intel-76cc0cce2c8cbe547009573901a1d7247e43fc97.tar.gz
Revert "slimboot: add recipe for Slim Bootloader"
This reverts commit 1d1d0f182815eeca36e4e80349fb0e16036171ff. The recipe needs some more work.
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/slimboot/slimboot_git.bb58
1 files changed, 0 insertions, 58 deletions
diff --git a/recipes-devtools/slimboot/slimboot_git.bb b/recipes-devtools/slimboot/slimboot_git.bb
deleted file mode 100644
index 15137cdc..00000000
--- a/recipes-devtools/slimboot/slimboot_git.bb
+++ /dev/null
@@ -1,58 +0,0 @@
1SUMMARY = "Slim Bootloader"
2DESCRIPTION = "Slim Bootloader is an open-source boot firmware, built from the \
3ground up to be small, secure and optimized running on Intel x86 architecture."
4HOMEPAGE = "https://slimbootloader.github.io"
5
6LICENSE = "BSD-2-Clause-Patent & MIT & Apache-2.0 & Python-2.0"
7
8SRC_URI = "git://github.com/slimbootloader/slimbootloader;protocol=https;branch=master"
9SRCREV = "07b7a1f0e017de6f4041a04e12c44e9574126dfe"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=ef7fba7be2819ac13aaf5d0f842ce5d9 \
11 file://Licenses/EDK2_License.txt;md5=6123e5bf044a66db96c4ce88a36b2d08 \
12 file://Licenses/IPP_License.txt;md5=e3fc50a88d0a364313df4b21ef20c29e \
13 file://Licenses/Lz4_License.txt;md5=093ffc6380c6b1dadf52045a6e44a874 \
14 file://Licenses/MIT_License.txt;md5=f0f3a517d46b5f0ca048b58f503b6dc1 \
15 file://Licenses/NetBSD_License.txt;md5=1811b558fd7e03c491ca7f665eaf5529 \
16 file://Licenses/Python_License.txt;md5=dd98d01d471fac8d8dbdd975229dba03 \
17 "
18PV = "0.0.0+git${SRCPV}"
19
20inherit python3native
21
22DEPENDS = "openssl-native nasm-native acpica-native util-linux-native"
23S = "${WORKDIR}/git"
24
25do_configure[noexec] = "1"
26
27SLIMBOOT_TARGET ?= "qemu"
28SLIMBOOT_KEY_DIR ?= "keys"
29
30do_compile() {
31 # WA: To overcome direct call to "python" in scripts of slimbootloader
32 ln -sf ${PYTHON} ${STAGING_BINDIR_NATIVE}/python
33
34 cd ${S}
35 rm -rf ${SLIMBOOT_KEY_DIR}; mkdir -p ${SLIMBOOT_KEY_DIR}
36 export SBL_KEY_DIR=${S}/${SLIMBOOT_KEY_DIR}
37 ${PYTHON} BootloaderCorePkg/Tools/GenerateKeys.py -k ${SBL_KEY_DIR}
38
39 # Currently use EXTRA_OPTFLAGS to pass the include directory of sysroot-native to
40 # bitbake build system.
41 export EXTRA_OPTFLAGS="-I${STAGING_INCDIR_NATIVE}"
42
43 export EXTRA_LDFLAGS="-L${STAGING_LIBDIR_NATIVE}"
44
45 for target in ${SLIMBOOT_TARGET}; do
46 ${PYTHON} BuildLoader.py build ${target}
47 done
48}
49
50do_install() {
51 for target in ${SLIMBOOT_TARGET}; do
52 install -m 0755 -d ${D}${libexecdir}/slimboot/Outputs/${target}
53 install -m 0755 ${S}/Outputs/${target}/* ${D}${libexecdir}/slimboot/Outputs/${target}
54 done
55
56 install -m 0644 -d ${D}${libexecdir}/slimboot/${SLIMBOOT_KEY_DIR}
57 install -m 0644 ${S}/${SLIMBOOT_KEY_DIR}/* ${D}${libexecdir}/slimboot/${SLIMBOOT_KEY_DIR}
58}