summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/ngraph/ngraph_0.22.1.bb
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2019-09-11 12:25:56 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2019-09-13 09:28:53 +0800
commit420247ef2db5c08ade2a34d4170f8db8aa7bc439 (patch)
treed3fb665ac094d15b640a826c60d6eb4a52a7a5c9 /recipes-devtools/ngraph/ngraph_0.22.1.bb
parent42eb1f0d3a1993699da21b45095b46ba3f8ee7a8 (diff)
downloadmeta-intel-420247ef2db5c08ade2a34d4170f8db8aa7bc439.tar.gz
ngraph: add recipe
nGraph Library is an open-source C++ library and runtime/compiler suite for Deep Learning ecosystem. For more details, see: https://www.intel.ai/ngraph/ Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'recipes-devtools/ngraph/ngraph_0.22.1.bb')
-rw-r--r--recipes-devtools/ngraph/ngraph_0.22.1.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes-devtools/ngraph/ngraph_0.22.1.bb b/recipes-devtools/ngraph/ngraph_0.22.1.bb
new file mode 100644
index 00000000..fa6427b3
--- /dev/null
+++ b/recipes-devtools/ngraph/ngraph_0.22.1.bb
@@ -0,0 +1,23 @@
1SUMMARY = "nGraph Compiler Stack"
2DESCRIPTION = "nGraph Compiler aims to accelerate developing AI workloads using \
3any deep learning framework and deploying to a variety of \
4hardware targets."
5HOMEPAGE = "https://www.ngraph.ai"
6
7SRC_URI = "git://github.com/NervanaSystems/ngraph.git;protocol=https;branch=r0.22 \
8 file://0001-ngraph-compile-for-DLDT-R2.patch;striplevel=2 \
9 "
10
11SRCREV = "6818cc5fae57a46d8558c9fd112e04c57a35e0fa"
12
13LICENSE = "Apache-2.0"
14LIC_FILES_CHKSUM = "file://../LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
15
16S = "${WORKDIR}/git/src"
17
18inherit cmake
19
20OECMAKE_GENERATOR = "Unix Makefiles"
21
22FILES_${PN}-dev = "${includedir}"
23FILES_${PN} += "${libdir}/libngraph.so"