summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/thermald
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2017-11-07 10:32:26 -0800
committerSaul Wold <sgw@linux.intel.com>2017-11-20 15:33:02 -0800
commitd53dbb38c43da3fd04fed9a55e7b3b9e2c512b9a (patch)
treefbe372dba00d45bbf9fbfbb3726708dc2590daeb /recipes-bsp/thermald
parent5adbf6df4fd89e7531ccccfb9cec7a5314d635f0 (diff)
downloadmeta-intel-d53dbb38c43da3fd04fed9a55e7b3b9e2c512b9a.tar.gz
meta-intel: Reorganize the layout to remove common
Remove the concept of the common directory and move all the recipes-* dirs to the top level as a normal layer would be. layer.conf is updated appropriately Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'recipes-bsp/thermald')
-rw-r--r--recipes-bsp/thermald/thermald_1.6.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes-bsp/thermald/thermald_1.6.bb b/recipes-bsp/thermald/thermald_1.6.bb
new file mode 100644
index 00000000..e6cbb621
--- /dev/null
+++ b/recipes-bsp/thermald/thermald_1.6.bb
@@ -0,0 +1,33 @@
1SUMMARY = "Linux thermal daemon"
2
3DESCRIPTION = "Thermal Daemon is a Linux daemon used to prevent the \
4overheating of platforms. This daemon monitors temperature and applies \
5compensation using available cooling methods."
6
7HOMEPAGE = "https://github.com/01org/thermal_daemon"
8
9DEPENDS = "dbus dbus-glib dbus-glib-native libxml2 glib-2.0 glib-2.0-native"
10DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES','systemd','systemd','',d)}"
11DEPENDS_append_libc-musl = " argp-standalone"
12DEPENDS_append_toolchain-clang = " openmp"
13LICENSE = "GPL-2.0"
14LIC_FILES_CHKSUM = "file://COPYING;md5=ea8831610e926e2e469075b52bf08848"
15
16SRC_URI = "git://github.com/intel/thermal_daemon/"
17SRCREV = "5f1be4d9d6f3b27d2c9884f833ca05cdcb4428e0"
18S = "${WORKDIR}/git"
19
20inherit pkgconfig autotools systemd
21
22FILES_${PN} += "${datadir}/dbus-1/system-services/*.service"
23
24SYSTEMD_SERVICE_${PN} = "thermald.service"
25
26COMPATIBLE_HOST = '(i.86|x86_64).*-linux'
27
28CONFFILES_${PN} = " \
29 ${sysconfdir}/thermald/thermal-conf.xml \
30 ${sysconfdir}/thermald/thermal-cpu-cdev-order.xml \
31 "
32
33UPSTREAM_CHECK_URI = "https://github.com/01org/thermal_daemon/releases"