summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/thermald/thermald_1.8.bb
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2018-09-24 17:50:31 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2018-09-27 10:29:14 +0800
commitaf677f5e4aba2c027365843d61cb8f9f31de4e91 (patch)
treed526124ce3d7a8eb1781109248777fe6ac3971a8 /recipes-bsp/thermald/thermald_1.8.bb
parentba19605153725d66dc55e0a16962ae684e66c9e4 (diff)
downloadmeta-intel-af677f5e4aba2c027365843d61cb8f9f31de4e91.tar.gz
thermald: 1.7.2 -> 1.8
Changes from release notes: - Support of KBL-G with discrete GPU - Fast removal of any cooling action which was applied once temperature is normal - Android support - Add Hot trip point, which when reached just calls "suspend" - Adding new tag "DependsOn" which enable/disable trip based on some other trip - Polling interval can be configured via thermal xml config - Per trip PID control - Simplify RAPL cooling device Also remove upstreamed patches and add a change to fix build failures. Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'recipes-bsp/thermald/thermald_1.8.bb')
-rw-r--r--recipes-bsp/thermald/thermald_1.8.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/recipes-bsp/thermald/thermald_1.8.bb b/recipes-bsp/thermald/thermald_1.8.bb
new file mode 100644
index 00000000..f7725f31
--- /dev/null
+++ b/recipes-bsp/thermald/thermald_1.8.bb
@@ -0,0 +1,35 @@
1SUMMARY = "Linux thermal daemon"
2
3DESCRIPTION = "Thermal Daemon is a Linux daemon used to prevent the \
4overheating of platforms. This daemon monitors temperature and applies \
5compensation using available cooling methods."
6
7HOMEPAGE = "https://github.com/01org/thermal_daemon"
8
9DEPENDS = "dbus dbus-glib dbus-glib-native libxml2 glib-2.0 glib-2.0-native"
10DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES','systemd','systemd','',d)}"
11DEPENDS_append_libc-musl = " argp-standalone"
12DEPENDS_append_toolchain-clang = " openmp"
13LICENSE = "GPLv2"
14LIC_FILES_CHKSUM = "file://COPYING;md5=ea8831610e926e2e469075b52bf08848"
15
16SRC_URI = "git://github.com/intel/thermal_daemon/ \
17 file://0001-Use-correct-format-specifier-for-size_t.patch \
18 "
19SRCREV = "517c0e5f92d49aeeef3a22b04caf40d588216827"
20S = "${WORKDIR}/git"
21
22inherit pkgconfig autotools systemd
23
24FILES_${PN} += "${datadir}/dbus-1/system-services/*.service"
25
26SYSTEMD_SERVICE_${PN} = "thermald.service"
27
28COMPATIBLE_HOST = '(i.86|x86_64).*-linux'
29
30CONFFILES_${PN} = " \
31 ${sysconfdir}/thermald/thermal-conf.xml \
32 ${sysconfdir}/thermald/thermal-cpu-cdev-order.xml \
33 "
34
35UPSTREAM_CHECK_URI = "https://github.com/01org/thermal_daemon/releases"