summaryrefslogtreecommitdiffstats
path: root/meta-romley/recipes-graphics
diff options
context:
space:
mode:
authorKishore Bodke <kishore.k.bodke@intel.com>2011-10-27 14:21:43 -0700
committerTom Zanussi <tom.zanussi@intel.com>2011-10-28 00:04:20 -0500
commit478969defe862a2779bf7eb3bca30e2067827d7e (patch)
tree7f4eca944555205306c3a9d2145268a31cead89a /meta-romley/recipes-graphics
parentb5c9f0af18b80c2b4c478fd7cfb537e0a04a4e22 (diff)
downloadmeta-intel-478969defe862a2779bf7eb3bca30e2067827d7e.tar.gz
New Romley BSP created. Uses Matrox MGA graphics driver.
This layer provides new BSP meta-romley. This provides the support for Romley + Patsburg Chipset for Intel Systems. Romley refers to the Intel Rosecity Board. Signed-off-by: Kishore Bodke <kishore.k.bodke@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
Diffstat (limited to 'meta-romley/recipes-graphics')
-rwxr-xr-xmeta-romley/recipes-graphics/xorg-driver/xf86-video-mga_1.4.13.bb19
-rw-r--r--meta-romley/recipes-graphics/xorg-xserver/xserver-xf86-config/romley/xorg.conf26
-rw-r--r--meta-romley/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend3
-rw-r--r--meta-romley/recipes-graphics/xorg-xserver/xserver-xorg_1.11.1.bbappend1
4 files changed, 49 insertions, 0 deletions
diff --git a/meta-romley/recipes-graphics/xorg-driver/xf86-video-mga_1.4.13.bb b/meta-romley/recipes-graphics/xorg-driver/xf86-video-mga_1.4.13.bb
new file mode 100755
index 00000000..b48e56d8
--- /dev/null
+++ b/meta-romley/recipes-graphics/xorg-driver/xf86-video-mga_1.4.13.bb
@@ -0,0 +1,19 @@
1require recipes-graphics/xorg-driver/xorg-driver-video.inc
2
3SUMMARY = "X.Org X server -- Matrox MGA display driver"
4
5DESCRIPTION = "mga is an Xorg driver for Matrox video cards"
6
7LIC_FILES_CHKSUM = "file://COPYING;md5=bc1395d2cd32dfc5d6c57d2d8f83d3fc"
8
9DEPENDS += "virtual/libx11 libxvmc drm xf86driproto glproto \
10 virtual/libgl xineramaproto libpciaccess"
11
12EXTRA_OECONF += "--enable-dri"
13
14PR = "r0"
15
16COMPATIBLE_HOST = '(i.86.*-linux|x86_64.*-linux)'
17
18SRC_URI[md5sum] = "f967fb3e655f6f68aa3f495eaadcaac2"
19SRC_URI[sha256sum] = "b657bd5fec4aade6396c683886739b7c8ce57924278bee0e36f13a966eeddff6"
diff --git a/meta-romley/recipes-graphics/xorg-xserver/xserver-xf86-config/romley/xorg.conf b/meta-romley/recipes-graphics/xorg-xserver/xserver-xf86-config/romley/xorg.conf
new file mode 100644
index 00000000..28ad0bf7
--- /dev/null
+++ b/meta-romley/recipes-graphics/xorg-xserver/xserver-xf86-config/romley/xorg.conf
@@ -0,0 +1,26 @@
1Section "Device"
2 Identifier "Matrox MGA"
3 Driver "mga"
4EndSection
5
6Section "Monitor"
7 Identifier "Generic Monitor"
8 Option "DPMS"
9EndSection
10
11Section "Screen"
12 Identifier "Default Screen"
13 Device "Matrox MGA"
14 Monitor "Generic Monitor"
15 DefaultDepth 24
16EndSection
17
18Section "ServerLayout"
19 Identifier "Default Layout"
20 Screen "Default Screen"
21EndSection
22
23Section "ServerFlags"
24 Option "DontZap" "0"
25 Option "AutoAddDevices" "False"
26EndSection
diff --git a/meta-romley/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend b/meta-romley/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend
new file mode 100644
index 00000000..4b8d0e65
--- /dev/null
+++ b/meta-romley/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend
@@ -0,0 +1,3 @@
1THISDIR := "${@os.path.dirname(bb.data.getVar('FILE', d, True))}"
2FILESPATH =. "${@base_set_filespath(["${THISDIR}/${PN}"], d)}:"
3
diff --git a/meta-romley/recipes-graphics/xorg-xserver/xserver-xorg_1.11.1.bbappend b/meta-romley/recipes-graphics/xorg-xserver/xserver-xorg_1.11.1.bbappend
new file mode 100644
index 00000000..b2808ef2
--- /dev/null
+++ b/meta-romley/recipes-graphics/xorg-xserver/xserver-xorg_1.11.1.bbappend
@@ -0,0 +1 @@
EXTRA_OECONF += "--enable-dga"