summaryrefslogtreecommitdiffstats
path: root/meta-romley/recipes-extended/dpdk/dpdk_1.7.0.bb
diff options
context:
space:
mode:
authorTom Zanussi <tom.zanussi@linux.intel.com>2014-11-06 07:05:52 -0600
committerTom Zanussi <tom.zanussi@linux.intel.com>2014-11-06 10:55:26 -0600
commit0f6d30a95c84ec239f5a30bbfba17ed42e2cf284 (patch)
tree768a8dc74cb17cdfa009ba12c241c5fd4f68751c /meta-romley/recipes-extended/dpdk/dpdk_1.7.0.bb
parent567358dae4a005e09b37311beed78ca923cb4aad (diff)
downloadmeta-intel-2.0-rc4-dizzy-1.7.tar.gz
common: Remove DPDK recipes2.0-rc4-dizzy-1.72.0-dizzy-1.7
Move the DPDK recipes out of common/ and into meta-romley/. The DPDK recipes have so far been shown to be broken for any other machine than Romley or for any other kernel version than the kernel Romley is still using, 3.10. So the logical place for them to live would be in meta-romley, if anywhere. Signed-off-by: Tom Zanussi <tom.zanussi@linux.intel.com> Acked-by: Burton, Ross <ross.burton@intel.com>
Diffstat (limited to 'meta-romley/recipes-extended/dpdk/dpdk_1.7.0.bb')
-rw-r--r--meta-romley/recipes-extended/dpdk/dpdk_1.7.0.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta-romley/recipes-extended/dpdk/dpdk_1.7.0.bb b/meta-romley/recipes-extended/dpdk/dpdk_1.7.0.bb
new file mode 100644
index 00000000..581f1d4a
--- /dev/null
+++ b/meta-romley/recipes-extended/dpdk/dpdk_1.7.0.bb
@@ -0,0 +1,41 @@
1include dpdk.inc
2
3SRC_URI = "http://dpdk.org/browse/dpdk/snapshot/dpdk-${PV}.tar.gz;name=dpdk \
4 file://dpdk-1.7.0-examples-Add-config-variables-to-enable-disable-dpdk.patch \
5 file://dpdk-1.7.0-examples-pipeline-build-with-all-examples.patch \
6 file://dpdk-1.7.0-ring-remove-extra-devices-creation-with-vdev-option.patch \
7 file://dpdk-1.7.0-ring-simplify-unit-tests.patch \
8 "
9
10SRC_URI[dpdk.md5sum] = "07907d7b1a64888a459a971c45818038"
11SRC_URI[dpdk.sha256sum] = "aafc290260b5002d248ab8f8c8ffa76454d4b1382aa3c82ae2700ecce481397a"
12
13export EXAMPLES_BUILD_DIR = "${RTE_TARGET}"
14
15# dpdk example apps dpdk_qat and vhost have dependancy on fuse and qat.
16# fuse is in meta-filesystems and qat is not yet upstreamed.
17# So adding mechanism to explicitly disable the use of fuse and qat.
18# To enable, uncomment the below line or include in .bbappend.
19# PACKAGECONFIG ?= " dpdk_qat vhost "
20
21PACKAGECONFIG[dpdk_qat] = ",,qat"
22PACKAGECONFIG[vhost] = ",,fuse"
23
24do_compile_append () {
25
26 cd ${S}/examples/
27
28 # Disable the compilation of example apps dpdk_qat and vhost if they are
29 # not included in the PACKAGECONFIG
30 export CONFIG_EXAMPLE_DPDK_QAT=${@base_contains('PACKAGECONFIG', 'dpdk_qat', 'y', 'n', d)}
31 export CONFIG_EXAMPLE_DPDK_VHOST="${@base_contains('PACKAGECONFIG', 'vhost', 'y', 'n', d)}"
32
33 ###############################################################
34 # In order to make use of dpdk.inc for example app installation
35 # without failure, override the default build directory
36 ###############################################################
37 oe_runmake CROSS="${TARGET_PREFIX}" O="${S}/examples/$@/"
38}
39
40
41