summaryrefslogtreecommitdiffstats
path: root/meta-n450/recipes-bsp/n450-audio/n450-audio.bb
diff options
context:
space:
mode:
authorDarren Hart <dvhart@linux.intel.com>2011-03-11 15:53:11 -0800
committerDarren Hart <dvhart@linux.intel.com>2011-03-12 00:46:41 -0800
commitd1ba49be3052aada2ca8fe8f12787b4fce8a6383 (patch)
tree1691ddc0be4a8df8352b59258856978af1378ab6 /meta-n450/recipes-bsp/n450-audio/n450-audio.bb
parent4bbfc4f08b0e906ba4182f0ad2baad77a5938db9 (diff)
downloadmeta-intel-d1ba49be3052aada2ca8fe8f12787b4fce8a6383.tar.gz
n450: revamp audio mixer init script
Fixes [YOCTO #798] n450-audiofix suffered from various problems, including not getting installed. This patch adds it via MACHINE_EXTRA_RRECOMMENDS and cleans up the various bugs in the implementation. The structure has been renamed and the comments updated for consistency. This should be considered a stop-gap measure, as something along the lines of oe's alsa-state is a far better solution. Signed-off-by: Darren Hart <dvhart@linux.intel.com>
Diffstat (limited to 'meta-n450/recipes-bsp/n450-audio/n450-audio.bb')
-rw-r--r--meta-n450/recipes-bsp/n450-audio/n450-audio.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-n450/recipes-bsp/n450-audio/n450-audio.bb b/meta-n450/recipes-bsp/n450-audio/n450-audio.bb
new file mode 100644
index 00000000..20e3a9ad
--- /dev/null
+++ b/meta-n450/recipes-bsp/n450-audio/n450-audio.bb
@@ -0,0 +1,23 @@
1SUMMARY = "Provide a basic init script to enable audio"
2DESCRIPTION = "Set the volume and unmute the Front mixer setting during boot."
3SECTION = "base"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://${POKYBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
6
7PR = "r3"
8
9inherit update-rc.d
10
11RDEPENDS = "alsa-utils-amixer"
12
13SRC_URI = "file://n450-audio"
14
15INITSCRIPT_NAME = "n450-audio"
16INITSCRIPT_PARAMS = "defaults 90"
17
18do_install() {
19 install -d ${D}${sysconfdir} \
20 ${D}${sysconfdir}/init.d
21 install -m 0755 ${WORKDIR}/n450-audio ${D}${sysconfdir}/init.d
22}
23