summaryrefslogtreecommitdiffstats
path: root/meta-isg/common/recipes-extended/qat/qat16/qat16_2.3.0-34-make-sure-CFLAGS-are-correct.patch
diff options
context:
space:
mode:
authorAnuj Mittal <anujx.mittal@intel.com>2015-09-18 15:40:05 +0800
committerSaul Wold <sgw@linux.intel.com>2015-09-21 09:14:53 -0700
commit1201a576c9bcdab3bfcf87efeb2184f0025ae53e (patch)
tree50f32b8f7353c97ddbe6be22b2871a7d6f593fec /meta-isg/common/recipes-extended/qat/qat16/qat16_2.3.0-34-make-sure-CFLAGS-are-correct.patch
parent10a7d933f18c3796c431436b028cca844be12180 (diff)
downloadmeta-intel-1201a576c9bcdab3bfcf87efeb2184f0025ae53e.tar.gz
meta-isg: qat: fix inline build errors for gcc5
gcc5 has changed its default standard to gnu11 from gnu89. These two standards have different inline semantics. This results in errors like: undefined reference to `icp_adf_getQueueNext' undefined reference to `icp_adf_updateQueueTail' undefined reference to `icp_adf_pollQueue' undefined reference to `icp_adf_queueDataToSend' undefined reference to `icp_adf_getQueueMemory' Use the -fgnu89-inline command line option as suggested in [1]. Also, make sure that all the CFLAGS values are being picked up by the compiler. [1] https://gcc.gnu.org/gcc-5/porting_to.html Signed-off-by: Anuj Mittal <anujx.mittal@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta-isg/common/recipes-extended/qat/qat16/qat16_2.3.0-34-make-sure-CFLAGS-are-correct.patch')
-rw-r--r--meta-isg/common/recipes-extended/qat/qat16/qat16_2.3.0-34-make-sure-CFLAGS-are-correct.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-isg/common/recipes-extended/qat/qat16/qat16_2.3.0-34-make-sure-CFLAGS-are-correct.patch b/meta-isg/common/recipes-extended/qat/qat16/qat16_2.3.0-34-make-sure-CFLAGS-are-correct.patch
new file mode 100644
index 00000000..e1ed3fc9
--- /dev/null
+++ b/meta-isg/common/recipes-extended/qat/qat16/qat16_2.3.0-34-make-sure-CFLAGS-are-correct.patch
@@ -0,0 +1,30 @@
1From 83f465ee776868875f6c19c2110eed4db6c547ce Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anujx.mittal@intel.com>
3Date: Thu, 10 Sep 2015 11:58:44 +0800
4Subject: [PATCH] qat: make sure CFLAGS are correct
5
6Upstream-Status: Submitted
7
8Ensure that all the CFLAGS values are being considered.
9
10Signed-off-by: Anuj Mittal <anujx.mittal@intel.com>
11---
12 quickassist/adf/user/user_proxy/src/Makefile | 2 +-
13 1 file changed, 1 insertion(+), 1 deletion(-)
14
15diff --git a/quickassist/adf/user/user_proxy/src/Makefile b/quickassist/adf/user/user_proxy/src/Makefile
16index 868313a..efd352c 100644
17--- a/quickassist/adf/user/user_proxy/src/Makefile
18+++ b/quickassist/adf/user/user_proxy/src/Makefile
19@@ -133,7 +133,7 @@ INCLUDES+= -I$(ADF_DIR)/include \
20 -I$(ADF_PLATFORM_DIR)/include \
21 -I$(ADF_CTL_DIR)/include
22
23-CFLAGS = -D_GNU_SOURCE -O2 $(INCLUDES)
24+CFLAGS += -D_GNU_SOURCE -O2 $(INCLUDES)
25 #needed by SAL
26 EXTRA_CFLAGS += -fPIC -fno-strict-aliasing
27 #include your $(ICP_OS)_$(ICP_OS_LEVEL).mk file
28--
291.7.9.5
30