summaryrefslogtreecommitdiffstats
path: root/meta-isg/common/recipes-extended/openssl-qat/openssl-qat/openssl_qat-environment-variables-to-have-precedence.patch
diff options
context:
space:
mode:
authorRahul Kumar Gupta <rahul.kumarxx.gupta@intel.com>2016-02-10 17:29:05 +0800
committerSaul Wold <sgw@linux.intel.com>2016-02-12 14:20:52 -0800
commit5640cd6bc13a520ba4bf73c94fe9b739ac23c7e6 (patch)
tree46d09b1011b40be99bf6c94a49a83a6603e0d278 /meta-isg/common/recipes-extended/openssl-qat/openssl-qat/openssl_qat-environment-variables-to-have-precedence.patch
parent39544083034168d0d75b4dc0d7053ce448c16e31 (diff)
downloadmeta-intel-5640cd6bc13a520ba4bf73c94fe9b739ac23c7e6.tar.gz
meta-isg: openssl-qat: Add support for v0.4.9-009
This recipe adds the openssl-qat engine that accelerates some of the libcrypto algorithms via the Intel QAT implemented on Intel communication chipsets. QAT sample patch v0.4.9-009 is based on async branch of openssl-1.0.1m. openssl & zlib shim layers both install the qat_mem.ko driver. Make openssl shim dependent on zlib-qat and ensure that only zlib-qat installs this kernel module. This fix change in future when qat_mem module has been forked into a separate package. The recipe is for platforms like grantley and crystalforest using the common BSP intel-corei7-64. Signed-off-by: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta-isg/common/recipes-extended/openssl-qat/openssl-qat/openssl_qat-environment-variables-to-have-precedence.patch')
-rw-r--r--meta-isg/common/recipes-extended/openssl-qat/openssl-qat/openssl_qat-environment-variables-to-have-precedence.patch59
1 files changed, 59 insertions, 0 deletions
diff --git a/meta-isg/common/recipes-extended/openssl-qat/openssl-qat/openssl_qat-environment-variables-to-have-precedence.patch b/meta-isg/common/recipes-extended/openssl-qat/openssl-qat/openssl_qat-environment-variables-to-have-precedence.patch
new file mode 100644
index 00000000..82c9965d
--- /dev/null
+++ b/meta-isg/common/recipes-extended/openssl-qat/openssl-qat/openssl_qat-environment-variables-to-have-precedence.patch
@@ -0,0 +1,59 @@
1From dde5f7d6603d875b1d871498ae95a6837ccd591d Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anujx.mittal@intel.com>
3Date: Sat, 20 Jun 2015 00:25:27 +0800
4Subject: [PATCH] openssl_qat: environment variables to have precedence
5
6Upstream-Status: Inappropriate [configuration]
7
8(From meta/recipes-connectivity/openssl/openssl/shared-libs.patch
9 rev: 5dd1d7566964c90d33c0c44f569d9336fb0724ce)
10
11Signed-off-by: Anuj Mittal <anujx.mittal@intel.com>
12---
13 Makefile.org | 2 +-
14 crypto/Makefile | 2 +-
15 ssl/Makefile | 2 +-
16 3 files changed, 3 insertions(+), 3 deletions(-)
17
18diff --git a/Makefile.org b/Makefile.org
19index 1f2f5e1..679c884 100644
20--- a/Makefile.org
21+++ b/Makefile.org
22@@ -311,7 +311,7 @@ libcrypto$(SHLIB_EXT): libcrypto.a fips_premain_dso$(EXE_EXT)
23
24 libssl$(SHLIB_EXT): libcrypto$(SHLIB_EXT) libssl.a
25 @if [ "$(SHLIB_TARGET)" != "" ]; then \
26- $(MAKE) SHLIBDIRS=ssl SHLIBDEPS='-lcrypto' build-shared; \
27+ $(MAKE) -e SHLIBDIRS=ssl SHLIBDEPS='-lcrypto' build-shared; \
28 else \
29 echo "There's no support for shared libraries on this platform" >&2; \
30 exit 1; \
31diff --git a/crypto/Makefile b/crypto/Makefile
32index 2355661..1b0c324 100644
33--- a/crypto/Makefile
34+++ b/crypto/Makefile
35@@ -107,7 +107,7 @@ $(LIB): $(LIBOBJ)
36
37 shared: buildinf.h lib subdirs
38 if [ -n "$(SHARED_LIBS)" ]; then \
39- (cd ..; $(MAKE) $(SHARED_LIB)); \
40+ (cd ..; $(MAKE) -e $(SHARED_LIB)); \
41 fi
42
43 libs:
44diff --git a/ssl/Makefile b/ssl/Makefile
45index e05ada2..6f51862 100644
46--- a/ssl/Makefile
47+++ b/ssl/Makefile
48@@ -64,7 +64,7 @@ lib: $(LIBOBJ)
49
50 shared: lib
51 if [ -n "$(SHARED_LIBS)" ]; then \
52- (cd ..; $(MAKE) $(SHARED_LIB)); \
53+ (cd ..; $(MAKE) -e $(SHARED_LIB)); \
54 fi
55
56 files:
57--
581.7.9.5
59