summaryrefslogtreecommitdiffstats
path: root/meta-isg/common/recipes-extended/dpdk/dpdk
diff options
context:
space:
mode:
authorGeorge Nita <george.nita@enea.com>2015-07-30 05:11:54 +0200
committerGeorge Nita <george.nita@enea.com>2015-07-30 05:11:54 +0200
commit1be68da0e9ec9b9035c94346a5b51b4c3b27af96 (patch)
tree5f8fa419dadfc5fc16505d6413b5543cb6fd0f6d /meta-isg/common/recipes-extended/dpdk/dpdk
parent46b382223d1427b70ab84f419f2739c06ace9c28 (diff)
parent3577c351cd82fabd95fb3520c3e4d5809091cb30 (diff)
downloadmeta-intel-1be68da0e9ec9b9035c94346a5b51b4c3b27af96.tar.gz
Merge remote-tracking branch 'origin/master' into master-enea
Diffstat (limited to 'meta-isg/common/recipes-extended/dpdk/dpdk')
-rw-r--r--meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-1.8.0-and-2.0.0-dpdk-defconfig-select-RTE_MACHINE-type.patch48
-rw-r--r--meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-1.8.0-and-2.0.0-point-to-the-right-include-and-lib-path.patch43
-rw-r--r--meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-1.8.0-dpdk-enable-build-config-VHOST-in-common_linuxapp-config.patch43
-rw-r--r--meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-2.0.0-dpdk-enable-VHOST-and-ip_fragmentation-in-common_linuxapp.patch50
-rw-r--r--meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-2.0.0-dpdk-enable-ip_fragmentation-in-common_linuxapp.patch31
5 files changed, 74 insertions, 141 deletions
diff --git a/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-1.8.0-and-2.0.0-dpdk-defconfig-select-RTE_MACHINE-type.patch b/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-1.8.0-and-2.0.0-dpdk-defconfig-select-RTE_MACHINE-type.patch
deleted file mode 100644
index 979541e9..00000000
--- a/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-1.8.0-and-2.0.0-dpdk-defconfig-select-RTE_MACHINE-type.patch
+++ /dev/null
@@ -1,48 +0,0 @@
1From 6eaf6b1a61321acb824f9672c12d0e30a2110f52 Mon Sep 17 00:00:00 2001
2From: Ong Boon Leong <boon.leong.ong@intel.com>
3Date: Mon, 16 Mar 2015 11:10:43 +0800
4Subject: [PATCH] DPDK: defconfig: add selectable RTE_MACHINE option
5
6In order to make sure that DPDK build environment config can handle the
7package being built on different build machine for different target machine
8which will have different x86 architecture intrinsics than the build machine,
9we introduce DPDK_TARGET_MACH to be tunable from dpdk recipe. The machine
10type can be under mk/machine folder.
11
12Upstream-Status: Inappropriate [configuration]
13
14Signed-off-by: Ong Boon Leong <boon.leong.ong@intel.com>
15---
16 config/defconfig_i686-native-linuxapp-gcc | 2 +-
17 config/defconfig_x86_64-native-linuxapp-gcc | 2 +-
18 2 files changed, 2 insertions(+), 2 deletions(-)
19
20diff --git a/config/defconfig_i686-native-linuxapp-gcc b/config/defconfig_i686-native-linuxapp-gcc
21index a90de9b..c9a74a5 100644
22--- a/config/defconfig_i686-native-linuxapp-gcc
23+++ b/config/defconfig_i686-native-linuxapp-gcc
24@@ -32,7 +32,7 @@
25
26 #include "common_linuxapp"
27
28-CONFIG_RTE_MACHINE="native"
29+CONFIG_RTE_MACHINE=$(DPDK_TARGET_MACH)
30
31 CONFIG_RTE_ARCH="i686"
32 CONFIG_RTE_ARCH_I686=y
33diff --git a/config/defconfig_x86_64-native-linuxapp-gcc b/config/defconfig_x86_64-native-linuxapp-gcc
34index 60baf5b..0e4802d 100644
35--- a/config/defconfig_x86_64-native-linuxapp-gcc
36+++ b/config/defconfig_x86_64-native-linuxapp-gcc
37@@ -32,7 +32,7 @@
38
39 #include "common_linuxapp"
40
41-CONFIG_RTE_MACHINE="native"
42+CONFIG_RTE_MACHINE=$(DPDK_TARGET_MACH)
43
44 CONFIG_RTE_ARCH="x86_64"
45 CONFIG_RTE_ARCH_X86_64=y
46--
471.7.9.5
48
diff --git a/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-1.8.0-and-2.0.0-point-to-the-right-include-and-lib-path.patch b/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-1.8.0-and-2.0.0-point-to-the-right-include-and-lib-path.patch
new file mode 100644
index 00000000..75bb517d
--- /dev/null
+++ b/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-1.8.0-and-2.0.0-point-to-the-right-include-and-lib-path.patch
@@ -0,0 +1,43 @@
1From 928595c80ae28d19861d7e76ed898a8fb3f2c1dc Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anujx.mittal@intel.com>
3Date: Fri, 24 Jul 2015 23:57:17 +0800
4Subject: [PATCH] dpdk: point to the right include and lib path
5
6Upstream-Status: Inappropriate [Configuration]
7
8Make sure that we point to the right location of qat
9lac headers and library.
10
11Signed-off-by: Anuj Mittal <anujx.mittal@intel.com>
12---
13 examples/dpdk_qat/Makefile | 7 ++-----
14 1 file changed, 2 insertions(+), 5 deletions(-)
15
16diff --git a/examples/dpdk_qat/Makefile b/examples/dpdk_qat/Makefile
17index f1e06a1..5b906f7 100644
18--- a/examples/dpdk_qat/Makefile
19+++ b/examples/dpdk_qat/Makefile
20@@ -66,18 +66,15 @@ SRCS-y := main.c crypto.c
21
22 CFLAGS += -O3
23 CFLAGS += $(WERROR_FLAGS)
24-CFLAGS += -I$(ICP_ROOT)/quickassist/include \
25- -I$(ICP_ROOT)/quickassist/include/lac \
26- -I$(ICP_ROOT)/quickassist/lookaside/access_layer/include
27+CFLAGS += -I$(ICP_LAC_API_DIR)
28
29 # From CRF 1.2 driver, library was renamed to libicp_qa_al.a
30 ifneq ($(wildcard $(ICP_ROOT)/build/icp_qa_al.a),)
31 ICP_LIBRARY_PATH = $(ICP_ROOT)/build/icp_qa_al.a
32 else
33-ICP_LIBRARY_PATH = $(ICP_ROOT)/build/libicp_qa_al.a
34+ICP_LIBRARY_PATH = $(ICP_LIB_ROOT)/libicp_qa_al.a
35 endif
36
37-LDLIBS += -L$(ICP_ROOT)/build
38 LDLIBS += $(ICP_LIBRARY_PATH) \
39 -lz \
40 -losal \
41--
421.7.9.5
43
diff --git a/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-1.8.0-dpdk-enable-build-config-VHOST-in-common_linuxapp-config.patch b/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-1.8.0-dpdk-enable-build-config-VHOST-in-common_linuxapp-config.patch
deleted file mode 100644
index e8ded8d0..00000000
--- a/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-1.8.0-dpdk-enable-build-config-VHOST-in-common_linuxapp-config.patch
+++ /dev/null
@@ -1,43 +0,0 @@
1From c1a59d62f2aa7656060d8ebcc8e45e852d931ff1 Mon Sep 17 00:00:00 2001
2From: Ong Boon Leong <boon.leong.ong@intel.com>
3Date: Tue, 17 Feb 2015 00:23:12 +0800
4Subject: [PATCH] dpdk: enable VHOST build config in common_linuxapp config
5
6Introduce CONFIG_VHOST_ENABLED for package config selection purpose in
7building vhost feature.
8
9Upstream-Status: Inappropriate [configuration]
10
11Signed-off-by: Ong Boon Leong <boon.leong.ong@intel.com>
12---
13 config/common_linuxapp | 6 +++---
14 1 file changed, 3 insertions(+), 3 deletions(-)
15
16diff --git a/config/common_linuxapp b/config/common_linuxapp
17index 2f9643b..67f5edb 100644
18--- a/config/common_linuxapp
19+++ b/config/common_linuxapp
20@@ -361,9 +361,9 @@ CONFIG_RTE_LIBRTE_PIPELINE=y
21 #
22 CONFIG_RTE_LIBRTE_KNI=y
23 CONFIG_RTE_KNI_KO_DEBUG=n
24-CONFIG_RTE_KNI_VHOST=n
25+CONFIG_RTE_KNI_VHOST=$(CONFIG_VHOST_ENABLED)
26 CONFIG_RTE_KNI_VHOST_MAX_CACHE_SIZE=1024
27-CONFIG_RTE_KNI_VHOST_VNET_HDR_EN=n
28+CONFIG_RTE_KNI_VHOST_VNET_HDR_EN=$(CONFIG_VHOST_ENABLED)
29 CONFIG_RTE_KNI_VHOST_DEBUG_RX=n
30 CONFIG_RTE_KNI_VHOST_DEBUG_TX=n
31
32@@ -372,7 +372,7 @@ CONFIG_RTE_KNI_VHOST_DEBUG_TX=n
33 # fuse-devel is needed to run vhost.
34 # fuse-devel enables user space char driver development
35 #
36-CONFIG_RTE_LIBRTE_VHOST=n
37+CONFIG_RTE_LIBRTE_VHOST=$(CONFIG_VHOST_ENABLED)
38 CONFIG_RTE_LIBRTE_VHOST_DEBUG=n
39
40 #
41--
421.7.9.5
43
diff --git a/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-2.0.0-dpdk-enable-VHOST-and-ip_fragmentation-in-common_linuxapp.patch b/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-2.0.0-dpdk-enable-VHOST-and-ip_fragmentation-in-common_linuxapp.patch
deleted file mode 100644
index 45ce5e05..00000000
--- a/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-2.0.0-dpdk-enable-VHOST-and-ip_fragmentation-in-common_linuxapp.patch
+++ /dev/null
@@ -1,50 +0,0 @@
1From 3d3c03d947394696565b3bb7bed8c900de057a28 Mon Sep 17 00:00:00 2001
2From: WU CHIA CHUAN <chia.chuan.wu@intel.com>
3Date: Thu, 2 Jul 2015 15:59:18 +0800
4Subject: [PATCH] dpdk enable VHOST and ip_fragmentation in common_linuxapp config
5
6Introduce CONFIG_VHOST_ENABLED for package config selection purpose in
7building vhost feature.
8
9Upstream-Status: Inappropriate [configuration]
10
11Signed-off-by: WU CHIA CHUAN <chia.chuan.wu@intel.com>
12---
13 config/common_linuxapp | 11 ++++++++---
14 1 file changed, 8 insertions(+), 3 deletions(-)
15
16diff --git a/config/common_linuxapp b/config/common_linuxapp
17index 0b25f34..000f950 100644
18--- a/config/common_linuxapp
19+++ b/config/common_linuxapp
20@@ -406,19 +406,24 @@ CONFIG_RTE_LIBRTE_PIPELINE=y
21 CONFIG_RTE_LIBRTE_KNI=y
22 CONFIG_RTE_KNI_PREEMPT_DEFAULT=y
23 CONFIG_RTE_KNI_KO_DEBUG=n
24-CONFIG_RTE_KNI_VHOST=n
25+CONFIG_RTE_KNI_VHOST=$(CONFIG_VHOST_ENABLED)
26 CONFIG_RTE_KNI_VHOST_MAX_CACHE_SIZE=1024
27-CONFIG_RTE_KNI_VHOST_VNET_HDR_EN=n
28+CONFIG_RTE_KNI_VHOST_VNET_HDR_EN=$(CONFIG_VHOST_ENABLED)
29 CONFIG_RTE_KNI_VHOST_DEBUG_RX=n
30 CONFIG_RTE_KNI_VHOST_DEBUG_TX=n
31
32 #
33+# Compile ip_fragmentation
34+#
35+CONFIG_RTE_IP_FRAG=y
36+
37+#
38 # Compile vhost library
39 # fuse-devel is needed to run vhost-cuse.
40 # fuse-devel enables user space char driver development
41 # vhost-user is turned on by default.
42 #
43-CONFIG_RTE_LIBRTE_VHOST=n
44+CONFIG_RTE_LIBRTE_VHOST=$(CONFIG_VHOST_ENABLED)
45 CONFIG_RTE_LIBRTE_VHOST_USER=y
46 CONFIG_RTE_LIBRTE_VHOST_DEBUG=n
47
48--
491.7.9.5
50
diff --git a/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-2.0.0-dpdk-enable-ip_fragmentation-in-common_linuxapp.patch b/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-2.0.0-dpdk-enable-ip_fragmentation-in-common_linuxapp.patch
new file mode 100644
index 00000000..c4c683e8
--- /dev/null
+++ b/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-2.0.0-dpdk-enable-ip_fragmentation-in-common_linuxapp.patch
@@ -0,0 +1,31 @@
1From ebf07e9708c96aa1e655127175c39ad6ae3fc5ae Mon Sep 17 00:00:00 2001
2From: WU CHIA CHUAN <chia.chuan.wu@intel.com>
3Date: Tue, 28 Jul 2015 13:12:21 +0800
4Subject: [PATCH] dpdk enable ip_fragmentation in common_linuxapp config
5
6Upstream-Status: Inappropriate [Configuration]
7
8Signed-off-by: WU CHIA CHUAN <chia.chuan.wu@intel.com>
9---
10 config/common_linuxapp | 5 +++++
11 1 file changed, 5 insertions(+)
12
13diff --git a/config/common_linuxapp b/config/common_linuxapp
14index 0b25f34..8cd97d7 100644
15--- a/config/common_linuxapp
16+++ b/config/common_linuxapp
17@@ -354,6 +354,11 @@ CONFIG_RTE_MAX_LCORE_FREQS=64
18 CONFIG_RTE_LIBRTE_NET=y
19
20 #
21+# Compile ip_fragmentation
22+#
23+CONFIG_RTE_IP_FRAG=y
24+
25+#
26 # Compile librte_ip_frag
27 #
28 CONFIG_RTE_LIBRTE_IP_FRAG=y
29--
301.9.1
31