summaryrefslogtreecommitdiffstats
path: root/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-16.04-add-sysroot-option-within-app-makefile.patch
diff options
context:
space:
mode:
authorRahul Kumar Gupta <rahul.kumarxx.gupta@intel.com>2016-04-14 22:18:19 +0800
committerSaul Wold <sgw@linux.intel.com>2016-04-14 09:57:29 -0700
commitc5650b6811f58c27d7d4493864b3ca859cf66cbd (patch)
treef61e1d461f029bec3b9f268a7d2734b491c3dcac /meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-16.04-add-sysroot-option-within-app-makefile.patch
parentb6c9d76e184c219cca688ad309841084615e315d (diff)
downloadmeta-intel-c5650b6811f58c27d7d4493864b3ca859cf66cbd.tar.gz
meta-isg: dpdk: Update v2.2.0 -> v16.04
update the dpdk recipe from v2.2.0 to v16.04. Rename the patches according to the recipe version. Now dpdk is following 'year-month' format for version numbering. dpdk v16.04 required "CONFIG_RTE_IP_FRAG=y" in order to build ip_fragmentation application. Signed-off-by: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-16.04-add-sysroot-option-within-app-makefile.patch')
-rw-r--r--meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-16.04-add-sysroot-option-within-app-makefile.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-16.04-add-sysroot-option-within-app-makefile.patch b/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-16.04-add-sysroot-option-within-app-makefile.patch
new file mode 100644
index 00000000..db762e9e
--- /dev/null
+++ b/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-16.04-add-sysroot-option-within-app-makefile.patch
@@ -0,0 +1,33 @@
1From 893d208cc66fbe533ab4e3e66907c5f63266579b Mon Sep 17 00:00:00 2001
2From: Ong Boon Leong <boon.leong.ong@intel.com>
3Date: Thu, 2 Jul 2015 23:51:01 +0800
4Subject: [PATCH] dpdk: add --sysroot option within app makefile
5
6Upstream-Status: Inappropriate [configuration]
7
8rte.app.mk has been changed to add -Wl, to all items listed
9under EXTRA_LDFLAGS. It causes --sysroot=<path> to not setup
10correctly when we depends on gcc to setup for GNU ld.
11
12Signed-off-by: Ong Boon Leong <boon.leong.ong@intel.com>
13Signed-off-by: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com>
14---
15 mk/rte.app.mk | 2 +-
16 1 file changed, 1 insertion(+), 1 deletion(-)
17
18diff --git a/mk/rte.app.mk b/mk/rte.app.mk
19index 8ecab41..35fcd8d 100644
20--- a/mk/rte.app.mk
21+++ b/mk/rte.app.mk
22@@ -186,7 +186,7 @@ ifeq ($(LINK_USING_CC),1)
23 override EXTRA_LDFLAGS := $(call linkerprefix,$(EXTRA_LDFLAGS))
24 O_TO_EXE = $(CC) $(CFLAGS) $(LDFLAGS_$(@)) \
25 -Wl,-Map=$(@).map,--cref -o $@ $(OBJS-y) $(call linkerprefix,$(LDFLAGS)) \
26- $(EXTRA_LDFLAGS) $(call linkerprefix,$(LDLIBS))
27+ $(EXTRA_LDFLAGS) $(SYSROOTPATH) $(call linkerprefix,$(LDLIBS))
28 else
29 O_TO_EXE = $(LD) $(LDFLAGS) $(LDFLAGS_$(@)) $(EXTRA_LDFLAGS) \
30 -Map=$(@).map --cref -o $@ $(OBJS-y) $(LDLIBS)
31--
321.9.1
33