summaryrefslogtreecommitdiffstats
path: root/meta-crownbay/conf
diff options
context:
space:
mode:
authorTom Zanussi <tom.zanussi@intel.com>2010-12-13 22:40:15 -0600
committerSaul Wold <sgw@linux.intel.com>2011-01-03 15:36:04 -0800
commitf09be34c92f2fdbb8dd957dd9581afc3a371fe8b (patch)
treec296741c2f2a097c7fa4d9c1fa9ad3232f60651d /meta-crownbay/conf
parentaf40e14ce335fa689d1a989feba3c02a8c71b7a7 (diff)
downloadmeta-intel-f09be34c92f2fdbb8dd957dd9581afc3a371fe8b.tar.gz
meta-crownbay: new layer for E6xx/EG20T systems
This layer provides support for Tunnel Creek + Topcliff Intel systems to laverne (0.90). It supports the E6xx embedded on-chip graphics via the Intel Embedded Media and Graphics Driver (EMGD) 1.5 Gold Driver. The EMGD and EG20T PCH kernel drivers are of course GPL'ed and are submitted in a separate patchset for the 2.6.34 yocto kernel. The userspace X drivers and supporting libraries however are closed and need to be manually copied into the layer before building. The details on how to do this can be found in the README doc in meta-crownbay/. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
Diffstat (limited to 'meta-crownbay/conf')
-rw-r--r--meta-crownbay/conf/layer.conf10
-rw-r--r--meta-crownbay/conf/machine/crownbay.conf46
2 files changed, 56 insertions, 0 deletions
diff --git a/meta-crownbay/conf/layer.conf b/meta-crownbay/conf/layer.conf
new file mode 100644
index 00000000..52581e1c
--- /dev/null
+++ b/meta-crownbay/conf/layer.conf
@@ -0,0 +1,10 @@
1# We have a conf and classes directory, add to BBPATH
2BBPATH := "${BBPATH}:${LAYERDIR}"
3
4# We have a recipes directory, add to BBFILES
5BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb \
6 ${LAYERDIR}/recipes-*/*/*.bbappend"
7
8BBFILE_COLLECTIONS += "crownbay"
9BBFILE_PATTERN_crownbay := "^${LAYERDIR}/"
10BBFILE_PRIORITY_crownbay = "6"
diff --git a/meta-crownbay/conf/machine/crownbay.conf b/meta-crownbay/conf/machine/crownbay.conf
new file mode 100644
index 00000000..1fc27b78
--- /dev/null
+++ b/meta-crownbay/conf/machine/crownbay.conf
@@ -0,0 +1,46 @@
1#@TYPE: Machine
2#@NAME: crownbay
3
4#@DESCRIPTION: Machine configuration for Crown Bay systems
5# i.e. E660 + EG20T
6
7TARGET_ARCH = "i586"
8PACKAGE_EXTRA_ARCHS = "x86 atom"
9
10include conf/machine/include/tune-atom.inc
11
12BASE_PACKAGE_ARCH="atom"
13
14MACHINE_FEATURES = "kernel26 screen keyboard pci usbhost ext2 ext3 x86 \
15 acpi serial usbgadget"
16
17KERNEL_IMAGETYPE = "bzImage"
18
19PREFERRED_PROVIDER_virtual/kernel ?= "linux-wrs"
20PREFERRED_PROVIDER_virtual/libx11 ?= "libx11-trim"
21PREFERRED_PROVIDER_virtual/libgl ?= "mesa-dri"
22PREFERRED_PROVIDER_virtual/xserver ?= "xserver-xf86-emgd"
23PREFERRED_PROVIDER_virtual/xserver-xf86 ?= "xserver-xf86-emgd"
24XSERVER ?= "xserver-xf86-emgd \
25 xserver-xf86-emgd-bin \
26 xf86-input-mouse \
27 xf86-input-keyboard \
28 xf86-input-evdev \
29 xf86-input-synaptics \
30 xf86-video-vesa"
31
32PREFERRED_VERSION_xserver-xf86-emgd ?= "1.7.99.2"
33PREFERRED_VERSION_xserver-xf86-emgd-bin ?= "1.7.99.2"
34
35SERIAL_CONSOLE = "115200 ttyS0"
36
37MACHINE_EXTRA_RRECOMMENDS = "kernel-modules eee-acpi-scripts"
38
39GUI_MACHINE_CLASS = "bigscreen"
40
41IMAGE_ROOTFS_SIZE_ext3 = "2000000"
42
43IMAGE_FSTYPES ?= "ext3 cpio.gz"
44
45GLIBC_ADDONS = "nptl"
46GLIBC_EXTRA_OECONF = "--with-tls"