summaryrefslogtreecommitdiffstats
path: root/dynamic-layers
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2024-04-29 12:48:11 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2024-04-29 16:20:58 +0800
commit7864daf8ecec559fe144ba3d767768ba7392ec86 (patch)
tree5b2ce1d5d931661e5fc1bb2400f65f3dca726201 /dynamic-layers
parent547f00bca5e81f52996b218771054b53f1752bcd (diff)
downloadmeta-intel-7864daf8ecec559fe144ba3d767768ba7392ec86.tar.gz
recipes: avoid using WORKDIR in do_install
Replace usage of WORKDIR in do_compile/do_install by ${S} or ${B}. It also helps with cases when externalsrc is used like with devtool. Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo_2024.0.0.bb10
1 files changed, 5 insertions, 5 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo_2024.0.0.bb b/dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo_2024.0.0.bb
index 495a4786..4c322f04 100644
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo_2024.0.0.bb
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo_2024.0.0.bb
@@ -44,11 +44,11 @@ do_install(){
44 install -d ${D}${bindir} 44 install -d ${D}${bindir}
45 install -d ${D}${datadir}/openvino/open-model-zoo/tools 45 install -d ${D}${datadir}/openvino/open-model-zoo/tools
46 install -d ${D}${datadir}/openvino/open-model-zoo/demos 46 install -d ${D}${datadir}/openvino/open-model-zoo/demos
47 cp -rf ${WORKDIR}/build/intel64/Release/*.a ${D}${libdir} 47 cp -rf ${B}/intel64/Release/*.a ${D}${libdir}
48 cp -rf ${WORKDIR}/build/intel64/Release/*_demo* ${D}${bindir} 48 cp -rf ${B}/intel64/Release/*_demo* ${D}${bindir}
49 cp -rf ${WORKDIR}/git/models ${D}${datadir}/openvino/open-model-zoo 49 cp -rf ${S}/models ${D}${datadir}/openvino/open-model-zoo
50 cp -rf ${WORKDIR}/git/demos ${D}${datadir}/openvino/open-model-zoo 50 cp -rf ${S}/demos ${D}${datadir}/openvino/open-model-zoo
51 cp -rf ${WORKDIR}/git/tools/model_tools ${D}${datadir}/openvino/open-model-zoo/tools 51 cp -rf ${S}/tools/model_tools ${D}${datadir}/openvino/open-model-zoo/tools
52} 52}
53 53
54FILES:${PN} += "${datadir}/openvino" 54FILES:${PN} += "${datadir}/openvino"