summaryrefslogtreecommitdiffstats
path: root/dynamic-layers
diff options
context:
space:
mode:
authorTeoh Suh Haw <suh.haw.teoh@intel.com>2023-06-08 16:00:25 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2023-06-09 13:25:43 +0800
commit3c367f25f6a0c043733b752e084a9c419416b5ad (patch)
tree00e968a12f8c8c2b9f2fe14ef8e75b9f5d8d872a /dynamic-layers
parentdbc3ac3084a4259e0f02c8849228bd7fe2fcf9ae (diff)
downloadmeta-intel-3c367f25f6a0c043733b752e084a9c419416b5ad.tar.gz
ispc: upgrade 1.19.0 -> 1.20.0
* Release Notes: https://github.com/ispc/ispc/releases/tag/v1.20.0 * Drop already merged patches: 0001-CMakeLists.txt-allow-to-pick-llvm-config-from-usr-bi.patch 0001-CMakeLists.txt-link-with-libclang-cpp-library-instea.patch ffc75e464ff2b8fce7dbf74f1846ebd0852bc6f9.patch * Fix packaging to ensure libispcrt is packaged correctly. * ISPC runtime with CPU support can either be enabled with OpenMP or TBB. TBB is enabled by default that needs meta-oe to be included. Signed-off-by: Teoh Suh Haw <suh.haw.teoh@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers')
-rw-r--r--dynamic-layers/clang-layer/recipes-core/ispc/ispc/0001-CMakeLists.txt-allow-to-pick-llvm-config-from-usr-bi.patch37
-rw-r--r--dynamic-layers/clang-layer/recipes-core/ispc/ispc/0001-CMakeLists.txt-link-with-libclang-cpp-library-instea.patch28
-rw-r--r--dynamic-layers/clang-layer/recipes-core/ispc/ispc/ffc75e464ff2b8fce7dbf74f1846ebd0852bc6f9.patch32
-rw-r--r--dynamic-layers/openembedded-layer/recipes-core/ispc/ispc/0001-Add-print-function-to-print-test-run-status-in-ptest.patch (renamed from dynamic-layers/clang-layer/recipes-core/ispc/ispc/0001-Add-print-function-to-print-test-run-status-in-ptest.patch)0
-rw-r--r--dynamic-layers/openembedded-layer/recipes-core/ispc/ispc/0001-Fix-QA-Issues.patch (renamed from dynamic-layers/clang-layer/recipes-core/ispc/ispc/0001-Fix-QA-Issues.patch)0
-rw-r--r--dynamic-layers/openembedded-layer/recipes-core/ispc/ispc/0002-cmake-don-t-build-for-32-bit-targets.patch (renamed from dynamic-layers/clang-layer/recipes-core/ispc/ispc/0002-cmake-don-t-build-for-32-bit-targets.patch)0
-rw-r--r--dynamic-layers/openembedded-layer/recipes-core/ispc/ispc/run-ptest (renamed from dynamic-layers/clang-layer/recipes-core/ispc/ispc/run-ptest)0
-rw-r--r--dynamic-layers/openembedded-layer/recipes-core/ispc/ispc_1.20.0.bb (renamed from dynamic-layers/clang-layer/recipes-core/ispc/ispc_1.19.0.bb)19
8 files changed, 14 insertions, 102 deletions
diff --git a/dynamic-layers/clang-layer/recipes-core/ispc/ispc/0001-CMakeLists.txt-allow-to-pick-llvm-config-from-usr-bi.patch b/dynamic-layers/clang-layer/recipes-core/ispc/ispc/0001-CMakeLists.txt-allow-to-pick-llvm-config-from-usr-bi.patch
deleted file mode 100644
index 79e8e683..00000000
--- a/dynamic-layers/clang-layer/recipes-core/ispc/ispc/0001-CMakeLists.txt-allow-to-pick-llvm-config-from-usr-bi.patch
+++ /dev/null
@@ -1,37 +0,0 @@
1From 51d248d3b470f3fa1cf2ed3f5742851091acb65f Mon Sep 17 00:00:00 2001
2From: Naveen Saini <naveen.kumar.saini@intel.com>
3Date: Fri, 12 May 2023 09:10:11 +0800
4Subject: [PATCH] CMakeLists.txt: allow to pick llvm-config from
5 usr/bin/crossscripts/
6
7ispc needs to invoke native llvm-config from target sysroot to list LLVM
8lib libraries. clang already provides crossscripts/llvm-config, which does
9the job.
10
11However, using LLVM_TOOLS_BINARY_DIR leads to wrong llvm-config being
12used. So remove it from search path for llvm-config.
13
14Upstream-Status: Inappropriate
15
16Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
17---
18 cmake/FindLLVM.cmake | 3 +--
19 1 file changed, 1 insertion(+), 2 deletions(-)
20
21diff --git a/cmake/FindLLVM.cmake b/cmake/FindLLVM.cmake
22index d0297d5d..90d9fed2 100644
23--- a/cmake/FindLLVM.cmake
24+++ b/cmake/FindLLVM.cmake
25@@ -41,8 +41,7 @@ find_package(LLVM REQUIRED CONFIG)
26 set(LLVM_VERSION "LLVM_${LLVM_VERSION_MAJOR}_${LLVM_VERSION_MINOR}")
27 message(STATUS "Found LLVM ${LLVM_VERSION}")
28
29-find_program(LLVM_CONFIG_EXECUTABLE NAMES llvm-config
30- PATHS ${LLVM_TOOLS_BINARY_DIR} PATH_SUFFIXES bin NO_DEFAULT_PATH)
31+find_program(LLVM_CONFIG_EXECUTABLE NAMES llvm-config)
32 if (NOT LLVM_CONFIG_EXECUTABLE)
33 message(FATAL_ERROR "Failed to find llvm-config")
34 endif()
35--
362.37.3
37
diff --git a/dynamic-layers/clang-layer/recipes-core/ispc/ispc/0001-CMakeLists.txt-link-with-libclang-cpp-library-instea.patch b/dynamic-layers/clang-layer/recipes-core/ispc/ispc/0001-CMakeLists.txt-link-with-libclang-cpp-library-instea.patch
deleted file mode 100644
index cacbbbc1..00000000
--- a/dynamic-layers/clang-layer/recipes-core/ispc/ispc/0001-CMakeLists.txt-link-with-libclang-cpp-library-instea.patch
+++ /dev/null
@@ -1,28 +0,0 @@
1From 0445d97c8ad66c9cbb2c6f88c52aadc0b01a1f15 Mon Sep 17 00:00:00 2001
2From: Naveen Saini <naveen.kumar.saini@intel.com>
3Date: Tue, 11 Oct 2022 16:43:22 +0800
4Subject: [PATCH] CMakeLists.txt: link with libclang-cpp library instead
5
6Upstream-Status: Inappropriate
7
8Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
9---
10 CMakeLists.txt | 2 +-
11 1 file changed, 1 insertion(+), 1 deletion(-)
12
13diff --git a/CMakeLists.txt b/CMakeLists.txt
14index f6199704..f979f1c1 100644
15--- a/CMakeLists.txt
16+++ b/CMakeLists.txt
17@@ -288,7 +288,7 @@ if (WASM_ENABLED)
18 list(APPEND ISPC_TARGETS wasm-i32x4)
19 endif()
20
21-set(CLANG_LIBRARY_LIST clangFrontend clangDriver clangSerialization clangParse clangSema clangAnalysis clangAST clangBasic clangEdit clangLex)
22+set(CLANG_LIBRARY_LIST clang-cpp)
23 if (${LLVM_VERSION_NUMBER} VERSION_GREATER_EQUAL "15.0.0")
24 list(APPEND CLANG_LIBRARY_LIST clangSupport)
25 endif()
26--
272.37.3
28
diff --git a/dynamic-layers/clang-layer/recipes-core/ispc/ispc/ffc75e464ff2b8fce7dbf74f1846ebd0852bc6f9.patch b/dynamic-layers/clang-layer/recipes-core/ispc/ispc/ffc75e464ff2b8fce7dbf74f1846ebd0852bc6f9.patch
deleted file mode 100644
index 52fb8126..00000000
--- a/dynamic-layers/clang-layer/recipes-core/ispc/ispc/ffc75e464ff2b8fce7dbf74f1846ebd0852bc6f9.patch
+++ /dev/null
@@ -1,32 +0,0 @@
1From ffc75e464ff2b8fce7dbf74f1846ebd0852bc6f9 Mon Sep 17 00:00:00 2001
2From: Luya Tshimbalanga <luya@fedoraproject.org>
3Date: Tue, 28 Feb 2023 17:20:21 -0800
4Subject: [PATCH] Fix build with GCC 13 and possibly Clang 15
5
6This fix add missing <cstdint> include to handle "uint32_t".
7
8Upstream-Status: Backport
9Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
10---
11 src/target_registry.h | 3 ++-
12 1 file changed, 2 insertions(+), 1 deletion(-)
13
14diff --git a/src/target_registry.h b/src/target_registry.h
15index 2f7d13a8af..bad4ed0815 100644
16--- a/src/target_registry.h
17+++ b/src/target_registry.h
18@@ -1,5 +1,5 @@
19 /*
20- Copyright (c) 2019-2021, Intel Corporation
21+ Copyright (c) 2019-2023, Intel Corporation
22 All rights reserved.
23
24 Redistribution and use in source and binary forms, with or without
25@@ -40,6 +40,7 @@
26 #include "bitcode_lib.h"
27
28 #include <bitset>
29+#include <cstdint>
30 #include <map>
31 #include <vector>
32
diff --git a/dynamic-layers/clang-layer/recipes-core/ispc/ispc/0001-Add-print-function-to-print-test-run-status-in-ptest.patch b/dynamic-layers/openembedded-layer/recipes-core/ispc/ispc/0001-Add-print-function-to-print-test-run-status-in-ptest.patch
index 3ce431d4..3ce431d4 100644
--- a/dynamic-layers/clang-layer/recipes-core/ispc/ispc/0001-Add-print-function-to-print-test-run-status-in-ptest.patch
+++ b/dynamic-layers/openembedded-layer/recipes-core/ispc/ispc/0001-Add-print-function-to-print-test-run-status-in-ptest.patch
diff --git a/dynamic-layers/clang-layer/recipes-core/ispc/ispc/0001-Fix-QA-Issues.patch b/dynamic-layers/openembedded-layer/recipes-core/ispc/ispc/0001-Fix-QA-Issues.patch
index e7bb599e..e7bb599e 100644
--- a/dynamic-layers/clang-layer/recipes-core/ispc/ispc/0001-Fix-QA-Issues.patch
+++ b/dynamic-layers/openembedded-layer/recipes-core/ispc/ispc/0001-Fix-QA-Issues.patch
diff --git a/dynamic-layers/clang-layer/recipes-core/ispc/ispc/0002-cmake-don-t-build-for-32-bit-targets.patch b/dynamic-layers/openembedded-layer/recipes-core/ispc/ispc/0002-cmake-don-t-build-for-32-bit-targets.patch
index a13ade9f..a13ade9f 100644
--- a/dynamic-layers/clang-layer/recipes-core/ispc/ispc/0002-cmake-don-t-build-for-32-bit-targets.patch
+++ b/dynamic-layers/openembedded-layer/recipes-core/ispc/ispc/0002-cmake-don-t-build-for-32-bit-targets.patch
diff --git a/dynamic-layers/clang-layer/recipes-core/ispc/ispc/run-ptest b/dynamic-layers/openembedded-layer/recipes-core/ispc/ispc/run-ptest
index 77d13bb4..77d13bb4 100644
--- a/dynamic-layers/clang-layer/recipes-core/ispc/ispc/run-ptest
+++ b/dynamic-layers/openembedded-layer/recipes-core/ispc/ispc/run-ptest
diff --git a/dynamic-layers/clang-layer/recipes-core/ispc/ispc_1.19.0.bb b/dynamic-layers/openembedded-layer/recipes-core/ispc/ispc_1.20.0.bb
index ab48f5fb..4e607004 100644
--- a/dynamic-layers/clang-layer/recipes-core/ispc/ispc_1.19.0.bb
+++ b/dynamic-layers/openembedded-layer/recipes-core/ispc/ispc_1.20.0.bb
@@ -5,23 +5,20 @@ HOMEPAGE = "https://github.com/ispc/ispc"
5 5
6LICENSE = "BSD-3-Clause & Apache-2.0-with-LLVM-exception" 6LICENSE = "BSD-3-Clause & Apache-2.0-with-LLVM-exception"
7LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=da5ecffdd210b3cf776b32b41c182e87 \ 7LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=da5ecffdd210b3cf776b32b41c182e87 \
8 file://third-party-programs.txt;md5=3cd6f8a7c3bd9d2bb898fcb27c75221a" 8 file://third-party-programs.txt;md5=2061218c7be521556719c8b504bf9ddd"
9 9
10inherit cmake python3native ptest 10inherit cmake python3native ptest
11 11
12S = "${WORKDIR}/git" 12S = "${WORKDIR}/git"
13 13
14SRC_URI = "git://github.com/ispc/ispc.git;protocol=https;branch=main \ 14SRC_URI = "git://github.com/ispc/ispc.git;protocol=https;branch=main \
15 file://0001-CMakeLists.txt-link-with-libclang-cpp-library-instea.patch \
16 file://0002-cmake-don-t-build-for-32-bit-targets.patch \ 15 file://0002-cmake-don-t-build-for-32-bit-targets.patch \
17 file://0001-Fix-QA-Issues.patch \ 16 file://0001-Fix-QA-Issues.patch \
18 file://0001-Add-print-function-to-print-test-run-status-in-ptest.patch \ 17 file://0001-Add-print-function-to-print-test-run-status-in-ptest.patch \
19 file://0001-CMakeLists.txt-allow-to-pick-llvm-config-from-usr-bi.patch \
20 file://ffc75e464ff2b8fce7dbf74f1846ebd0852bc6f9.patch \
21 file://run-ptest \ 18 file://run-ptest \
22 " 19 "
23 20
24SRCREV = "ee43967286215a0511c2bc090e604848b4a32bed" 21SRCREV = "14bd04aa7e68cd33eb1d96b33058cb64d7ef76f4"
25 22
26COMPATIBLE_HOST = '(x86_64).*-linux' 23COMPATIBLE_HOST = '(x86_64).*-linux'
27 24
@@ -29,6 +26,9 @@ DEPENDS += " clang-native bison-native flex-native"
29DEPENDS:append:class-target = " clang" 26DEPENDS:append:class-target = " clang"
30RDEPENDS:${PN}-ptest += " python3-multiprocessing" 27RDEPENDS:${PN}-ptest += " python3-multiprocessing"
31 28
29PACKAGECONFIG ??= "tbb"
30PACKAGECONFIG[tbb] = "-DISPCRT_BUILD_TASK_MODEL=TBB, -DISPCRT_BUILD_TASK_MODEL=OpenMP, tbb"
31
32YFLAGS='-d -t -v -y --file-prefix-map=${WORKDIR}=/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}' 32YFLAGS='-d -t -v -y --file-prefix-map=${WORKDIR}=/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}'
33 33
34do_configure:prepend() { 34do_configure:prepend() {
@@ -62,4 +62,13 @@ EXTRA_OECMAKE += " \
62 -DLLVM_DIS_EXECUTABLE=${STAGING_BINDIR_NATIVE}/llvm-dis \ 62 -DLLVM_DIS_EXECUTABLE=${STAGING_BINDIR_NATIVE}/llvm-dis \
63 -DLLVM_AS_EXECUTABLE=${STAGING_BINDIR_NATIVE}/llvm-as \ 63 -DLLVM_AS_EXECUTABLE=${STAGING_BINDIR_NATIVE}/llvm-as \
64 " 64 "
65
66FILES:${PN}-dev = "\
67 ${libdir}/libispcrt_device_cpu${SOLIBSDEV} \
68 ${libdir}/cmake \
69 ${includedir} \
70 "
71
72FILES:${PN} += "${libdir}/libispcrt.so"
73
65BBCLASSEXTEND = "native nativesdk" 74BBCLASSEXTEND = "native nativesdk"