summaryrefslogtreecommitdiffstats
path: root/dynamic-layers
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2023-08-21 09:47:15 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2023-08-21 12:21:15 +0800
commit068533789330a35320cefa8bfbae180d4aea19f8 (patch)
tree6da7e8044b936c4f8f04c5bebdfa5a9c95ef70d3 /dynamic-layers
parent7368b9654e181ab0f3214df2cf40328f54237109 (diff)
downloadmeta-intel-068533789330a35320cefa8bfbae180d4aea19f8.tar.gz
ispc: upgrade 1.20.0 -> 1.21.0
* Allows compilation with LLVM16. * ISPC_NO_DUMPS is no longer an option and ISPC_PS4_TARGET has been renamed. * Libraries now have proper so versions so packaging tweaks are no longer required. Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-core/ispc/ispc/0002-cmake-don-t-build-for-32-bit-targets.patch27
-rw-r--r--dynamic-layers/openembedded-layer/recipes-core/ispc/ispc_1.21.0.bb (renamed from dynamic-layers/openembedded-layer/recipes-core/ispc/ispc_1.20.0.bb)13
2 files changed, 11 insertions, 29 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-core/ispc/ispc/0002-cmake-don-t-build-for-32-bit-targets.patch b/dynamic-layers/openembedded-layer/recipes-core/ispc/ispc/0002-cmake-don-t-build-for-32-bit-targets.patch
index a13ade9f..ef9d99c0 100644
--- a/dynamic-layers/openembedded-layer/recipes-core/ispc/ispc/0002-cmake-don-t-build-for-32-bit-targets.patch
+++ b/dynamic-layers/openembedded-layer/recipes-core/ispc/ispc/0002-cmake-don-t-build-for-32-bit-targets.patch
@@ -1,4 +1,4 @@
1From 493e886d6dae2ed7bdc12ed03f717ee0e98dfe09 Mon Sep 17 00:00:00 2001 1From cad70deae39566fa11814e27f06d5fe8ddcb1cbc Mon Sep 17 00:00:00 2001
2From: Naveen Saini <naveen.kumar.saini@intel.com> 2From: Naveen Saini <naveen.kumar.saini@intel.com>
3Date: Thu, 24 Feb 2022 20:01:11 +0530 3Date: Thu, 24 Feb 2022 20:01:11 +0530
4Subject: [PATCH] cmake: don't build for 32-bit targets 4Subject: [PATCH] cmake: don't build for 32-bit targets
@@ -16,14 +16,14 @@ Upstream-Status: Inappropriate
16 16
17Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> 17Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
18--- 18---
19 cmake/GenerateBuiltins.cmake | 8 ++++---- 19 cmake/GenerateBuiltins.cmake | 6 +++---
20 1 file changed, 4 insertions(+), 4 deletions(-) 20 1 file changed, 3 insertions(+), 3 deletions(-)
21 21
22diff --git a/cmake/GenerateBuiltins.cmake b/cmake/GenerateBuiltins.cmake 22diff --git a/cmake/GenerateBuiltins.cmake b/cmake/GenerateBuiltins.cmake
23index fa228247..7adc7e52 100644 23index 936590a7..b8f731de 100644
24--- a/cmake/GenerateBuiltins.cmake 24--- a/cmake/GenerateBuiltins.cmake
25+++ b/cmake/GenerateBuiltins.cmake 25+++ b/cmake/GenerateBuiltins.cmake
26@@ -272,7 +272,7 @@ function(builtin_to_cpp bit os_name arch supported_archs supported_oses resultFi 26@@ -253,7 +253,7 @@ function(builtin_to_cpp bit os_name arch supported_archs supported_oses resultFi
27 # In this case headers will be installed in /usr/arm-linux-gnueabihf/include and will not be picked up 27 # In this case headers will be installed in /usr/arm-linux-gnueabihf/include and will not be picked up
28 # by clang by default. So the following line adds such path explicitly. If this path doesn't exist and 28 # by clang by default. So the following line adds such path explicitly. If this path doesn't exist and
29 # the headers can be found in other locations, this should not be a problem. 29 # the headers can be found in other locations, this should not be a problem.
@@ -32,7 +32,7 @@ index fa228247..7adc7e52 100644
32 endif() 32 endif()
33 endif() 33 endif()
34 34
35@@ -354,7 +354,7 @@ function (generate_target_builtins resultList) 35@@ -340,7 +340,7 @@ function (generate_target_builtins resultList)
36 set(regular_targets ${ARGN}) 36 set(regular_targets ${ARGN})
37 list(FILTER regular_targets EXCLUDE REGEX wasm) 37 list(FILTER regular_targets EXCLUDE REGEX wasm)
38 foreach (ispc_target ${regular_targets}) 38 foreach (ispc_target ${regular_targets})
@@ -41,24 +41,15 @@ index fa228247..7adc7e52 100644
41 foreach (os_name ${TARGET_OS_LIST_FOR_LL}) 41 foreach (os_name ${TARGET_OS_LIST_FOR_LL})
42 target_ll_to_cpp(target-${ispc_target} ${bit} ${os_name} output${os_name}${bit}) 42 target_ll_to_cpp(target-${ispc_target} ${bit} ${os_name} output${os_name}${bit})
43 list(APPEND tmpList ${output${os_name}${bit}}) 43 list(APPEND tmpList ${output${os_name}${bit}})
44@@ -415,7 +415,7 @@ function (generate_common_builtins resultList) 44@@ -406,7 +406,7 @@ function (generate_common_builtins resultList)
45 endif() 45 endif()
46 46
47 message (STATUS "ISPC will be built with support of ${supported_oses} for ${supported_archs}") 47 message (STATUS "ISPC will be built with support of ${supported_oses} for ${supported_archs}")
48- foreach (bit 32 64) 48- foreach (bit 32 64)
49+ foreach (bit 64) 49+ foreach (bit 64)
50 foreach (os_name "windows" "linux" "freebsd" "macos" "android" "ios" "ps4" "web") 50 foreach (os_name "windows" "linux" "freebsd" "macos" "android" "ios" "ps4" "web")
51 foreach (arch "x86" "arm" "wasm32") 51 foreach (arch "x86" "arm" "wasm")
52 builtin_to_cpp(${bit} ${os_name} ${arch} "${supported_archs}" "${supported_oses}" res${bit}${os_name}${arch}) 52 builtin_to_cpp(${bit} ${os_name} ${arch} "${supported_archs}" "${supported_oses}" res${bit}${os_name}${arch})
53@@ -428,7 +428,7 @@ function (generate_common_builtins resultList)
54 endforeach()
55 endforeach()
56 if (XE_ENABLED)
57- foreach (bit 32 64)
58+ foreach (bit 64)
59 builtin_xe_to_cpp(${bit} res_xe_${bit})
60 list(APPEND tmpList ${res_xe_${bit}} )
61 if(MSVC)
62-- 53--
632.17.1 542.41.0
64 55
diff --git a/dynamic-layers/openembedded-layer/recipes-core/ispc/ispc_1.20.0.bb b/dynamic-layers/openembedded-layer/recipes-core/ispc/ispc_1.21.0.bb
index 4e607004..773ed594 100644
--- a/dynamic-layers/openembedded-layer/recipes-core/ispc/ispc_1.20.0.bb
+++ b/dynamic-layers/openembedded-layer/recipes-core/ispc/ispc_1.21.0.bb
@@ -18,7 +18,7 @@ SRC_URI = "git://github.com/ispc/ispc.git;protocol=https;branch=main \
18 file://run-ptest \ 18 file://run-ptest \
19 " 19 "
20 20
21SRCREV = "14bd04aa7e68cd33eb1d96b33058cb64d7ef76f4" 21SRCREV = "f925f2563441a36eff1cb7a617934253dc9c100c"
22 22
23COMPATIBLE_HOST = '(x86_64).*-linux' 23COMPATIBLE_HOST = '(x86_64).*-linux'
24 24
@@ -48,14 +48,13 @@ do_install_ptest() {
48EXTRA_OECMAKE += " \ 48EXTRA_OECMAKE += " \
49 -DISPC_INCLUDE_TESTS=OFF \ 49 -DISPC_INCLUDE_TESTS=OFF \
50 -DISPC_INCLUDE_EXAMPLES=OFF \ 50 -DISPC_INCLUDE_EXAMPLES=OFF \
51 -DISPC_NO_DUMPS=ON \
52 -DARM_ENABLED=OFF \ 51 -DARM_ENABLED=OFF \
53 -DISPC_CROSS=ON \ 52 -DISPC_CROSS=ON \
54 -DISPC_ANDROID_TARGET=OFF \ 53 -DISPC_ANDROID_TARGET=OFF \
55 -DISPC_FREEBSD_TARGET=OFF \ 54 -DISPC_FREEBSD_TARGET=OFF \
56 -DISPC_WINDOWS_TARGET=OFF \ 55 -DISPC_WINDOWS_TARGET=OFF \
57 -DISPC_IOS_TARGET=OFF \ 56 -DISPC_IOS_TARGET=OFF \
58 -DISPC_PS4_TARGET=OFF \ 57 -DISPC_PS_TARGET=OFF \
59 -DSYSROOT_DIR=${STAGING_DIR} \ 58 -DSYSROOT_DIR=${STAGING_DIR} \
60 -DCLANG_EXECUTABLE=${STAGING_BINDIR_NATIVE}/clang \ 59 -DCLANG_EXECUTABLE=${STAGING_BINDIR_NATIVE}/clang \
61 -DCLANGPP_EXECUTABLE=${STAGING_BINDIR_NATIVE}/clang++ \ 60 -DCLANGPP_EXECUTABLE=${STAGING_BINDIR_NATIVE}/clang++ \
@@ -63,12 +62,4 @@ EXTRA_OECMAKE += " \
63 -DLLVM_AS_EXECUTABLE=${STAGING_BINDIR_NATIVE}/llvm-as \ 62 -DLLVM_AS_EXECUTABLE=${STAGING_BINDIR_NATIVE}/llvm-as \
64 " 63 "
65 64
66FILES:${PN}-dev = "\
67 ${libdir}/libispcrt_device_cpu${SOLIBSDEV} \
68 ${libdir}/cmake \
69 ${includedir} \
70 "
71
72FILES:${PN} += "${libdir}/libispcrt.so"
73
74BBCLASSEXTEND = "native nativesdk" 65BBCLASSEXTEND = "native nativesdk"