summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer
diff options
context:
space:
mode:
authorNaveen Saini <naveen.kumar.saini@intel.com>2023-01-25 18:22:37 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2023-01-26 09:34:50 +0800
commitb3c7d3ee44e4ab71df44b5be3c48d2f47d89d8a0 (patch)
tree11539a7d8ab513fd165accc2168d195cd6294d97 /dynamic-layers/openembedded-layer
parente99ca0c5cdc0465c688bc205f34227a5ba38d24c (diff)
downloadmeta-intel-b3c7d3ee44e4ab71df44b5be3c48d2f47d89d8a0.tar.gz
intel-oneapi-mkl: install missing headers
Download the -devel package to have MKL headers available too. Static libraries take too much space (>5GB) so package them separately. Make sure that the directories in /opt are not symlinked to avoid errors for packages (like tbb) that also install directories with same name in $includedir. Fixes: | fatal error: 'oneapi/mkl.hpp' file not found Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers/openembedded-layer')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-oneapi/mkl/intel-oneapi-mkl_2023.0.0-25398.bb24
1 files changed, 20 insertions, 4 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-oneapi/mkl/intel-oneapi-mkl_2023.0.0-25398.bb b/dynamic-layers/openembedded-layer/recipes-oneapi/mkl/intel-oneapi-mkl_2023.0.0-25398.bb
index 9d8c7826..61a0721b 100644
--- a/dynamic-layers/openembedded-layer/recipes-oneapi/mkl/intel-oneapi-mkl_2023.0.0-25398.bb
+++ b/dynamic-layers/openembedded-layer/recipes-oneapi/mkl/intel-oneapi-mkl_2023.0.0-25398.bb
@@ -25,34 +25,50 @@ MKLMAINVER = "2023.0.0"
25SRC_URI = " \ 25SRC_URI = " \
26 https://apt.repos.intel.com/oneapi/pool/main/intel-oneapi-runtime-mkl-${PV}_amd64.deb;subdir=${BPN};name=runtime \ 26 https://apt.repos.intel.com/oneapi/pool/main/intel-oneapi-runtime-mkl-${PV}_amd64.deb;subdir=${BPN};name=runtime \
27 https://apt.repos.intel.com/oneapi/pool/main/intel-oneapi-runtime-mkl-common-${PV}_all.deb;subdir=${BPN};name=common \ 27 https://apt.repos.intel.com/oneapi/pool/main/intel-oneapi-runtime-mkl-common-${PV}_all.deb;subdir=${BPN};name=common \
28 https://apt.repos.intel.com/oneapi/pool/main/intel-oneapi-mkl-common-devel-${MKLMAINVER}-${PV}_all.deb;subdir=${BPN};name=devel \ 28 https://apt.repos.intel.com/oneapi/pool/main/intel-oneapi-mkl-common-devel-${MKLMAINVER}-${PV}_all.deb;subdir=${BPN};name=common-devel \
29 https://apt.repos.intel.com/oneapi/pool/main/intel-oneapi-mkl-devel-${MKLMAINVER}-${PV}_amd64.deb;subdir=${BPN};name=devel \
30 https://apt.repos.intel.com/oneapi/pool/main/intel-oneapi-mkl-common-${MKLMAINVER}-${PV}_all.deb;subdir=${BPN};name=common-vars \
29 " 31 "
30 32
31SRC_URI[runtime.sha256sum] = "e681b760aa3ca669f56c535cae5bf5b990fbc768301d0d4885b4a6acffd51f3b" 33SRC_URI[runtime.sha256sum] = "e681b760aa3ca669f56c535cae5bf5b990fbc768301d0d4885b4a6acffd51f3b"
32SRC_URI[common.sha256sum] = "5983af05c8f8873d3df772392b87612c09594ca0ee7c2f667857c517b0024062" 34SRC_URI[common.sha256sum] = "5983af05c8f8873d3df772392b87612c09594ca0ee7c2f667857c517b0024062"
33SRC_URI[devel.sha256sum] = "114861a697500e5ee5e0e5f1e920bc0c96dbacd80145877e4974c582acb26c52" 35SRC_URI[common-devel.sha256sum] = "114861a697500e5ee5e0e5f1e920bc0c96dbacd80145877e4974c582acb26c52"
36SRC_URI[devel.sha256sum] = "ee582b8e443b6104e3cc8813f990e8081a0e44d203aa0f65edca0f3406107793"
37SRC_URI[common-vars.sha256sum] = "47fc873a5c0b736016ed76b7b99fd93b6bd9c27ee052a23e1944d8095b1b0a6c"
34 38
35S = "${WORKDIR}/${BPN}" 39S = "${WORKDIR}/${BPN}"
36 40
37inherit bin_package 41inherit bin_package
38 42
39do_install:append () { 43do_install:append () {
44 install -d ${D}${bindir}
45 (cd ${D}${bindir} ; ln -s ../../opt/intel/oneapi/mkl/${MKLMAINVER}/bin/intel64/* .)
40 install -d ${D}${libdir} 46 install -d ${D}${libdir}
41 (cd ${D}${libdir} ; ln -s ../../opt/intel/oneapi/lib/intel64/*.so* .) 47 (cd ${D}${libdir} ; ln -s ../../opt/intel/oneapi/lib/intel64/*.so* .)
48 (cd ${D}${libdir} ; ln -s ../../opt/intel/oneapi/mkl/${MKLMAINVER}/lib/intel64/*.a* .)
42 install -d ${D}${libdir}/pkgconfig 49 install -d ${D}${libdir}/pkgconfig
43 (cd ${D}${libdir}/pkgconfig ; ln -s ../../../opt/intel/oneapi/mkl/${MKLMAINVER}/lib/pkgconfig/* .) 50 (cd ${D}${libdir}/pkgconfig ; ln -s ../../../opt/intel/oneapi/mkl/${MKLMAINVER}/lib/pkgconfig/* .)
44 install -d ${D}${libdir}/cmake 51 install -d ${D}${libdir}/cmake
45 (cd ${D}${libdir}/cmake ; ln -s ../../../opt/intel/oneapi/mkl/${MKLMAINVER}/lib/cmake/* .) 52 (cd ${D}${libdir}/cmake ; ln -s ../../../opt/intel/oneapi/mkl/${MKLMAINVER}/lib/cmake/* .)
46 53
47 install -d ${D}${includedir} 54 install -d ${D}${includedir}
48 (cd ${D}${includedir} ; ln -s ../../opt/intel/oneapi/mkl/${MKLMAINVER}/include/* .) 55 find ${D}/opt/intel/oneapi/mkl/${MKLMAINVER}/include/ -mindepth 1 -maxdepth 1 -type d -printf '%f\n' | while read srcdir; do
56 install -d ${D}${includedir}/$srcdir
57 (cd ${D}${includedir} ; ln -s ../../opt/intel/oneapi/mkl/${MKLMAINVER}/include/$srcdir/* ./$srcdir/)
58 done
59
60 find ${D}/opt/intel/oneapi/mkl/${MKLMAINVER}/include/ -mindepth 1 -maxdepth 1 -type f -printf '%f\n' | while read srcfile; do
61 (cd ${D}${includedir} ; ln -s ../../opt/intel/oneapi/mkl/${MKLMAINVER}/include/$srcfile .)
62 done
49} 63}
50 64
51INHIBIT_PACKAGE_STRIP = "1" 65INHIBIT_PACKAGE_STRIP = "1"
52INHIBIT_PACKAGE_DEBUG_SPLIT = "1" 66INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
53 67
54RDEPENDS:${PN} += "bash tbb intel-oneapi-compiler setup-intel-oneapi-env ocl-icd" 68RDEPENDS:${PN} += "bash tbb intel-oneapi-compiler setup-intel-oneapi-env ocl-icd"
55INSANE_SKIP:${PN} = "ldflags textrel dev-so" 69INSANE_SKIP:${PN} = "ldflags textrel dev-so staticdev"
70
71FILES:${PN}-staticdev += "/opt/intel/oneapi/mkl/${MKLMAINVER}/lib/intel64/*.a*"
56 72
57SKIP_FILEDEPS:${PN} = '1' 73SKIP_FILEDEPS:${PN} = '1'
58 74