summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-support/opencv
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2023-02-22 15:35:49 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2023-02-22 21:49:13 +0800
commit1790fd8d2ed4b0176f493f29408cee7f9a6949a3 (patch)
tree89f1ef25f10330e3c947d00920581ec8a04f5754 /dynamic-layers/openembedded-layer/recipes-support/opencv
parentcba5ffa6d4c5fec8900811ba86d7def73f63140e (diff)
downloadmeta-intel-1790fd8d2ed4b0176f493f29408cee7f9a6949a3.tar.gz
openvino-inference-engine: update to latest on 2022.3 branch
Brings in support for NumPy 1.24 and support for system installed OpenCL. Includes a newer version of myriad firmware as well. Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-support/opencv')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build.patch40
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2022.3.0.bb12
2 files changed, 14 insertions, 38 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build.patch
index ed488808..86ed2a96 100644
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build.patch
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build.patch
@@ -1,17 +1,14 @@
1Yocto specific tweaks to the build process: 1Yocto specific tweaks to the build process:
2 2
3* Install python modules to site-packages.
4* Dont try to detect glibc version as that doesn't work when cross compiling. 3* Dont try to detect glibc version as that doesn't work when cross compiling.
5* Use shared protobuf and gflags libs. 4* Use shared protobuf and gflags libs.
6* Use system installed ocl headers.
7* We have va.h in recipe-sysroot and having a va.h here leads to failures.
8* Install sample binaries as well. 5* Install sample binaries as well.
9 6
10Upstream-Status: Inappropriate 7Upstream-Status: Inappropriate
11Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> 8Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
12 9
13diff --git a/cmake/developer_package/target_flags.cmake b/cmake/developer_package/target_flags.cmake 10diff --git a/cmake/developer_package/target_flags.cmake b/cmake/developer_package/target_flags.cmake
14index 62831fffab..b123bbad75 100644 11index e6c72540288..fec9996db14 100644
15--- a/cmake/developer_package/target_flags.cmake 12--- a/cmake/developer_package/target_flags.cmake
16+++ b/cmake/developer_package/target_flags.cmake 13+++ b/cmake/developer_package/target_flags.cmake
17@@ -123,4 +123,4 @@ function(ov_glibc_version) 14@@ -123,4 +123,4 @@ function(ov_glibc_version)
@@ -21,7 +18,7 @@ index 62831fffab..b123bbad75 100644
21-ov_glibc_version() 18-ov_glibc_version()
22+#ov_glibc_version() 19+#ov_glibc_version()
23diff --git a/samples/c/common/opencv_c_wrapper/CMakeLists.txt b/samples/c/common/opencv_c_wrapper/CMakeLists.txt 20diff --git a/samples/c/common/opencv_c_wrapper/CMakeLists.txt b/samples/c/common/opencv_c_wrapper/CMakeLists.txt
24index f27e934793..da51c56cf3 100644 21index 40c29d3c297..f6800592de9 100644
25--- a/samples/c/common/opencv_c_wrapper/CMakeLists.txt 22--- a/samples/c/common/opencv_c_wrapper/CMakeLists.txt
26+++ b/samples/c/common/opencv_c_wrapper/CMakeLists.txt 23+++ b/samples/c/common/opencv_c_wrapper/CMakeLists.txt
27@@ -32,5 +32,4 @@ endif() 24@@ -32,5 +32,4 @@ endif()
@@ -32,7 +29,7 @@ index f27e934793..da51c56cf3 100644
32-) 29-)
33+ LIBRARY DESTINATION ${IE_CPACK_LIBRARY_PATH} COMPONENT samples_bin) 30+ LIBRARY DESTINATION ${IE_CPACK_LIBRARY_PATH} COMPONENT samples_bin)
34diff --git a/samples/cpp/CMakeLists.txt b/samples/cpp/CMakeLists.txt 31diff --git a/samples/cpp/CMakeLists.txt b/samples/cpp/CMakeLists.txt
35index 3a10819c47..d82262a714 100644 32index 1fe54c602e8..01c86d418d9 100644
36--- a/samples/cpp/CMakeLists.txt 33--- a/samples/cpp/CMakeLists.txt
37+++ b/samples/cpp/CMakeLists.txt 34+++ b/samples/cpp/CMakeLists.txt
38@@ -230,9 +230,8 @@ macro(ie_add_sample) 35@@ -230,9 +230,8 @@ macro(ie_add_sample)
@@ -48,7 +45,7 @@ index 3a10819c47..d82262a714 100644
48 # create global target with all samples / demo apps 45 # create global target with all samples / demo apps
49 if(NOT TARGET ie_samples) 46 if(NOT TARGET ie_samples)
50diff --git a/samples/cpp/common/format_reader/CMakeLists.txt b/samples/cpp/common/format_reader/CMakeLists.txt 47diff --git a/samples/cpp/common/format_reader/CMakeLists.txt b/samples/cpp/common/format_reader/CMakeLists.txt
51index 44d94e8a27..208edd8e4e 100644 48index 7c07bf07dbb..4cd566749e5 100644
52--- a/samples/cpp/common/format_reader/CMakeLists.txt 49--- a/samples/cpp/common/format_reader/CMakeLists.txt
53+++ b/samples/cpp/common/format_reader/CMakeLists.txt 50+++ b/samples/cpp/common/format_reader/CMakeLists.txt
54@@ -44,5 +44,5 @@ endif() 51@@ -44,5 +44,5 @@ endif()
@@ -58,32 +55,11 @@ index 44d94e8a27..208edd8e4e 100644
58- LIBRARY DESTINATION samples_bin/ COMPONENT samples_bin EXCLUDE_FROM_ALL 55- LIBRARY DESTINATION samples_bin/ COMPONENT samples_bin EXCLUDE_FROM_ALL
59+ LIBRARY DESTINATION ${IE_CPACK_LIBRARY_PATH} COMPONENT samples_bin 56+ LIBRARY DESTINATION ${IE_CPACK_LIBRARY_PATH} COMPONENT samples_bin
60 ) 57 )
61diff --git a/src/plugins/intel_gpu/include/va/va.h b/src/plugins/intel_gpu/include/va/va.h
62deleted file mode 100644
63index 5c8a5c6f6e..0000000000
64--- a/src/plugins/intel_gpu/include/va/va.h
65+++ /dev/null
66@@ -1,6 +0,0 @@
67-// Copyright (C) 2018-2022 Intel Corporation
68-// SPDX-License-Identifier: Apache-2.0
69-//
70-
71-typedef cl_uint VASurfaceID;
72-typedef void* VADisplay;
73diff --git a/thirdparty/CMakeLists.txt b/thirdparty/CMakeLists.txt 58diff --git a/thirdparty/CMakeLists.txt b/thirdparty/CMakeLists.txt
74index 98067991a7..bb19b592ee 100644 59index cf2863438c7..3ec5c5ed86b 100644
75--- a/thirdparty/CMakeLists.txt 60--- a/thirdparty/CMakeLists.txt
76+++ b/thirdparty/CMakeLists.txt 61+++ b/thirdparty/CMakeLists.txt
77@@ -20,7 +20,7 @@ if(ENABLE_SAMPLES OR ENABLE_TESTS) 62@@ -268,11 +268,11 @@ endif()
78 endif()
79
80 if(ENABLE_INTEL_GPU)
81- add_subdirectory(ocl)
82+ #add_subdirectory(ocl)
83 endif()
84
85 add_subdirectory(xbyak EXCLUDE_FROM_ALL)
86@@ -187,11 +187,11 @@ endif()
87 63
88 if(ENABLE_SAMPLES OR ENABLE_COMPILE_TOOL OR ENABLE_TESTS) 64 if(ENABLE_SAMPLES OR ENABLE_COMPILE_TOOL OR ENABLE_TESTS)
89 if(LINUX) 65 if(LINUX)
@@ -100,7 +76,7 @@ index 98067991a7..bb19b592ee 100644
100 find_package(gflags QUIET OPTIONAL_COMPONENTS ${gflag_component}) 76 find_package(gflags QUIET OPTIONAL_COMPONENTS ${gflag_component})
101 endif() 77 endif()
102 78
103@@ -248,7 +248,7 @@ endif() 79@@ -329,7 +329,7 @@ endif()
104 80
105 if(ENABLE_OV_PADDLE_FRONTEND OR ENABLE_OV_ONNX_FRONTEND OR ENABLE_OV_TF_FRONTEND) 81 if(ENABLE_OV_PADDLE_FRONTEND OR ENABLE_OV_ONNX_FRONTEND OR ENABLE_OV_TF_FRONTEND)
106 if(ENABLE_SYSTEM_PROTOBUF) 82 if(ENABLE_SYSTEM_PROTOBUF)
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2022.3.0.bb b/dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2022.3.0.bb
index 2e28ae8f..b1417c17 100644
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2022.3.0.bb
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2022.3.0.bb
@@ -5,8 +5,8 @@ deep learning models through a high-level C++ Inference Engine API \
5integrated with application logic." 5integrated with application logic."
6 6
7SRC_URI = "git://github.com/openvinotoolkit/openvino.git;protocol=https;branch=releases/2022/3;lfs=0 \ 7SRC_URI = "git://github.com/openvinotoolkit/openvino.git;protocol=https;branch=releases/2022/3;lfs=0 \
8 https://storage.openvinotoolkit.org/dependencies/myriad/firmware_usb-ma2x8x_20221129_35.zip;name=usb_ma2x8x \ 8 https://storage.openvinotoolkit.org/dependencies/myriad/firmware_usb-ma2x8x_20230121_38.zip;name=usb_ma2x8x \
9 https://storage.openvinotoolkit.org/dependencies/myriad/firmware_pcie-ma2x8x_20221129_35.zip;name=pcie_ma2x8x \ 9 https://storage.openvinotoolkit.org/dependencies/myriad/firmware_pcie-ma2x8x_20230121_38.zip;name=pcie_ma2x8x \
10 git://github.com/openvinotoolkit/oneDNN.git;protocol=https;destsuffix=git/src/plugins/intel_cpu/thirdparty/onednn;name=mkl;nobranch=1 \ 10 git://github.com/openvinotoolkit/oneDNN.git;protocol=https;destsuffix=git/src/plugins/intel_cpu/thirdparty/onednn;name=mkl;nobranch=1 \
11 git://github.com/oneapi-src/oneDNN.git;protocol=https;destsuffix=git/src/plugins/intel_gpu/thirdparty/onednn_gpu;name=onednn;nobranch=1 \ 11 git://github.com/oneapi-src/oneDNN.git;protocol=https;destsuffix=git/src/plugins/intel_gpu/thirdparty/onednn_gpu;name=onednn;nobranch=1 \
12 git://github.com/herumi/xbyak.git;protocol=https;destsuffix=git/thirdparty/xbyak;name=xbyak;branch=master \ 12 git://github.com/herumi/xbyak.git;protocol=https;destsuffix=git/thirdparty/xbyak;name=xbyak;branch=master \
@@ -16,15 +16,15 @@ SRC_URI = "git://github.com/openvinotoolkit/openvino.git;protocol=https;branch=r
16 file://cython-cmake.patch \ 16 file://cython-cmake.patch \
17 " 17 "
18 18
19SRCREV = "9752fafe8ebf7e30dfea7edd447ff3bf0ac1d01d" 19SRCREV = "0a5ca5375265f0f12cdaee68574030408dd1c352"
20SRCREV_mkl = "44de3c3698b687c26e487fc8f0213fa487e8fe2c" 20SRCREV_mkl = "44de3c3698b687c26e487fc8f0213fa487e8fe2c"
21SRCREV_onednn = "fbec3e25a559ee252022ae066817b204e106a6ba" 21SRCREV_onednn = "fbec3e25a559ee252022ae066817b204e106a6ba"
22SRCREV_xbyak = "f8ea5c28dfcdc98585881d0ca9e499580ca077ae" 22SRCREV_xbyak = "f8ea5c28dfcdc98585881d0ca9e499580ca077ae"
23SRCREV_json = "bc889afb4c5bf1c0d8ee29ef35eaaf4c8bef8a5d" 23SRCREV_json = "bc889afb4c5bf1c0d8ee29ef35eaaf4c8bef8a5d"
24SRCREV_ade = "58b2595a1a95cc807be8bf6222f266a9a1f393a9" 24SRCREV_ade = "58b2595a1a95cc807be8bf6222f266a9a1f393a9"
25 25
26SRC_URI[usb_ma2x8x.sha256sum] = "1ca3566d294c8d269f3a0ad2f5699e9dbb2679a24a455b2cc343612303d867bd" 26SRC_URI[usb_ma2x8x.sha256sum] = "f7351b2e26f25d652a0539f6ace5797d7700735d52479c3e6ef354c236abbd3a"
27SRC_URI[pcie_ma2x8x.sha256sum] = "5667eb028290fbec92220031590ba5f87774a7b638b13178e0dcf8447a4ee8ca" 27SRC_URI[pcie_ma2x8x.sha256sum] = "439219aeac010f8b85f19838420e9a247f2cdf23a6d00e7727cf92d96dbdaeeb"
28 28
29LICENSE = "Apache-2.0 & MIT & BSD-3-Clause" 29LICENSE = "Apache-2.0 & MIT & BSD-3-Clause"
30LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327 \ 30LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327 \
@@ -75,7 +75,7 @@ COMPATIBLE_HOST = '(x86_64).*-linux'
75COMPATIBLE_HOST:libc-musl = "null" 75COMPATIBLE_HOST:libc-musl = "null"
76 76
77PACKAGECONFIG ?= "vpu opencl" 77PACKAGECONFIG ?= "vpu opencl"
78PACKAGECONFIG[opencl] = "-DENABLE_INTEL_GPU=TRUE -DOpenCL_INCLUDE_DIR=${STAGING_INCDIR} -DOpenCL_LIBRARY=${STAGING_LIBDIR}/libOpenCL.so, -DENABLE_INTEL_GPU=FALSE, ocl-icd opencl-headers opencl-clhpp libva," 78PACKAGECONFIG[opencl] = "-DENABLE_INTEL_GPU=TRUE, -DENABLE_INTEL_GPU=FALSE, ocl-icd opencl-headers opencl-clhpp,"
79PACKAGECONFIG[python3] = "-DENABLE_PYTHON=ON -DPYTHON_LIBRARY=${PYTHON_LIBRARY} -DPYTHON_INCLUDE_DIR=${PYTHON_INCLUDE_DIR}, -DENABLE_PYTHON=OFF, python3-cython-native patchelf-native, python3 python3-numpy python3-opencv python3-progress python3-cython" 79PACKAGECONFIG[python3] = "-DENABLE_PYTHON=ON -DPYTHON_LIBRARY=${PYTHON_LIBRARY} -DPYTHON_INCLUDE_DIR=${PYTHON_INCLUDE_DIR}, -DENABLE_PYTHON=OFF, python3-cython-native patchelf-native, python3 python3-numpy python3-opencv python3-progress python3-cython"
80PACKAGECONFIG[vpu] = "-DENABLE_INTEL_MYRIAD=ON -DVPU_FIRMWARE_USB-MA2X8X_FILE=../usb-ma2x8x.mvcmd -DVPU_FIRMWARE_PCIE-MA2X8X_FILE=../pcie-ma2x8x.mvcmd,-DENABLE_INTEL_MYRIAD=OFF,,${PN}-vpu-firmware" 80PACKAGECONFIG[vpu] = "-DENABLE_INTEL_MYRIAD=ON -DVPU_FIRMWARE_USB-MA2X8X_FILE=../usb-ma2x8x.mvcmd -DVPU_FIRMWARE_PCIE-MA2X8X_FILE=../pcie-ma2x8x.mvcmd,-DENABLE_INTEL_MYRIAD=OFF,,${PN}-vpu-firmware"
81PACKAGECONFIG[verbose] = "-DVERBOSE_BUILD=1,-DVERBOSE_BUILD=0" 81PACKAGECONFIG[verbose] = "-DVERBOSE_BUILD=1,-DVERBOSE_BUILD=0"