summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-support/opencv
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2021-07-14 01:06:36 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2021-07-21 00:06:57 +0800
commit0c37f3522f5a9fa07f5d9503744d70257bf5b29c (patch)
treed81226651efba42ed3dc44e1501197b3b73436a7 /dynamic-layers/openembedded-layer/recipes-support/opencv
parent94c097a82cf9167fa567c2af80d5e39a3fbbc11f (diff)
downloadmeta-intel-0c37f3522f5a9fa07f5d9503744d70257bf5b29c.tar.gz
openvino-inference-engine: fix inference engine cmake config
When included in a project using find_package, it goes and looks for headers and cmake module at an incorrect path. Make sure that we are able to locate the headers and cmake module file. Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-support/opencv')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-InferenceEngineConfig.cmake-set-the-right-paths.patch50
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2021.3.bb1
2 files changed, 51 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-InferenceEngineConfig.cmake-set-the-right-paths.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-InferenceEngineConfig.cmake-set-the-right-paths.patch
new file mode 100644
index 00000000..31a7f7ff
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-InferenceEngineConfig.cmake-set-the-right-paths.patch
@@ -0,0 +1,50 @@
1From 13a9e6fbe3e62720d088e750de73483f2b74a855 Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Wed, 14 Jul 2021 00:55:31 +0800
4Subject: [PATCH] InferenceEngineConfig.cmake: set the right paths
5
6Make sure that the projects using cmake to locate the libraries
7are able to do so.
8
9Upstream-Status: Inappropriate
10
11Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
12---
13 .../cmake/templates/InferenceEngineConfig.cmake.in | 8 ++++----
14 1 file changed, 4 insertions(+), 4 deletions(-)
15
16diff --git a/inference-engine/cmake/templates/InferenceEngineConfig.cmake.in b/inference-engine/cmake/templates/InferenceEngineConfig.cmake.in
17index 5ede817bbf..83d258834b 100644
18--- a/inference-engine/cmake/templates/InferenceEngineConfig.cmake.in
19+++ b/inference-engine/cmake/templates/InferenceEngineConfig.cmake.in
20@@ -74,7 +74,7 @@ else()
21 ext_message(FATAL_ERROR "inference_engine root directory is not found")
22 endif()
23
24- find_path(IE_INCLUDE_DIR inference_engine.hpp "${IE_ROOT_DIR}/include" NO_DEFAULT_PATH)
25+ find_path(IE_INCLUDE_DIR inference_engine.hpp "${IE_ROOT_DIR}/include")
26
27 set(IE_LIB_DIR "${IE_ROOT_DIR}/lib/${_ARCH}")
28 set(IE_LIB_REL_DIR "${IE_LIB_DIR}/Release")
29@@ -89,8 +89,8 @@ else()
30 find_library(IE_RELEASE_LIBRARY inference_engine@IE_RELEASE_POSTFIX_MAC@ "${IE_LIB_DIR}" NO_DEFAULT_PATH)
31 find_library(IE_C_API_RELEASE_LIBRARY inference_engine_c_api@IE_RELEASE_POSTFIX_MAC@ "${IE_LIB_DIR}" NO_DEFAULT_PATH)
32 else()
33- find_library(IE_RELEASE_LIBRARY inference_engine@IE_RELEASE_POSTFIX_LIN@ "${IE_LIB_DIR}" NO_DEFAULT_PATH)
34- find_library(IE_C_API_RELEASE_LIBRARY inference_engine_c_api@IE_RELEASE_POSTFIX_LIN@ "${IE_LIB_DIR}" NO_DEFAULT_PATH)
35+ find_library(IE_RELEASE_LIBRARY inference_engine@IE_RELEASE_POSTFIX_LIN@ "${IE_LIB_DIR}")
36+ find_library(IE_C_API_RELEASE_LIBRARY inference_engine_c_api@IE_RELEASE_POSTFIX_LIN@ "${IE_LIB_DIR}")
37 endif()
38
39 find_package_handle_standard_args( InferenceEngine
40@@ -163,6 +163,6 @@ else()
41 IE::inference_engine_c_api)
42
43 set(IE_EXTERNAL_DIR "${IE_ROOT_DIR}/external")
44- include("${IE_ROOT_DIR}/share/ie_parallel.cmake")
45+ include("$ENV{PKG_CONFIG_SYSROOT_DIR}@CMAKE_INSTALL_PREFIX@/@CMAKE_INSTALL_LIBDIR@/cmake/InferenceEngine/ie_parallel.cmake")
46 endif()
47 endif()
48--
492.32.0
50
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2021.3.bb b/dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2021.3.bb
index 2d8c7b59..19da3e1b 100644
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2021.3.bb
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2021.3.bb
@@ -14,6 +14,7 @@ SRC_URI = "git://github.com/openvinotoolkit/openvino.git;protocol=git;branch=rel
14 file://0003-inference-engine-installation-fixes.patch \ 14 file://0003-inference-engine-installation-fixes.patch \
15 file://0001-dont-install-licenses-and-version-file.patch \ 15 file://0001-dont-install-licenses-and-version-file.patch \
16 file://0001-plugin_api-fix-build-with-gcc-11.patch \ 16 file://0001-plugin_api-fix-build-with-gcc-11.patch \
17 file://0001-InferenceEngineConfig.cmake-set-the-right-paths.patch \
17 " 18 "
18 19
19SRCREV = "c5f7ad383e654dfb4a5ac0805323cf8d43426b3f" 20SRCREV = "c5f7ad383e654dfb4a5ac0805323cf8d43426b3f"