summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2022.3.0.bb
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2022-12-29 23:30:42 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2023-01-09 17:15:31 +0800
commitb15d2fbc3399c70f4bb5e65fe24195d63e125eb1 (patch)
treef1a8670cea16be3bc11e5175091134ddaa3ad094 /dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2022.3.0.bb
parent7d7aaa0826756bd7fb22e606e6d4a53ce3709497 (diff)
downloadmeta-intel-b15d2fbc3399c70f4bb5e65fe24195d63e125eb1.tar.gz
openvino-inference-engine: upgrade 2022.2.0 -> 2022.3.0
* OpenVINO now installs libraries and headers correctly so we don't need the local patches anymore. * Switch to using pybind11 from system. json-schema-validator is no longer used and open model zoo submodule is only used when building a specific tool so these submodules have been removed. * Tweak build scripts to include Yocto specific changes. License-Update: xbyak deleted the Japaneses translation from COPYRIGHT and nlohmann_json updated copyright years. Signed-off-by: Yogesh Tyagi <yogesh.tyagi@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2022.3.0.bb')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2022.3.0.bb121
1 files changed, 121 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2022.3.0.bb b/dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2022.3.0.bb
new file mode 100644
index 00000000..f7dc5ce2
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2022.3.0.bb
@@ -0,0 +1,121 @@
1SUMMARY = "OpenVINO(TM) Toolkit - Deep Learning Deployment Toolkit"
2HOMEPAGE = "https://github.com/opencv/dldt"
3DESCRIPTION = "This toolkit allows developers to deploy pre-trained \
4deep learning models through a high-level C++ Inference Engine API \
5integrated with application logic."
6
7SRC_URI = "git://github.com/openvinotoolkit/openvino.git;protocol=https;branch=releases/2022/3;lfs=0 \
8 https://storage.openvinotoolkit.org/dependencies/myriad/firmware_usb-ma2x8x_20221129_35.zip;name=usb_ma2x8x \
9 https://storage.openvinotoolkit.org/dependencies/myriad/firmware_pcie-ma2x8x_20221129_35.zip;name=pcie_ma2x8x \
10 git://github.com/openvinotoolkit/oneDNN.git;protocol=https;destsuffix=git/src/plugins/intel_cpu/thirdparty/onednn;name=mkl;nobranch=1 \
11 git://github.com/oneapi-src/oneDNN.git;protocol=https;destsuffix=git/src/plugins/intel_gpu/thirdparty/onednn_gpu;name=onednn;nobranch=1 \
12 git://github.com/herumi/xbyak.git;protocol=https;destsuffix=git/thirdparty/xbyak;name=xbyak;branch=master \
13 git://github.com/nlohmann/json.git;protocol=https;destsuffix=git/thirdparty/json/nlohmann_json;name=json;branch=develop \
14 git://github.com/opencv/ade.git;protocol=https;destsuffix=git/thirdparty/ade;name=ade;nobranch=1 \
15 file://fix-build.patch \
16 file://cython-cmake.patch \
17 "
18
19SRCREV = "9752fafe8ebf7e30dfea7edd447ff3bf0ac1d01d"
20SRCREV_mkl = "44de3c3698b687c26e487fc8f0213fa487e8fe2c"
21SRCREV_onednn = "fbec3e25a559ee252022ae066817b204e106a6ba"
22SRCREV_xbyak = "f8ea5c28dfcdc98585881d0ca9e499580ca077ae"
23SRCREV_json = "bc889afb4c5bf1c0d8ee29ef35eaaf4c8bef8a5d"
24SRCREV_ade = "58b2595a1a95cc807be8bf6222f266a9a1f393a9"
25
26SRC_URI[usb_ma2x8x.sha256sum] = "1ca3566d294c8d269f3a0ad2f5699e9dbb2679a24a455b2cc343612303d867bd"
27SRC_URI[pcie_ma2x8x.sha256sum] = "5667eb028290fbec92220031590ba5f87774a7b638b13178e0dcf8447a4ee8ca"
28
29LICENSE = "Apache-2.0 & MIT & BSD-3-Clause"
30LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327 \
31 file://thirdparty/xbyak/COPYRIGHT;md5=3c98edfaa50a86eeaef4c6109e803f16 \
32 file://thirdparty/cnpy/LICENSE;md5=689f10b06d1ca2d4b1057e67b16cd580 \
33 file://thirdparty/json/nlohmann_json/LICENSE.MIT;md5=f969127d7b7ed0a8a63c2bbeae002588 \
34 file://thirdparty/ade/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
35 file://src/plugins/intel_cpu/thirdparty/onednn/LICENSE;md5=b48e3de3bfd47c27882a0d85b20823f5 \
36 file://src/plugins/intel_gpu/thirdparty/onednn_gpu/LICENSE;md5=b48e3de3bfd47c27882a0d85b20823f5 \
37"
38
39inherit cmake python3native pkgconfig
40
41S = "${WORKDIR}/git"
42EXTRA_OECMAKE += " \
43 -DENABLE_OPENCV=OFF \
44 -DOpenCV_DIR=${STAGING_LIBDIR}/cmake \
45 -DENABLE_INTEL_GNA=OFF \
46 -DENABLE_SYSTEM_TBB=ON \
47 -DPYTHON_EXECUTABLE=${PYTHON} \
48 -DCMAKE_BUILD_TYPE=RelWithDebInfo \
49 -DTHREADING=TBB -DTBB_DIR="${STAGING_LIBDIR}/cmake/TBB" \
50 -DENABLE_SAMPLES=ON \
51 -DTREAT_WARNING_AS_ERROR=FALSE \
52 -DENABLE_DATA=FALSE \
53 -DENABLE_SYSTEM_PUGIXML=TRUE \
54 -DENABLE_SYSTEM_PROTOBUF=TRUE \
55 -DENABLE_OV_ONNX_FRONTEND=FALSE \
56 -DUSE_BUILD_TYPE_SUBFOLDER=OFF \
57 -DENABLE_FUZZING=OFF \
58 -DENABLE_TBBBIND_2_5=OFF \
59 -DCPACK_GENERATOR=DEB \
60 "
61
62
63DEPENDS += "libusb1 \
64 opencv \
65 protobuf \
66 protobuf-native \
67 protobuf-c \
68 pugixml \
69 python3-pybind11 \
70 tbb \
71 zlib \
72 "
73
74COMPATIBLE_HOST = '(x86_64).*-linux'
75COMPATIBLE_HOST:libc-musl = "null"
76
77PACKAGECONFIG ?= "vpu opencl"
78PACKAGECONFIG[opencl] = "-DENABLE_INTEL_GPU=TRUE -DOpenCL_INCLUDE_DIR=${STAGING_INCDIR} -DOpenCL_LIBRARY=${STAGING_LIBDIR}/libOpenCL.so, -DENABLE_INTEL_GPU=FALSE, ocl-icd opencl-headers opencl-clhpp libva,"
79PACKAGECONFIG[python3] = "-DENABLE_PYTHON=ON -DPYTHON_LIBRARY=${PYTHON_LIBRARY} -DPYTHON_INCLUDE_DIR=${PYTHON_INCLUDE_DIR}, -DENABLE_PYTHON=OFF, python3-cython-native patchelf-native, python3 python3-numpy python3-opencv python3-progress python3-cython"
80PACKAGECONFIG[vpu] = "-DENABLE_INTEL_MYRIAD=ON -DVPU_FIRMWARE_USB-MA2X8X_FILE=../usb-ma2x8x.mvcmd -DVPU_FIRMWARE_PCIE-MA2X8X_FILE=../pcie-ma2x8x.mvcmd,-DENABLE_INTEL_MYRIAD=OFF,,${PN}-vpu-firmware"
81PACKAGECONFIG[verbose] = "-DVERBOSE_BUILD=1,-DVERBOSE_BUILD=0"
82
83do_configure:prepend() {
84 # Dont set PROJECT_ROOT_DIR
85 sed -i -e 's:\${OpenVINO_SOURCE_DIR}::;' ${S}/src/CMakeLists.txt
86}
87
88do_install:append() {
89 rm -rf ${D}${prefix}/install_dependencies
90 rm -rf ${D}${prefix}/setupvars.sh
91 rm -rf ${D}${datadir}/lintian
92
93 sed -i -e 's:^#include.*imp.hpp"$:#include "/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}/git/src/plugins/intel_cpu/src/nodes/proposal_imp.hpp":g;' ${B}/src/plugins/intel_cpu/cross-compiled/proposal_imp_disp.cpp
94}
95
96# Otherwise e.g. ros-openvino-toolkit-dynamic-vino-sample when using dldt-inference-engine uses dldt-inference-engine WORKDIR
97# instead of RSS
98SSTATE_SCAN_FILES:append = " *.cmake"
99
100FILES:${PN} += "\
101 ${libdir}/openvino-${PV}/lib*${SOLIBSDEV} \
102 ${libdir}/openvino-${PV}/plugins.xml \
103 ${libdir}/openvino-${PV}/cache.json \
104 "
105
106# Move inference engine samples into a separate package
107PACKAGES =+ "${PN}-samples ${PN}-vpu-firmware"
108
109FILES:${PN}-samples = "${datadir}/openvino \
110 ${bindir} \
111 ${libdir}/libformat_reader.so \
112 ${libdir}/libopencv_c_wrapper.so \
113 "
114FILES:${PN}-vpu-firmware += "${libdir}/openvino-${PV}/*.mvcmd"
115
116# Package for inference engine python API
117PACKAGES =+ "${PN}-${PYTHON_PN}"
118
119FILES:${PN}-${PYTHON_PN} = "${PYTHON_SITEPACKAGES_DIR}"
120
121UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>(\d+(\.\d+)+))"