summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-support/opencv/files
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2022-12-29 23:30:42 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2023-01-09 17:15:31 +0800
commitb15d2fbc3399c70f4bb5e65fe24195d63e125eb1 (patch)
treef1a8670cea16be3bc11e5175091134ddaa3ad094 /dynamic-layers/openembedded-layer/recipes-support/opencv/files
parent7d7aaa0826756bd7fb22e606e6d4a53ce3709497 (diff)
downloadmeta-intel-b15d2fbc3399c70f4bb5e65fe24195d63e125eb1.tar.gz
openvino-inference-engine: upgrade 2022.2.0 -> 2022.3.0
* OpenVINO now installs libraries and headers correctly so we don't need the local patches anymore. * Switch to using pybind11 from system. json-schema-validator is no longer used and open model zoo submodule is only used when building a specific tool so these submodules have been removed. * Tweak build scripts to include Yocto specific changes. License-Update: xbyak deleted the Japaneses translation from COPYRIGHT and nlohmann_json updated copyright years. Signed-off-by: Yogesh Tyagi <yogesh.tyagi@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-support/opencv/files')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-Use-system-installed-dependencies.patch196
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-Fix-installation-of-binaries-and-libraries.patch348
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0003-Fix-build-issues-due-to-gflag-and-zlib.patch40
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build.patch128
4 files changed, 128 insertions, 584 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-Use-system-installed-dependencies.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-Use-system-installed-dependencies.patch
deleted file mode 100644
index 2dde9880..00000000
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-Use-system-installed-dependencies.patch
+++ /dev/null
@@ -1,196 +0,0 @@
1From 86fc5a725883cf59086c319fca29ddb3e47fa7de Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Thu, 7 Apr 2022 21:39:26 +0800
4Subject: [PATCH 1/2] Use system installed dependencies
5
6Use the system versions of libva, ade and zlib.
7
8Upstream-Status: Inappropriate
9Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
10---
11 cmake/dependencies.cmake | 20 --------------------
12 cmake/extra_modules.cmake | 4 ++--
13 src/plugins/intel_gpu/include/va/va.h | 6 ------
14 tests/fuzz/src/CMakeLists.txt | 3 +--
15 thirdparty/CMakeLists.txt | 25 +++++++++++--------------
16 thirdparty/cnpy/CMakeLists.txt | 2 +-
17 6 files changed, 15 insertions(+), 45 deletions(-)
18 delete mode 100644 src/plugins/intel_gpu/include/va/va.h
19
20diff --git a/cmake/dependencies.cmake b/cmake/dependencies.cmake
21index 8d66a012b8..75db89b915 100644
22--- a/cmake/dependencies.cmake
23+++ b/cmake/dependencies.cmake
24@@ -27,26 +27,6 @@ get_linux_name(LINUX_OS_NAME)
25
26 if(CMAKE_CROSSCOMPILING AND CMAKE_HOST_SYSTEM_NAME MATCHES Linux AND CMAKE_HOST_SYSTEM_PROCESSOR MATCHES "amd64.*|x86_64.*|AMD64.*")
27 set(protoc_version "3.18.2")
28-
29- RESOLVE_DEPENDENCY(SYSTEM_PROTOC_ROOT
30- ARCHIVE_LIN "protoc-${protoc_version}-linux-x86_64.tar.gz"
31- TARGET_PATH "${TEMP}/protoc-${protoc_version}-linux-x86_64"
32- SHA256 "42fde2b6044c1f74c7e86d4e03b43aac87128ddf57ac6ed8c4eab7a1e21bbf21"
33- )
34- debug_message(STATUS "host protoc-${protoc_version} root path = " ${SYSTEM_PROTOC_ROOT})
35-
36- reset_deps_cache(SYSTEM_PROTOC)
37-
38- find_host_program(
39- SYSTEM_PROTOC
40- NAMES protoc
41- PATHS "${SYSTEM_PROTOC_ROOT}/bin"
42- NO_DEFAULT_PATH)
43- if(NOT SYSTEM_PROTOC)
44- message(FATAL_ERROR "[ONNX IMPORTER] Missing host protoc binary")
45- endif()
46-
47- update_deps_cache(SYSTEM_PROTOC "${SYSTEM_PROTOC}" "Path to host protoc for ONNX Importer")
48 endif()
49
50 if(ENABLE_INTEL_MYRIAD)
51diff --git a/cmake/extra_modules.cmake b/cmake/extra_modules.cmake
52index 72eed6ad3a..39e9674a11 100644
53--- a/cmake/extra_modules.cmake
54+++ b/cmake/extra_modules.cmake
55@@ -22,7 +22,7 @@ function(ie_generate_dev_package_config)
56 configure_package_config_file("${OpenVINO_SOURCE_DIR}/cmake/templates/InferenceEngineDeveloperPackageConfig.cmake.in"
57 "${CMAKE_BINARY_DIR}/InferenceEngineDeveloperPackageConfig.cmake"
58 INSTALL_DESTINATION share # not used
59- PATH_VARS "OpenVINO_SOURCE_DIR;gflags_BINARY_DIR"
60+ PATH_VARS "OpenVINO_SOURCE_DIR"
61 NO_CHECK_REQUIRED_COMPONENTS_MACRO)
62
63 configure_file("${OpenVINO_SOURCE_DIR}/cmake/templates/InferenceEngineConfig-version.cmake.in"
64@@ -53,7 +53,7 @@ function(ov_generate_dev_package_config)
65 configure_package_config_file("${OpenVINO_SOURCE_DIR}/cmake/templates/OpenVINODeveloperPackageConfig.cmake.in"
66 "${CMAKE_BINARY_DIR}/OpenVINODeveloperPackageConfig.cmake"
67 INSTALL_DESTINATION share # not used
68- PATH_VARS "OpenVINO_SOURCE_DIR;gflags_BINARY_DIR"
69+ PATH_VARS "OpenVINO_SOURCE_DIR"
70 NO_CHECK_REQUIRED_COMPONENTS_MACRO)
71
72 configure_file("${OpenVINO_SOURCE_DIR}/cmake/templates/OpenVINOConfig-version.cmake.in"
73diff --git a/src/plugins/intel_gpu/include/va/va.h b/src/plugins/intel_gpu/include/va/va.h
74deleted file mode 100644
75index 5c8a5c6f6e..0000000000
76--- a/src/plugins/intel_gpu/include/va/va.h
77+++ /dev/null
78@@ -1,6 +0,0 @@
79-// Copyright (C) 2018-2022 Intel Corporation
80-// SPDX-License-Identifier: Apache-2.0
81-//
82-
83-typedef cl_uint VASurfaceID;
84-typedef void* VADisplay;
85diff --git a/tests/fuzz/src/CMakeLists.txt b/tests/fuzz/src/CMakeLists.txt
86index 5e6b7b168e..a81c51bb77 100644
87--- a/tests/fuzz/src/CMakeLists.txt
88+++ b/tests/fuzz/src/CMakeLists.txt
89@@ -10,14 +10,13 @@ add_custom_target(fuzz)
90 FILE(GLOB tests "*-fuzzer.cc")
91
92 add_subdirectory(../../../thirdparty/cnpy ${CMAKE_CURRENT_BINARY_DIR}/cnpy)
93-add_subdirectory(../../../thirdparty/zlib ${CMAKE_CURRENT_BINARY_DIR}/zlib)
94
95 foreach(test_source ${tests})
96 get_filename_component(test_name ${test_source} NAME_WE)
97 add_fuzzer(${test_name} ${test_source})
98
99 target_link_libraries(${test_name} PRIVATE
100- openvino::runtime cnpy zlib)
101+ openvino::runtime cnpy z)
102
103 add_dependencies(fuzz ${test_name})
104
105diff --git a/thirdparty/CMakeLists.txt b/thirdparty/CMakeLists.txt
106index 38b0a5439d..4cba1588fe 100644
107--- a/thirdparty/CMakeLists.txt
108+++ b/thirdparty/CMakeLists.txt
109@@ -14,7 +14,7 @@ add_subdirectory(ittapi)
110 add_subdirectory(itt_collector EXCLUDE_FROM_ALL)
111 add_subdirectory(cnpy EXCLUDE_FROM_ALL)
112 if(ENABLE_INTEL_GPU)
113- add_subdirectory(ocl)
114+ #add_subdirectory(ocl)
115 endif()
116
117 add_subdirectory(xbyak EXCLUDE_FROM_ALL)
118@@ -72,12 +72,11 @@ endif()
119 add_library(ocv_hal INTERFACE)
120 target_include_directories(ocv_hal INTERFACE "${CMAKE_CURRENT_SOURCE_DIR}/ocv")
121
122-add_subdirectory(ade EXCLUDE_FROM_ALL)
123 add_subdirectory(fluid/modules/gapi EXCLUDE_FROM_ALL)
124-set_target_properties(ade fluid PROPERTIES FOLDER thirdparty)
125-openvino_developer_export_targets(COMPONENT openvino_common TARGETS ade fluid)
126+set_target_properties(fluid PROPERTIES FOLDER thirdparty)
127+openvino_developer_export_targets(COMPONENT openvino_common TARGETS fluid)
128+
129
130-ov_install_static_lib(ade openvino_common)
131 ov_install_static_lib(fluid openvino_common)
132
133 #
134@@ -93,8 +92,6 @@ if(gflags_FOUND)
135 set_target_properties(gflags PROPERTIES IMPORTED_GLOBAL ON)
136 message(STATUS "gflags (${gflags_VERSION}) is found at ${gflags_DIR}")
137 else()
138- add_subdirectory(gflags EXCLUDE_FROM_ALL)
139- openvino_developer_export_targets(COMPONENT openvino_common TARGETS gflags)
140 endif()
141
142 #
143@@ -119,13 +116,13 @@ if(ENABLE_OV_PADDLE_FRONTEND OR ENABLE_OV_ONNX_FRONTEND OR ENABLE_OV_TF_FRONTEND
144 set(Protobuf_DEBUG ON)
145 endif()
146 find_package(Protobuf 3.18.2 REQUIRED)
147- set(Protobuf_LITE_LIBRARIES protobuf::libprotobuf-lite)
148- set(Protobuf_LIBRARIES protobuf::libprotobuf)
149- set(SYSTEM_PROTOC protobuf::protoc)
150+ set(Protobuf_LITE_LIBRARIES protobuf::libprotobuf-lite)
151+ set(Protobuf_LIBRARIES protobuf::libprotobuf)
152+ #set(SYSTEM_PROTOC protobuf::protoc)
153 set(PROTOC_EXECUTABLE ${SYSTEM_PROTOC})
154
155 foreach(target ${SYSTEM_PROTOC} ${Protobuf_LIBRARIES} ${Protobuf_LITE_LIBRARIES})
156- set_property(TARGET ${target} PROPERTY IMPORTED_GLOBAL TRUE)
157+ #set_property(TARGET ${target} PROPERTY IMPORTED_GLOBAL TRUE)
158 endforeach()
159 else()
160 add_subdirectory(protobuf EXCLUDE_FROM_ALL)
161@@ -134,8 +131,8 @@ if(ENABLE_OV_PADDLE_FRONTEND OR ENABLE_OV_ONNX_FRONTEND OR ENABLE_OV_TF_FRONTEND
162 # forward variables used in the other places
163 set(SYSTEM_PROTOC ${SYSTEM_PROTOC} PARENT_SCOPE)
164 set(PROTOC_EXECUTABLE ${PROTOC_EXECUTABLE} PARENT_SCOPE)
165- set(Protobuf_LIBRARIES ${Protobuf_LIBRARIES} PARENT_SCOPE)
166- set(Protobuf_LITE_LIBRARIES ${Protobuf_LITE_LIBRARIES} PARENT_SCOPE)
167+ set(Protobuf_LIBRARIES ${Protobuf_LIBRARY} PARENT_SCOPE)
168+ set(Protobuf_LITE_LIBRARIES ${Protobuf_LITE_LIBRARY} PARENT_SCOPE)
169 set(Protobuf_INCLUDE_DIRS ${Protobuf_INCLUDE_DIRS} PARENT_SCOPE)
170 set(Protobuf_IN_FRONTEND ON PARENT_SCOPE)
171
172@@ -146,7 +143,7 @@ if(ENABLE_OV_PADDLE_FRONTEND OR ENABLE_OV_ONNX_FRONTEND OR ENABLE_OV_TF_FRONTEND
173 set(link_type INTERFACE)
174 endif()
175 if(CMAKE_COMPILER_IS_GNUCXX OR OV_COMPILER_IS_CLANG)
176- target_compile_options(${target} ${link_type} -Wno-undef)
177+ #target_compile_options(${target} ${link_type} -Wno-undef)
178 endif()
179 endforeach()
180 endif()
181diff --git a/thirdparty/cnpy/CMakeLists.txt b/thirdparty/cnpy/CMakeLists.txt
182index 556adb03c4..793de9845c 100644
183--- a/thirdparty/cnpy/CMakeLists.txt
184+++ b/thirdparty/cnpy/CMakeLists.txt
185@@ -13,7 +13,7 @@ if(CMAKE_COMPILER_IS_GNUCXX OR CMAKE_CXX_COMPILER_ID MATCHES "^(Apple)?Clang$")
186 PRIVATE -Wno-all)
187 endif()
188
189-target_link_libraries(${TARGET_NAME} PUBLIC zlib::zlib)
190+target_link_libraries(${TARGET_NAME} PUBLIC z)
191 target_include_directories(${TARGET_NAME} PUBLIC "${CMAKE_CURRENT_SOURCE_DIR}")
192
193 set_target_properties(${TARGET_NAME} PROPERTIES FOLDER thirdparty)
194--
1952.37.3
196
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-Fix-installation-of-binaries-and-libraries.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-Fix-installation-of-binaries-and-libraries.patch
deleted file mode 100644
index 12c8054e..00000000
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-Fix-installation-of-binaries-and-libraries.patch
+++ /dev/null
@@ -1,348 +0,0 @@
1From 3d55027cd86db299faeed0a4a97ddcec1baedd61 Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Mon, 11 Apr 2022 11:11:23 +0800
4Subject: [PATCH 2/2] Fix installation of binaries and libraries
5
6Make sure binaries are installed correctly.
7
8Upstream-Status: Inappropriate
9
10Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
11---
12 CMakeLists.txt | 2 +-
13 cmake/developer_package/frontends/frontends.cmake | 2 +-
14 cmake/developer_package/packaging.cmake | 4 ++--
15 cmake/developer_package/plugins/plugins.cmake | 2 +-
16 docs/CMakeLists.txt | 3 ++-
17 samples/CMakeLists.txt | 2 +-
18 samples/c/common/opencv_c_wrapper/CMakeLists.txt | 2 ++
19 samples/cpp/CMakeLists.txt | 2 ++
20 scripts/CMakeLists.txt | 10 +++++-----
21 src/bindings/c/src/CMakeLists.txt | 4 ++--
22 src/cmake/openvino.cmake | 12 ++++++------
23 src/common/preprocessing/CMakeLists.txt | 2 +-
24 src/core/CMakeLists.txt | 4 ++--
25 src/inference/CMakeLists.txt | 2 +-
26 .../intel_gpu/src/kernel_selector/CMakeLists.txt | 2 +-
27 src/plugins/intel_myriad/myriad_dependencies.cmake | 2 +-
28 .../intel_myriad/myriad_plugin/CMakeLists.txt | 2 +-
29 tools/CMakeLists.txt | 2 +-
30 tools/compile_tool/CMakeLists.txt | 8 ++++----
31 19 files changed, 37 insertions(+), 32 deletions(-)
32
33diff --git a/CMakeLists.txt b/CMakeLists.txt
34index f570d4246c..d20ac60749 100644
35--- a/CMakeLists.txt
36+++ b/CMakeLists.txt
37@@ -111,7 +111,7 @@ include(cmake/extra_modules.cmake)
38 add_subdirectory(docs)
39 add_subdirectory(tools)
40 add_subdirectory(scripts)
41-add_subdirectory(licensing)
42+#add_subdirectory(licensing)
43
44 #
45 # CPack
46diff --git a/cmake/developer_package/frontends/frontends.cmake b/cmake/developer_package/frontends/frontends.cmake
47index 0779ed286d..f80cb9bb79 100644
48--- a/cmake/developer_package/frontends/frontends.cmake
49+++ b/cmake/developer_package/frontends/frontends.cmake
50@@ -2,7 +2,7 @@
51 # SPDX-License-Identifier: Apache-2.0
52 #
53
54-set(FRONTEND_INSTALL_INCLUDE "runtime/include/")
55+set(FRONTEND_INSTALL_INCLUDE "include/")
56 set(FRONTEND_NAME_PREFIX "openvino_")
57 set(FRONTEND_NAME_SUFFIX "_frontend")
58
59diff --git a/cmake/developer_package/packaging.cmake b/cmake/developer_package/packaging.cmake
60index 458ddade93..626eb6548a 100644
61--- a/cmake/developer_package/packaging.cmake
62+++ b/cmake/developer_package/packaging.cmake
63@@ -20,8 +20,8 @@ function(ie_cpack_set_library_dir)
64 set(IE_CPACK_RUNTIME_PATH runtime/lib/${ARCH_FOLDER}/$<CONFIG> PARENT_SCOPE)
65 set(IE_CPACK_ARCHIVE_PATH runtime/lib/${ARCH_FOLDER}/$<CONFIG> PARENT_SCOPE)
66 else()
67- set(IE_CPACK_LIBRARY_PATH runtime/lib/${ARCH_FOLDER} PARENT_SCOPE)
68- set(IE_CPACK_RUNTIME_PATH runtime/lib/${ARCH_FOLDER} PARENT_SCOPE)
69+ set(IE_CPACK_LIBRARY_PATH ${CMAKE_INSTALL_LIBDIR} PARENT_SCOPE)
70+ set(IE_CPACK_RUNTIME_PATH ${CMAKE_INSTALL_BINDIR} PARENT_SCOPE)
71 set(IE_CPACK_ARCHIVE_PATH runtime/lib/${ARCH_FOLDER} PARENT_SCOPE)
72 endif()
73 endfunction()
74diff --git a/cmake/developer_package/plugins/plugins.cmake b/cmake/developer_package/plugins/plugins.cmake
75index b748ebddef..fe670e88bc 100644
76--- a/cmake/developer_package/plugins/plugins.cmake
77+++ b/cmake/developer_package/plugins/plugins.cmake
78@@ -139,7 +139,7 @@ function(ie_add_plugin)
79
80 if(BUILD_SHARED_LIBS)
81 install(TARGETS ${IE_PLUGIN_NAME}
82- LIBRARY DESTINATION ${IE_CPACK_RUNTIME_PATH}
83+ LIBRARY DESTINATION ${IE_CPACK_LIBRARY_PATH}
84 COMPONENT ${install_component})
85 else()
86 ov_install_static_lib(${IE_PLUGIN_NAME} ${install_component})
87diff --git a/docs/CMakeLists.txt b/docs/CMakeLists.txt
88index 86b0e8652b..4f31d3cc4b 100644
89--- a/docs/CMakeLists.txt
90+++ b/docs/CMakeLists.txt
91@@ -36,9 +36,10 @@ if(NOT ENABLE_DOCKER)
92 foreach(target openvino_template_plugin template_extension openvino_template_extension)
93 if(TARGET ${target})
94 install(TARGETS ${target}
95- LIBRARY DESTINATION ${IE_CPACK_RUNTIME_PATH}
96+ LIBRARY DESTINATION ${IE_CPACK_RUNTIME_PATH}
97 COMPONENT tests
98 EXCLUDE_FROM_ALL)
99+ install(TARGETS ${target} LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR})
100 endif()
101 endforeach()
102 endif()
103diff --git a/samples/CMakeLists.txt b/samples/CMakeLists.txt
104index 8101b5e328..6abe8c20ce 100644
105--- a/samples/CMakeLists.txt
106+++ b/samples/CMakeLists.txt
107@@ -9,7 +9,7 @@ add_subdirectory(c)
108 if(TARGET format_reader)
109 install(TARGETS format_reader
110 RUNTIME DESTINATION ${IE_CPACK_RUNTIME_PATH} COMPONENT tests EXCLUDE_FROM_ALL
111- LIBRARY DESTINATION ${IE_CPACK_LIBRARY_PATH} COMPONENT tests EXCLUDE_FROM_ALL)
112+ LIBRARY DESTINATION ${IE_CPACK_LIBRARY_PATH} COMPONENT tests)
113 endif()
114
115 openvino_developer_export_targets(COMPONENT openvino_common TARGETS format_reader ie_samples_utils)
116diff --git a/samples/c/common/opencv_c_wrapper/CMakeLists.txt b/samples/c/common/opencv_c_wrapper/CMakeLists.txt
117index 2755579a0f..4a5f5b424f 100644
118--- a/samples/c/common/opencv_c_wrapper/CMakeLists.txt
119+++ b/samples/c/common/opencv_c_wrapper/CMakeLists.txt
120@@ -34,3 +34,5 @@ install(
121 RUNTIME DESTINATION samples_bin/ COMPONENT samples_bin EXCLUDE_FROM_ALL
122 LIBRARY DESTINATION samples_bin/ COMPONENT samples_bin EXCLUDE_FROM_ALL
123 )
124+
125+install(TARGETS ${TARGET_NAME} DESTINATION ${CMAKE_INSTALL_LIBDIR})
126diff --git a/samples/cpp/CMakeLists.txt b/samples/cpp/CMakeLists.txt
127index 3628c8283a..186540940f 100644
128--- a/samples/cpp/CMakeLists.txt
129+++ b/samples/cpp/CMakeLists.txt
130@@ -258,6 +258,8 @@ macro(ie_add_sample)
131 COMPONENT samples_bin
132 EXCLUDE_FROM_ALL)
133
134+ install(TARGETS ${IE_SAMPLE_NAME} DESTINATION bin)
135+
136 # create global target with all samples / demo apps
137 if(NOT TARGET ie_samples)
138 add_custom_target(ie_samples ALL)
139diff --git a/scripts/CMakeLists.txt b/scripts/CMakeLists.txt
140index 4e9f76638f..6d8df5f0a1 100644
141--- a/scripts/CMakeLists.txt
142+++ b/scripts/CMakeLists.txt
143@@ -37,7 +37,7 @@ ie_shellcheck_process(DIRECTORY "${OpenVINO_SOURCE_DIR}"
144
145 # install setupvars
146
147-ie_cpack_add_component(setupvars REQUIRED)
148+#ie_cpack_add_component(setupvars REQUIRED)
149
150 if(UNIX)
151 set(_setupvars_file setupvars/setupvars.sh)
152@@ -54,13 +54,13 @@ elseif(WIN32)
153 file(WRITE "${_setupvars_file}" "${_setupvars_content}")
154 endif()
155 endif()
156-install(PROGRAMS "${_setupvars_file}"
157- DESTINATION .
158- COMPONENT setupvars)
159+#install(PROGRAMS "${_setupvars_file}"
160+# DESTINATION .
161+# COMPONENT setupvars)
162
163 # install install_dependencies
164
165-if(LINUX)
166+if (FALSE)
167 ie_cpack_add_component(install_dependencies REQUIRED)
168 install(DIRECTORY install_dependencies/
169 DESTINATION install_dependencies
170diff --git a/src/bindings/c/src/CMakeLists.txt b/src/bindings/c/src/CMakeLists.txt
171index 9200d0bda1..b3636e0716 100644
172--- a/src/bindings/c/src/CMakeLists.txt
173+++ b/src/bindings/c/src/CMakeLists.txt
174@@ -43,8 +43,8 @@ install(TARGETS ${TARGET_NAME} EXPORT OpenVINOTargets
175 RUNTIME DESTINATION ${IE_CPACK_RUNTIME_PATH} COMPONENT core_c
176 ARCHIVE DESTINATION ${IE_CPACK_ARCHIVE_PATH} COMPONENT core_c
177 LIBRARY DESTINATION ${IE_CPACK_LIBRARY_PATH} COMPONENT core_c
178- INCLUDES DESTINATION runtime/include/ie)
179+ INCLUDES DESTINATION include/ie)
180
181 install(DIRECTORY ${InferenceEngine_C_API_SOURCE_DIR}/include/
182- DESTINATION runtime/include/ie
183+ DESTINATION include/ie
184 COMPONENT core_c_dev)
185diff --git a/src/cmake/openvino.cmake b/src/cmake/openvino.cmake
186index 340896e3a8..9bda84fe51 100644
187--- a/src/cmake/openvino.cmake
188+++ b/src/cmake/openvino.cmake
189@@ -62,8 +62,8 @@ install(TARGETS ${TARGET_NAME} EXPORT OpenVINOTargets
190 RUNTIME DESTINATION ${IE_CPACK_RUNTIME_PATH} COMPONENT core
191 ARCHIVE DESTINATION ${IE_CPACK_ARCHIVE_PATH} COMPONENT core
192 LIBRARY DESTINATION ${IE_CPACK_LIBRARY_PATH} COMPONENT core
193- INCLUDES DESTINATION runtime/include
194- runtime/include/ie)
195+ INCLUDES DESTINATION include
196+ include/ie)
197
198 #
199 # Add openvin::dev target
200@@ -107,7 +107,7 @@ ie_cpack_add_component(core_dev REQUIRED DEPENDS core ${core_dev_components})
201
202 if(BUILD_SHARED_LIBS)
203 install(FILES $<TARGET_FILE_DIR:${TARGET_NAME}>/plugins.xml
204- DESTINATION ${IE_CPACK_RUNTIME_PATH}
205+ DESTINATION ${IE_CPACK_LIBRARY_PATH}
206 COMPONENT core)
207
208 # for InferenceEngineUnitTest
209@@ -126,7 +126,7 @@ endif()
210 install(EXPORT OpenVINOTargets
211 FILE OpenVINOTargets.cmake
212 NAMESPACE openvino::
213- DESTINATION runtime/cmake
214+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/OpenVINO
215 COMPONENT core_dev)
216
217 set(PUBLIC_HEADERS_DIR "${OpenVINO_SOURCE_DIR}/src/inference/include")
218@@ -167,10 +167,10 @@ configure_file("${OpenVINO_SOURCE_DIR}/cmake/templates/OpenVINOConfig-version.cm
219
220 install(FILES "${CMAKE_BINARY_DIR}/share/InferenceEngineConfig.cmake"
221 "${CMAKE_BINARY_DIR}/InferenceEngineConfig-version.cmake"
222- DESTINATION runtime/cmake
223+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/InferenceEngine
224 COMPONENT core_dev)
225
226 install(FILES "${CMAKE_BINARY_DIR}/share/OpenVINOConfig.cmake"
227 "${CMAKE_BINARY_DIR}/OpenVINOConfig-version.cmake"
228- DESTINATION runtime/cmake
229+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/OpenVINO
230 COMPONENT core_dev)
231diff --git a/src/common/preprocessing/CMakeLists.txt b/src/common/preprocessing/CMakeLists.txt
232index e41e286c95..11aaffca6a 100644
233--- a/src/common/preprocessing/CMakeLists.txt
234+++ b/src/common/preprocessing/CMakeLists.txt
235@@ -202,7 +202,7 @@ openvino_developer_export_targets(COMPONENT core TARGETS ${TARGET_NAME})
236
237 if(BUILD_SHARED_LIBS)
238 install(TARGETS ${TARGET_NAME}
239- LIBRARY DESTINATION ${IE_CPACK_RUNTIME_PATH} COMPONENT core)
240+ LIBRARY DESTINATION ${IE_CPACK_LIBRARY_PATH} COMPONENT core)
241 else()
242 ov_install_static_lib(${TARGET_NAME} core)
243 endif()
244diff --git a/src/core/CMakeLists.txt b/src/core/CMakeLists.txt
245index 86b195ee1c..867121ee50 100644
246--- a/src/core/CMakeLists.txt
247+++ b/src/core/CMakeLists.txt
248@@ -127,7 +127,7 @@ target_include_directories(ngraph INTERFACE $<BUILD_INTERFACE:${OV_CORE_INCLUDE_
249 #-----------------------------------------------------------------------------------------------
250
251 install(DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/include/
252- DESTINATION "runtime/include"
253+ DESTINATION "include"
254 COMPONENT core_dev
255 FILES_MATCHING
256 PATTERN "*.hpp"
257@@ -143,5 +143,5 @@ write_basic_package_version_file(${CMAKE_BINARY_DIR}/ngraphConfigVersion.cmake
258
259 install(FILES ${CMAKE_BINARY_DIR}/ngraphConfig.cmake
260 ${CMAKE_BINARY_DIR}/ngraphConfigVersion.cmake
261- DESTINATION "runtime/cmake"
262+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/ngraph
263 COMPONENT core_dev)
264diff --git a/src/inference/CMakeLists.txt b/src/inference/CMakeLists.txt
265index 737e7e0027..259d5e141d 100644
266--- a/src/inference/CMakeLists.txt
267+++ b/src/inference/CMakeLists.txt
268@@ -209,7 +209,7 @@ set_target_properties(${TARGET_NAME}_obj
269
270 openvino_developer_export_targets(COMPONENT core_legacy TARGETS ${TARGET_NAME}_plugin_api)
271
272-install(DIRECTORY "${PUBLIC_HEADERS_DIR}/" DESTINATION runtime/include
273+install(DIRECTORY "${PUBLIC_HEADERS_DIR}/" DESTINATION include
274 COMPONENT core_dev)
275
276 # Install static libraries for case BUILD_SHARED_LIBS=OFF
277diff --git a/src/plugins/intel_gpu/src/kernel_selector/CMakeLists.txt b/src/plugins/intel_gpu/src/kernel_selector/CMakeLists.txt
278index 3993bd9731..99287bad51 100644
279--- a/src/plugins/intel_gpu/src/kernel_selector/CMakeLists.txt
280+++ b/src/plugins/intel_gpu/src/kernel_selector/CMakeLists.txt
281@@ -94,7 +94,7 @@ add_custom_command(
282 COMMAND "${CMAKE_COMMAND}" -E copy_if_different ${CMAKE_CURRENT_SOURCE_DIR}/core/cache/cache.json ${TUNING_CACHE_PATH}/cache.json)
283
284 install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/core/cache/cache.json
285- DESTINATION ${IE_CPACK_RUNTIME_PATH}
286+ DESTINATION ${IE_CPACK_LIBRARY_PATH}
287 COMPONENT gpu)
288
289 ov_install_static_lib(${TARGET_NAME} gpu)
290diff --git a/src/plugins/intel_myriad/myriad_dependencies.cmake b/src/plugins/intel_myriad/myriad_dependencies.cmake
291index 480acc05d1..5849f55878 100644
292--- a/src/plugins/intel_myriad/myriad_dependencies.cmake
293+++ b/src/plugins/intel_myriad/myriad_dependencies.cmake
294@@ -80,7 +80,7 @@ foreach(firmware_name IN LISTS VPU_SUPPORTED_FIRMWARES)
295 VERBATIM)
296
297 install(FILES ${${var_name}}
298- DESTINATION ${IE_CPACK_RUNTIME_PATH}
299+ DESTINATION ${IE_CPACK_LIBRARY_PATH}
300 COMPONENT myriad)
301
302 if(ENABLE_INTEL_MYRIAD AND ENABLE_BEH_TESTS)
303diff --git a/src/plugins/intel_myriad/myriad_plugin/CMakeLists.txt b/src/plugins/intel_myriad/myriad_plugin/CMakeLists.txt
304index d8ebea0bfc..66b5a3d462 100644
305--- a/src/plugins/intel_myriad/myriad_plugin/CMakeLists.txt
306+++ b/src/plugins/intel_myriad/myriad_plugin/CMakeLists.txt
307@@ -56,6 +56,6 @@ set_target_properties(${TARGET_NAME} PROPERTIES INTERPROCEDURAL_OPTIMIZATION_REL
308
309 if(LINUX)
310 install(FILES ${mvnc_SOURCE_DIR}/src/97-myriad-usbboot.rules
311- DESTINATION install_dependencies
312+ DESTINATION ${CMAKE_INSTALL_SYSCONFDIR}/udev/rules.d
313 COMPONENT myriad)
314 endif()
315diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
316index 2fe0fd9742..234110b7d4 100644
317--- a/tools/CMakeLists.txt
318+++ b/tools/CMakeLists.txt
319@@ -20,7 +20,7 @@ endif()
320 ie_cpack_add_component(deployment_manager REQUIRED)
321
322 install(DIRECTORY deployment_manager
323- DESTINATION tools
324+ DESTINATION share/openvino/tools
325 COMPONENT deployment_manager
326 USE_SOURCE_PERMISSIONS)
327
328diff --git a/tools/compile_tool/CMakeLists.txt b/tools/compile_tool/CMakeLists.txt
329index d19eb5cc14..9fc929cbb0 100644
330--- a/tools/compile_tool/CMakeLists.txt
331+++ b/tools/compile_tool/CMakeLists.txt
332@@ -38,9 +38,9 @@ add_cpplint_target(${TARGET_NAME}_cpplint FOR_TARGETS ${TARGET_NAME})
333 ie_cpack_add_component(core_tools DEPENDS core)
334
335 install(TARGETS compile_tool
336- RUNTIME DESTINATION tools/compile_tool
337+ RUNTIME DESTINATION bin
338 COMPONENT core_tools)
339
340-install(FILES README.md
341- DESTINATION tools/compile_tool
342- COMPONENT core_tools)
343+#install(FILES README.md
344+# DESTINATION tools/compile_tool
345+# COMPONENT core_tools)
346--
3472.37.3
348
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0003-Fix-build-issues-due-to-gflag-and-zlib.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0003-Fix-build-issues-due-to-gflag-and-zlib.patch
deleted file mode 100644
index ffb0f95d..00000000
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0003-Fix-build-issues-due-to-gflag-and-zlib.patch
+++ /dev/null
@@ -1,40 +0,0 @@
1From a817386f1d0539a040fbdc02853a73bbcdddf1f1 Mon Sep 17 00:00:00 2001
2From: Yogesh Tyagi <yogesh.tyagi@intel.com>
3Date: Fri, 30 Sep 2022 20:26:04 +0800
4Subject: [PATCH] Fix build issues due to gflag and zlib
5
6Change gflag to shared as we are not building with static library.
7We are using zlib from host, so don't add zlib as third party package
8
9Upstream-Status: Inappropriate
10
11Signed-off-by: Yogesh Tyagi <yogesh.tyagi@intel.com>
12---
13 thirdparty/CMakeLists.txt | 4 ++--
14 1 file changed, 2 insertions(+), 2 deletions(-)
15
16diff --git a/thirdparty/CMakeLists.txt b/thirdparty/CMakeLists.txt
17index 4cba1588fe..f82bf3148b 100644
18--- a/thirdparty/CMakeLists.txt
19+++ b/thirdparty/CMakeLists.txt
20@@ -39,7 +39,7 @@ if(NOT CMAKE_CROSSCOMPILING)
21 endif()
22
23 if(NOT zlib_FOUND)
24- add_subdirectory(zlib EXCLUDE_FROM_ALL)
25+ #add_subdirectory(zlib EXCLUDE_FROM_ALL)
26 endif()
27
28 #
29@@ -85,7 +85,7 @@ ov_install_static_lib(fluid openvino_common)
30
31 if(NOT APPLE)
32 # on Apple only dynamic libraries are available
33- find_package(gflags QUIET COMPONENTS nothreads_static)
34+ find_package(gflags QUIET COMPONENTS nothreads_shared)
35 endif()
36
37 if(gflags_FOUND)
38--
392.37.3
40
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build.patch
new file mode 100644
index 00000000..07a29fe7
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build.patch
@@ -0,0 +1,128 @@
1Yocto specific tweaks to the build process:
2
3* Install python modules to site-packages.
4* Dont try to detect glibc version as that doesn't work when cross compiling.
5* Use shared protobuf and gflags libs.
6* Use system installed ocl headers.
7* We have va.h in recipe-sysroot and having a va.h here leads to failures.
8* Install sample binaries as well.
9
10Upstream-Status: Inappropriate
11Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
12
13diff --git a/cmake/developer_package/packaging/debian/debian.cmake b/cmake/developer_package/packaging/debian/debian.cmake
14index 735160b469..26f51229e2 100644
15--- a/cmake/developer_package/packaging/debian/debian.cmake
16+++ b/cmake/developer_package/packaging/debian/debian.cmake
17@@ -31,7 +31,11 @@ macro(ov_debian_cpack_set_dirs)
18 set(OV_CPACK_NGRAPH_CMAKEDIR ${OV_CPACK_RUNTIMEDIR}/cmake/ngraph${OpenVINO_VERSION})
19 set(OV_CPACK_OPENVINO_CMAKEDIR ${OV_CPACK_RUNTIMEDIR}/cmake/openvino${OpenVINO_VERSION})
20 set(OV_CPACK_DOCDIR ${CMAKE_INSTALL_DATADIR}/doc/openvino-${OpenVINO_VERSION})
21- set(OV_CPACK_PYTHONDIR lib/python3/dist-packages)
22+
23+ ov_get_pyversion(pyversion)
24+ if(pyversion)
25+ set(OV_CPACK_PYTHONDIR lib/${pyversion}/site-packages)
26+ endif()
27
28 # non-native stuff
29 set(OV_CPACK_SHAREDIR ${CMAKE_INSTALL_DATADIR}/openvino) # internal
30diff --git a/cmake/developer_package/target_flags.cmake b/cmake/developer_package/target_flags.cmake
31index 62831fffab..b123bbad75 100644
32--- a/cmake/developer_package/target_flags.cmake
33+++ b/cmake/developer_package/target_flags.cmake
34@@ -123,4 +123,4 @@ function(ov_glibc_version)
35 endif()
36 endfunction()
37
38-ov_glibc_version()
39+#ov_glibc_version()
40diff --git a/samples/c/common/opencv_c_wrapper/CMakeLists.txt b/samples/c/common/opencv_c_wrapper/CMakeLists.txt
41index f27e934793..da51c56cf3 100644
42--- a/samples/c/common/opencv_c_wrapper/CMakeLists.txt
43+++ b/samples/c/common/opencv_c_wrapper/CMakeLists.txt
44@@ -32,5 +32,4 @@ endif()
45 install(
46 TARGETS ${TARGET_NAME}
47 RUNTIME DESTINATION samples_bin/ COMPONENT samples_bin EXCLUDE_FROM_ALL
48- LIBRARY DESTINATION samples_bin/ COMPONENT samples_bin EXCLUDE_FROM_ALL
49-)
50+ LIBRARY DESTINATION ${IE_CPACK_LIBRARY_PATH} COMPONENT samples_bin)
51diff --git a/samples/cpp/CMakeLists.txt b/samples/cpp/CMakeLists.txt
52index 3a10819c47..d82262a714 100644
53--- a/samples/cpp/CMakeLists.txt
54+++ b/samples/cpp/CMakeLists.txt
55@@ -230,9 +230,8 @@ macro(ie_add_sample)
56 target_link_libraries(${IE_SAMPLE_NAME} PRIVATE ${ov_link_libraries} Threads::Threads ${IE_SAMPLE_DEPENDENCIES})
57
58 install(TARGETS ${IE_SAMPLE_NAME}
59- RUNTIME DESTINATION samples_bin/
60- COMPONENT samples_bin
61- EXCLUDE_FROM_ALL)
62+ DESTINATION ${CMAKE_INSTALL_BINDIR}
63+ COMPONENT samples_bin)
64
65 # create global target with all samples / demo apps
66 if(NOT TARGET ie_samples)
67diff --git a/samples/cpp/common/format_reader/CMakeLists.txt b/samples/cpp/common/format_reader/CMakeLists.txt
68index 44d94e8a27..208edd8e4e 100644
69--- a/samples/cpp/common/format_reader/CMakeLists.txt
70+++ b/samples/cpp/common/format_reader/CMakeLists.txt
71@@ -44,5 +44,5 @@ endif()
72 install(
73 TARGETS ${TARGET_NAME}
74 RUNTIME DESTINATION samples_bin/ COMPONENT samples_bin EXCLUDE_FROM_ALL
75- LIBRARY DESTINATION samples_bin/ COMPONENT samples_bin EXCLUDE_FROM_ALL
76+ LIBRARY DESTINATION ${IE_CPACK_LIBRARY_PATH} COMPONENT samples_bin
77 )
78diff --git a/src/plugins/intel_gpu/include/va/va.h b/src/plugins/intel_gpu/include/va/va.h
79deleted file mode 100644
80index 5c8a5c6f6e..0000000000
81--- a/src/plugins/intel_gpu/include/va/va.h
82+++ /dev/null
83@@ -1,6 +0,0 @@
84-// Copyright (C) 2018-2022 Intel Corporation
85-// SPDX-License-Identifier: Apache-2.0
86-//
87-
88-typedef cl_uint VASurfaceID;
89-typedef void* VADisplay;
90diff --git a/thirdparty/CMakeLists.txt b/thirdparty/CMakeLists.txt
91index 98067991a7..bb19b592ee 100644
92--- a/thirdparty/CMakeLists.txt
93+++ b/thirdparty/CMakeLists.txt
94@@ -20,7 +20,7 @@ if(ENABLE_SAMPLES OR ENABLE_TESTS)
95 endif()
96
97 if(ENABLE_INTEL_GPU)
98- add_subdirectory(ocl)
99+ #add_subdirectory(ocl)
100 endif()
101
102 add_subdirectory(xbyak EXCLUDE_FROM_ALL)
103@@ -187,11 +187,11 @@ endif()
104
105 if(ENABLE_SAMPLES OR ENABLE_COMPILE_TOOL OR ENABLE_TESTS)
106 if(LINUX)
107- if(OV_OS_RHEL)
108- set(gflag_component nothreads_shared)
109- elseif(OV_OS_DEBIAN)
110- set(gflag_component nothreads_static)
111- endif()
112+ #if(OV_OS_RHEL)
113+ set(gflag_component nothreads_shared)
114+ #elseif(OV_OS_DEBIAN)
115+ #set(gflag_component nothreads_static)
116+ #endif()
117 find_package(gflags QUIET OPTIONAL_COMPONENTS ${gflag_component})
118 endif()
119
120@@ -248,7 +248,7 @@ endif()
121
122 if(ENABLE_OV_PADDLE_FRONTEND OR ENABLE_OV_ONNX_FRONTEND OR ENABLE_OV_TF_FRONTEND)
123 if(ENABLE_SYSTEM_PROTOBUF)
124- set(Protobuf_USE_STATIC_LIBS ON)
125+ #set(Protobuf_USE_STATIC_LIBS ON)
126 if(CMAKE_VERBOSE_MAKEFILE)
127 set(Protobuf_DEBUG ON)
128 endif()