summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-support/opencv/files
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2023-05-30 09:47:54 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2023-05-31 11:24:53 +0800
commit8220eccbbf5d2f9fed579726091e4ecaca3fef9f (patch)
tree3846a96c320252066fa23bce9fefece7413e9b84 /dynamic-layers/openembedded-layer/recipes-support/opencv/files
parentc8fc88b7ed082706af30aac7d4cf4e7201f62542 (diff)
downloadmeta-intel-8220eccbbf5d2f9fed579726091e4ecaca3fef9f.tar.gz
openvino-inference-engine: fix build with gcc13
Fix various issues when compiling with gcc13. Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-support/opencv/files')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/7cecc9138b89e1946e3e515727bb69b2ab119806.patch32
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build-with-gcc13.patch120
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/onednn-fix-build-with-gcc13.patch17
3 files changed, 169 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/7cecc9138b89e1946e3e515727bb69b2ab119806.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/7cecc9138b89e1946e3e515727bb69b2ab119806.patch
new file mode 100644
index 00000000..f744bd19
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/7cecc9138b89e1946e3e515727bb69b2ab119806.patch
@@ -0,0 +1,32 @@
1From 7cecc9138b89e1946e3e515727bb69b2ab119806 Mon Sep 17 00:00:00 2001
2From: Sergei Trofimovich <slyich@gmail.com>
3Date: Thu, 26 May 2022 07:11:37 +0100
4Subject: [PATCH] add missing <cstdint> header inclusion (gcc-13 support)
5
6Without the change ade build fails on this week's gcc-13 snapshot as:
7
8 [ 77%] Building CXX object sources/ade/CMakeFiles/ade.dir/source/topological_sort.cpp.o
9 In file included from ade/sources/ade/include/ade/passes/topological_sort.hpp:17,
10 from ade/sources/ade/source/topological_sort.cpp:7:
11 ade/sources/ade/include/ade/typed_graph.hpp:101:10: error: 'uintptr_t' in namespace 'std' does not name a type
12 101 | std::uintptr_t m_srcGraph;
13 | ^~~~~~~~~
14
15Upstream-Status: Backport
16Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
17---
18 sources/ade/include/ade/typed_graph.hpp | 1 +
19 1 file changed, 1 insertion(+)
20
21diff --git a/sources/ade/include/ade/typed_graph.hpp b/sources/ade/include/ade/typed_graph.hpp
22index d9676e6..8a27578 100644
23--- a/sources/ade/include/ade/typed_graph.hpp
24+++ b/sources/ade/include/ade/typed_graph.hpp
25@@ -9,6 +9,7 @@
26 #ifndef ADE_TYPED_GRAPH_HPP
27 #define ADE_TYPED_GRAPH_HPP
28
29+#include <cstdint>
30 #include <unordered_set>
31 #include <string>
32
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build-with-gcc13.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build-with-gcc13.patch
new file mode 100644
index 00000000..7089bc9c
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build-with-gcc13.patch
@@ -0,0 +1,120 @@
1From aac55921864fa91fe8e394a25fc565f28ae5fc64 Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Tue, 30 May 2023 09:31:09 +0800
4Subject: [PATCH] fix build with gcc13
5
6* Include the headers as per:
7https://gcc.gnu.org/gcc-13/porting_to.html
8
9* Remove -Werror for:
10|git/src/plugins/intel_gpu/src/kernel_selector/jitter.h:129:28: error: 'virtual kernel_selector::JitDefinitions kernel_selector::JitConstant::GetDefinitions() const' was hidden [-Werror=overloaded-virtual=]
11| 129 | virtual JitDefinitions GetDefinitions() const = 0;
12| | ^~~~~~~~~~~~~~
13
14* Fix:
15| /data/poky/build/tmp/work/x86-64-v3-poky-linux/openvino-inference-engine/2022.3.0-r0/git/src/inference/include/ie/ie_precision.hpp: In member function 'bool InferenceEngine::Precision::operator==(const InferenceEngine::Precision&) const':
16| /data/poky/build/tmp/work/x86-64-v3-poky-linux/openvino-inference-engine/2022.3.0-r0/git/src/inference/include/ie/ie_precision.hpp:153:36: error: ambiguous overload for 'operator==' (operand types are 'const InferenceEngine::Precision::ePrecision' and 'const InferenceEngine::Precision')
17| 153 | return precisionInfo.value == p && precisionInfo.bitsSize == p.precisionInfo.bitsSize &&
18| | ~~~~~~~~~~~~~~~~~~~ ^~ ~
19| | | |
20| | | const InferenceEngine::Precision
21| | const InferenceEngine::Precision::ePrecision
22| /data/poky/build/tmp/work/x86-64-v3-poky-linux/openvino-inference-engine/2022.3.0-r0/git/src/inference/include/ie/ie_precision.hpp:152:10: note: candidate: 'bool InferenceEngine::Precision::operator==(const InferenceEngine::Precision&) const' (reversed)
23| 152 | bool operator==(const Precision& p) const noexcept {
24| | ^~~~~~~~
25| /data/poky/build/tmp/work/x86-64-v3-poky-linux/openvino-inference-engine/2022.3.0-r0/git/src/inference/include/ie/ie_precision.hpp:153:36: note: candidate: 'operator==(InferenceEngine::Precision::ePrecision, InferenceEngine::Precision::ePrecision)' (built-in)
26| 153 | return precisionInfo.value == p && precisionInfo.bitsSize == p.precisionInfo.bitsSize &&
27| | ~~~~~~~~~~~~~~~~~~~~^~~~
28
29Upstream-Status: Pending
30Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
31---
32 src/common/itt/include/openvino/itt.hpp | 1 +
33 src/common/preprocessing/ie_preprocess_gapi_kernels.hpp | 1 +
34 src/common/util/include/openvino/util/file_util.hpp | 1 +
35 src/inference/include/ie/ie_precision.hpp | 2 +-
36 src/plugins/intel_gpu/CMakeLists.txt | 6 +++---
37 .../intel_gpu/include/intel_gpu/runtime/device_info.hpp | 1 +
38 6 files changed, 8 insertions(+), 4 deletions(-)
39
40diff --git a/src/common/itt/include/openvino/itt.hpp b/src/common/itt/include/openvino/itt.hpp
41index c978ca1b138..f01d59a652a 100644
42--- a/src/common/itt/include/openvino/itt.hpp
43+++ b/src/common/itt/include/openvino/itt.hpp
44@@ -8,6 +8,7 @@
45 */
46
47 #pragma once
48+#include <cstdint>
49 #include <openvino/function_name.hpp>
50 #include <openvino/util/pp.hpp>
51 #include <string>
52diff --git a/src/common/preprocessing/ie_preprocess_gapi_kernels.hpp b/src/common/preprocessing/ie_preprocess_gapi_kernels.hpp
53index dfbb182b7a0..0887cc60e34 100644
54--- a/src/common/preprocessing/ie_preprocess_gapi_kernels.hpp
55+++ b/src/common/preprocessing/ie_preprocess_gapi_kernels.hpp
56@@ -8,6 +8,7 @@
57 # error non standalone GAPI
58 # endif
59
60+#include <cstdint>
61 #include <tuple>
62
63 #include <opencv2/gapi/opencv_includes.hpp>
64diff --git a/src/common/util/include/openvino/util/file_util.hpp b/src/common/util/include/openvino/util/file_util.hpp
65index d2f2e00ff60..88e641526ab 100644
66--- a/src/common/util/include/openvino/util/file_util.hpp
67+++ b/src/common/util/include/openvino/util/file_util.hpp
68@@ -4,6 +4,7 @@
69
70 #pragma once
71
72+#include <cstdint>
73 #include <fstream>
74 #include <functional>
75 #include <string>
76diff --git a/src/inference/include/ie/ie_precision.hpp b/src/inference/include/ie/ie_precision.hpp
77index 48bdd945b13..96c29b73159 100644
78--- a/src/inference/include/ie/ie_precision.hpp
79+++ b/src/inference/include/ie/ie_precision.hpp
80@@ -149,7 +149,7 @@ public:
81 * @return `true` if values represent the same precisions, `false` otherwise
82 */
83 bool operator==(const Precision& p) const noexcept {
84- return precisionInfo.value == p && precisionInfo.bitsSize == p.precisionInfo.bitsSize &&
85+ return precisionInfo.value == p.precisionInfo.value && precisionInfo.bitsSize == p.precisionInfo.bitsSize &&
86 areSameStrings(precisionInfo.name, p.precisionInfo.name);
87 }
88
89diff --git a/src/plugins/intel_gpu/CMakeLists.txt b/src/plugins/intel_gpu/CMakeLists.txt
90index ab4d7618c30..4c93024eb3c 100644
91--- a/src/plugins/intel_gpu/CMakeLists.txt
92+++ b/src/plugins/intel_gpu/CMakeLists.txt
93@@ -34,9 +34,9 @@ set(INCLUDE_DIR "${CMAKE_CURRENT_SOURCE_DIR}/include")
94
95 add_subdirectory(thirdparty)
96
97-if(CMAKE_COMPILER_IS_GNUCXX)
98- ie_add_compiler_flags(-Werror)
99-endif()
100+#if(CMAKE_COMPILER_IS_GNUCXX)
101+# ie_add_compiler_flags(-Werror)
102+#endif()
103
104 add_subdirectory(src/runtime)
105 add_subdirectory(src/kernel_selector)
106diff --git a/src/plugins/intel_gpu/include/intel_gpu/runtime/device_info.hpp b/src/plugins/intel_gpu/include/intel_gpu/runtime/device_info.hpp
107index 0c5a7177d30..7119417185c 100644
108--- a/src/plugins/intel_gpu/include/intel_gpu/runtime/device_info.hpp
109+++ b/src/plugins/intel_gpu/include/intel_gpu/runtime/device_info.hpp
110@@ -4,6 +4,7 @@
111
112 #pragma once
113
114+#include <cstdint>
115 #include <string>
116 #include <vector>
117 #include <tuple>
118--
1192.37.3
120
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/onednn-fix-build-with-gcc13.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/onednn-fix-build-with-gcc13.patch
new file mode 100644
index 00000000..3063dc93
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/onednn-fix-build-with-gcc13.patch
@@ -0,0 +1,17 @@
1include cstdint header for gcc13
2
3Upstream-Status: Pending
4Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
5
6diff --git a/src/gpu/jit/gemm/kernel_catalog.hpp b/src/gpu/jit/gemm/kernel_catalog.hpp
7index 8e6e1f3b6..3c8e29981 100644
8--- a/src/gpu/jit/gemm/kernel_catalog.hpp
9+++ b/src/gpu/jit/gemm/kernel_catalog.hpp
10@@ -20,6 +20,7 @@
11 #include <string>
12 #include <tuple>
13 #include <vector>
14+#include <cstdint>
15
16 #include "gen_gemm_kernel_common.hpp"
17